summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-20 16:55:14 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-20 16:55:14 +0000
commitc064f85b1ee5c44c975474e6f9ac5dab91078607 (patch)
tree0a8dc371438e94584ea386578b997b42b25aa9d0 /sci-biology/blossoc
parentUse proper security terms. (diff)
downloadgentoo-2-c064f85b1ee5c44c975474e6f9ac5dab91078607.tar.gz
gentoo-2-c064f85b1ee5c44c975474e6f9ac5dab91078607.tar.bz2
gentoo-2-c064f85b1ee5c44c975474e6f9ac5dab91078607.zip
Fixing build with gcc-4.3. Thanks Sebastian Luther <SebastianLuther@gmx.de> for report and patch
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/blossoc')
-rw-r--r--sci-biology/blossoc/ChangeLog9
-rw-r--r--sci-biology/blossoc/blossoc-1.4.0.ebuild7
-rw-r--r--sci-biology/blossoc/files/blossoc-1.4.0-gcc43.patch15
3 files changed, 26 insertions, 5 deletions
diff --git a/sci-biology/blossoc/ChangeLog b/sci-biology/blossoc/ChangeLog
index d97265a52b2e..5be8ff808687 100644
--- a/sci-biology/blossoc/ChangeLog
+++ b/sci-biology/blossoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/blossoc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/blossoc/ChangeLog,v 1.3 2009/05/25 19:57:41 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/blossoc/ChangeLog,v 1.4 2010/06/20 16:55:14 xarthisius Exp $
+
+ 20 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> blossoc-1.4.0.ebuild,
+ +files/blossoc-1.4.0-gcc43.patch:
+ Fixing build with gcc-4.3. Thanks Sebastian Luther
+ <SebastianLuther@gmx.de> for report and patch
25 May 2009; Markus Meier <maekke@gentoo.org> blossoc-1.4.0.ebuild:
amd64/x86 stable, bug #269969
diff --git a/sci-biology/blossoc/blossoc-1.4.0.ebuild b/sci-biology/blossoc/blossoc-1.4.0.ebuild
index 00439ae28961..833c79d571b1 100644
--- a/sci-biology/blossoc/blossoc-1.4.0.ebuild
+++ b/sci-biology/blossoc/blossoc-1.4.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/blossoc/blossoc-1.4.0.ebuild,v 1.3 2009/05/25 19:57:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/blossoc/blossoc-1.4.0.ebuild,v 1.4 2010/06/20 16:55:14 xarthisius Exp $
EAPI="2"
-inherit autotools
+inherit autotools eutils
DESCRIPTION="A linkage disequilibrium association mapping tool"
HOMEPAGE="http://www.daimi.au.dk/~mailund/Blossoc/"
@@ -22,6 +22,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
sed -i '/TESTS += first_test.sh/ d' "${S}/Makefile.am" || die
+ epatch "${FILESDIR}"/${P}-gcc43.patch
eautoreconf
}
diff --git a/sci-biology/blossoc/files/blossoc-1.4.0-gcc43.patch b/sci-biology/blossoc/files/blossoc-1.4.0-gcc43.patch
new file mode 100644
index 000000000000..d8e354c1745f
--- /dev/null
+++ b/sci-biology/blossoc/files/blossoc-1.4.0-gcc43.patch
@@ -0,0 +1,15 @@
+Fixes build with >=GCC-4.3
+
+http://bugs.gentoo.org/show_bug.cgi?id=292949
+
+Patch written by Sebastian Luther <SebastianLuther@gmx.de>
+--- pph.cc
++++ pph.cc
+@@ -23,6 +23,7 @@
+ */
+
+ #include "pph.hh"
++#include <cstdio>
+ #include <cmath>
+ #include <snpfile/matrix.hh>
+ using namespace BiRC::SNPFile;