summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-02-14 19:50:11 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-02-14 19:50:11 +0000
commitc31e9547c0421343225d843664691c5433029c48 (patch)
tree206671245d40e17267aae17023b9a49d6a6cb536 /sci-biology/vaal
parentp.use.mask media-gfx/sanebackends v4l (diff)
downloadgentoo-2-c31e9547c0421343225d843664691c5433029c48.tar.gz
gentoo-2-c31e9547c0421343225d843664691c5433029c48.tar.bz2
gentoo-2-c31e9547c0421343225d843664691c5433029c48.zip
Apply patches, fix bug 294738 and move binaries to libexec
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/vaal')
-rw-r--r--sci-biology/vaal/ChangeLog11
-rw-r--r--sci-biology/vaal/files/vaal-1.2-as-needed.patch22
-rw-r--r--sci-biology/vaal/files/vaal-1.2-respect-flags.patch60
-rw-r--r--sci-biology/vaal/vaal-1.2-r1.ebuild (renamed from sci-biology/vaal/vaal-1.2.ebuild)12
4 files changed, 98 insertions, 7 deletions
diff --git a/sci-biology/vaal/ChangeLog b/sci-biology/vaal/ChangeLog
index bc23691ff3ec..d16a99ff8074 100644
--- a/sci-biology/vaal/ChangeLog
+++ b/sci-biology/vaal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/vaal
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/ChangeLog,v 1.3 2009/11/12 19:15:45 weaver Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/ChangeLog,v 1.4 2010/02/14 19:50:10 weaver Exp $
+
+*vaal-1.2-r1 (14 Feb 2010)
+
+ 14 Feb 2010; Andrey Kislyuk <weaver@gentoo.org>
+ +files/vaal-1.2-as-needed.patch, +files/vaal-1.2-respect-flags.patch,
+ -vaal-1.2.ebuild, +vaal-1.2-r1.ebuild:
+ Apply patches, fix bug 294738 and move binaries to libexec
12 Nov 2009; Andrey Kislyuk <weaver@gentoo.org> vaal-1.2.ebuild:
Remove hardcoded version in SRC_URI
diff --git a/sci-biology/vaal/files/vaal-1.2-as-needed.patch b/sci-biology/vaal/files/vaal-1.2-as-needed.patch
new file mode 100644
index 000000000000..31649010dbe3
--- /dev/null
+++ b/sci-biology/vaal/files/vaal-1.2-as-needed.patch
@@ -0,0 +1,22 @@
+--- VAAL.orig/MakeDepend.cc 2008-12-18 17:05:48.000000000 +0100
++++ VAAL/MakeDepend.cc 2010-02-14 13:42:23.734370178 +0100
+@@ -1195,9 +1195,6 @@
+ }
+ }
+ mf << " -L. -L$(LIB) -L$(OBJ) $(LINK_LIBS)";
+- for ( set<string>::iterator dep_iter = lib_deps.begin();
+- dep_iter != lib_deps.end(); ++dep_iter )
+- mf << " " << "$(" << *dep_iter << "_LFLAGS)";
+ for ( set<string>::iterator dep_iter = sharedlib_deps.begin();
+ dep_iter != sharedlib_deps.end(); ++dep_iter ) {
+ // Extract the symbolic name of this library from its filename.
+@@ -1208,6 +1205,9 @@
+ mf << " -l" << sharedlib_name;
+ }
+ mf << " -l" << libname;
++ for ( set<string>::iterator dep_iter = lib_deps.begin();
++ dep_iter != lib_deps.end(); ++dep_iter )
++ mf << " " << "$(" << *dep_iter << "_LFLAGS)";
+ mf << "\n\t" << "/bin/rm $(OBJ)/lib" << libname << ".a\n";
+ }
+ }
diff --git a/sci-biology/vaal/files/vaal-1.2-respect-flags.patch b/sci-biology/vaal/files/vaal-1.2-respect-flags.patch
new file mode 100644
index 000000000000..d3420556b608
--- /dev/null
+++ b/sci-biology/vaal/files/vaal-1.2-respect-flags.patch
@@ -0,0 +1,60 @@
+--- VAAL.orig/Makefile.in 2009-04-02 21:43:42.000000000 +0200
++++ VAAL/Makefile.in 2010-02-14 14:20:26.222370302 +0100
+@@ -161,12 +161,16 @@
+ COMPILER = @CC@
+ CPLUSPLUS = @CXX@
+
++CFLAGS = @CFLAGS@
++CXXFLAGS = @CXXFLAGS@
++LDFLAGS = @LDFLAGS@
++
+ # QUIET=yes causes the compiler to be less verbose about warnings.
+ QUIET = no
+
+ # DEBUG=yes forces out-of-date executables to be built with symbolic
+ # debugging information. Any other value is ignored.
+-DEBUG = yes
++DEBUG = no
+
+ # OPTIM=<compiler optimization> forces user-defined optimizations to be used,
+ # rather than the compiler-specific default.
+@@ -174,7 +178,7 @@
+ # If OPTIM=none, then no optimization is used.
+ # If unset, defaults are used.
+ # -fno-exceptions
+-OPTIM =
++OPTIM = none
+
+ # PROFILE=yes builds sampled-profiling (i.e. gprof) executables. Any other
+ # value is ignored.
+@@ -317,6 +321,7 @@
+ # Setup final compilation options:
+
+ CPP_OPTIONS = \
++ $(CXXFLAGS) \
+ $(SYS_WARN) \
+ $(SYS_OPT) \
+ $(SYS_DEBUG) \
+@@ -328,6 +333,7 @@
+ @INCLUDES@
+
+ LINK_OPTIONS = \
++ $(LDFLAGS) \
+ $(SYS_DEBUG) \
+ $(SYS_LINK) \
+ $(OMP_LINK) \
+@@ -406,12 +406,12 @@
+ $(CPLUSPLUS) $(CPPO) $(CPPC) $(SYS_LANG) $(MAKEDEPEND_OPTS) -o $(BIN)/MakeDepend $(SRC)/MakeDepend.cc
+
+ checkLock: $(SRC)/util/checkLock.cc
+- $(CPLUSPLUS) $(SRC)/util/checkLock.cc -o $(BIN)/checkLock
++ $(CPLUSPLUS) $(CXXFLAGS) $(SRC)/util/checkLock.cc $(LDFLAGS) -o $(BIN)/checkLock
+
+ random/Random.o: random/Random.cc
+ @ mkdir -p $(OBJ)/${@D}
+ cp $(SRC)/random/Random.cc $(SRC)/random/Random.c
+- $(CC) $(SYS_LANG) -c $(SRC)/random/Random.cc -w -Drandom=randomx -Dsrandom=srandomx -o $(OBJ)/random/Random.o
++ $(CC) $(CFLAGS) $(SYS_LANG) -c $(SRC)/random/Random.cc -w -Drandom=randomx -Dsrandom=srandomx -o $(OBJ)/random/Random.o
+ rm $(SRC)/random/Random.c
+
+ MemTracker.o: MemTracker.cc
diff --git a/sci-biology/vaal/vaal-1.2.ebuild b/sci-biology/vaal/vaal-1.2-r1.ebuild
index 58420917ef24..ead9c7a77f65 100644
--- a/sci-biology/vaal/vaal-1.2.ebuild
+++ b/sci-biology/vaal/vaal-1.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/vaal-1.2.ebuild,v 1.3 2009/11/12 19:15:45 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/vaal-1.2-r1.ebuild,v 1.1 2010/02/14 19:50:10 weaver Exp $
EAPI="2"
@@ -21,16 +21,18 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-gcc-x86-no-autocast.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-respect-flags.patch
)
S="${WORKDIR}/VAAL"
src_install() {
- exeinto /usr/share/${PN}/bin
+ exeinto /usr/libexec/${PN}
doexe bin/* || die
- echo "PATH=\"/usr/share/${PN}/bin\"" > "${S}/99${PN}"
+ echo "PATH=\"/usr/libexec/${PN}\"" > "${S}/99${PN}"
doenvd "${S}/99${PN}" || die
- dosym /usr/share/${PN}/bin/VAALrun /usr/bin/VAALrun || die
+ dosym /usr/libexec/${PN}/VAALrun /usr/bin/VAALrun || die
insinto /usr/share/doc/${PF}
doins "${DISTDIR}/VAAL_manual.doc"
}