summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-28 23:19:35 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-28 23:19:35 +0000
commitf1dec2d268d28d568acc3ed8c1aa73495c6a3529 (patch)
treefecfddace0bf06e234bac4ab6d560fe5d071d168 /sci-biology/velvet
parentStable arm, bug #495624 (diff)
downloadgentoo-2-f1dec2d268d28d568acc3ed8c1aa73495c6a3529.tar.gz
gentoo-2-f1dec2d268d28d568acc3ed8c1aa73495c6a3529.tar.bz2
gentoo-2-f1dec2d268d28d568acc3ed8c1aa73495c6a3529.zip
sci-biology/velvet: Import Version BUmp from sci overlay, thanks mahn for the ebuild, #495094
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/velvet')
-rw-r--r--sci-biology/velvet/ChangeLog7
-rw-r--r--sci-biology/velvet/velvet-1.2.10.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/sci-biology/velvet/ChangeLog b/sci-biology/velvet/ChangeLog
index 802a15362468..c32155ab5bcb 100644
--- a/sci-biology/velvet/ChangeLog
+++ b/sci-biology/velvet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/velvet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/velvet/ChangeLog,v 1.20 2013/03/12 12:13:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/velvet/ChangeLog,v 1.21 2013/12/28 23:19:35 jlec Exp $
+
+*velvet-1.2.10 (28 Dec 2013)
+
+ 28 Dec 2013; Justin Lecher <jlec@gentoo.org> +velvet-1.2.10.ebuild:
+ Import Version BUmp from sci overlay, thanks mahn for the ebuild, #495094
12 Mar 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop Andrey as maintainer so that bugs get assigned to sci-biology directly
diff --git a/sci-biology/velvet/velvet-1.2.10.ebuild b/sci-biology/velvet/velvet-1.2.10.ebuild
new file mode 100644
index 000000000000..47bbdb2d7b4d
--- /dev/null
+++ b/sci-biology/velvet/velvet-1.2.10.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/velvet/velvet-1.2.10.ebuild,v 1.1 2013/12/28 23:19:35 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="A sequence assembler for very short reads"
+HOMEPAGE="http://www.ebi.ac.uk/~zerbino/velvet/"
+SRC_URI="http://www.ebi.ac.uk/~zerbino/velvet/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc openmp"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ sed -i -e '/default :/ s/doc//' "${S}"/Makefile || die
+ fi
+ elog "Upstream recommendes using -O3 in CFLAGS"
+ echo
+ elog "To adjust the MAXKMERLENGTH or CATEGORIES parameters as described in the manual,"
+ elog "please set the variables VELVET_MAXKMERLENGTH or VELVET_CATEGORIES in your"
+ elog "environment or /etc/make.conf, then re-emerge the package. For example:"
+ elog " VELVET_MAXKMERLENGTH=NN emerge [options] velvet"
+ MAKEOPTS+=" -j1"
+
+ if [[ $(tc-getCC) =~ gcc ]]; then
+ local eopenmp=-fopenmp
+ elif [[ $(tc-getCC) =~ icc ]]; then
+ local eopenmp=-openmp
+ else
+ elog "Cannot detect compiler type so not setting openmp support"
+ fi
+ append-flags -fPIC ${eopenmp}
+ append-ldflags ${eopenmp}
+
+ tc-export CC
+
+ MAKE_XOPTS=(
+ CC=$(tc-getCC)
+ CFLAGS="${CFLAGS}"
+ OPT="${CFLAGS}"
+ )
+ if [[ ${VELVET_MAXKMERLENGTH} != "" ]]; then MAKE_XOPTS+=( MAXKMERLENGTH=${VELVET_MAXKMERLENGTH} ); fi
+ if [[ ${VELVET_CATEGORIES} != "" ]]; then MAKE_XOPTS+=( CATEGORIES=${VELVET_CATEGORIES} ); fi
+}
+
+src_compile() {
+ emake "${MAKE_XOPTS[@]}"
+ emake "${MAKE_XOPTS[@]}" color
+}
+
+src_test() {
+ emake "${MAKE_XOPTS[@]}" test
+}
+
+src_install() {
+ dobin velvet{g,h,g_de,h_de}
+ insinto /usr/share/${PN}
+ doins -r contrib
+ dodoc Manual.pdf CREDITS.txt ChangeLog
+}