summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-04-10 10:37:24 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-04-10 10:37:24 +0000
commit3522a7124b378ab8761d74c7cef8b0b0c9862250 (patch)
tree3454482a6c2f83bf07b90cc759831ab86fca491a /sci-biology
parentBug #174015 - clean up pidfile usage in init script. (No Bug #) - fix LDAP us... (diff)
downloadgentoo-2-3522a7124b378ab8761d74c7cef8b0b0c9862250.tar.gz
gentoo-2-3522a7124b378ab8761d74c7cef8b0b0c9862250.tar.bz2
gentoo-2-3522a7124b378ab8761d74c7cef8b0b0c9862250.zip
Adding experimental amd64-smp client.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/foldingathome/ChangeLog11
-rw-r--r--sci-biology/foldingathome/files/5.91_beta/fah-init36
-rw-r--r--sci-biology/foldingathome/files/5.91_beta/folding-conf.d18
-rw-r--r--sci-biology/foldingathome/files/5.91_beta/initfolding6
-rw-r--r--sci-biology/foldingathome/files/digest-foldingathome-5.91_beta3
-rw-r--r--sci-biology/foldingathome/foldingathome-5.91_beta.ebuild62
6 files changed, 134 insertions, 2 deletions
diff --git a/sci-biology/foldingathome/ChangeLog b/sci-biology/foldingathome/ChangeLog
index 067552b4bde2..67f48573c9e6 100644
--- a/sci-biology/foldingathome/ChangeLog
+++ b/sci-biology/foldingathome/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/foldingathome
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/ChangeLog,v 1.12 2006/11/03 02:48:57 ribosome Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/ChangeLog,v 1.13 2007/04/10 10:37:24 je_fro Exp $
+
+*foldingathome-5.91_beta (10 Apr 2007)
+
+ 10 Apr 2007; Jeff Gardner <je_fro@gentoo.org> +files/5.91_beta/fah-init,
+ +files/5.91_beta/folding-conf.d, +files/5.91_beta/initfolding,
+ +foldingathome-5.91_beta.ebuild:
+ Adding the amd64-smp client for testing. Thanks to John Gibson.
03 Nov 2006; Olivier Fisette <ribosome@gentoo.org> -files/init-5.0.2-r4,
-foldingathome-5.0.2-r4.ebuild:
diff --git a/sci-biology/foldingathome/files/5.91_beta/fah-init b/sci-biology/foldingathome/files/5.91_beta/fah-init
new file mode 100644
index 000000000000..028025e9a612
--- /dev/null
+++ b/sci-biology/foldingathome/files/5.91_beta/fah-init
@@ -0,0 +1,36 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/files/5.91_beta/fah-init,v 1.1 2007/04/10 10:37:24 je_fro Exp $
+
+opts="${opts} unitinfo"
+
+unitinfo() {
+ einfo "$(head -n1 /opt/foldingathome/amd64-smp/unitinfo.txt):"
+ sed -e '1,2d' /opt/foldingathome/amd64-smp/unitinfo.txt
+}
+
+start() {
+ ebegin "Starting Folding@Home"
+ cd /opt/foldingathome/amd64-smp
+ start-stop-daemon -v --chdir ${PWD} --chuid foldingathome --nicelevel 19 --start --background --exec ./fah5 -- ${FOLD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Folding@Home"
+ start-stop-daemon -vv --stop --user foldingathome --exec /opt/foldingathome/amd64-smp/fah5
+ cd /opt/foldingathome/amd64-smp
+ for I in FahCore*.exe; do
+ if ps ax|grep $I > /dev/null 2>&1; then
+ killall -q $I > /dev/null 2>&1
+ fi
+ done
+ sleep 1
+ if ps ax|grep '[/]opt[/]foldingathome[/]amd64-smp[/]fah5' > /dev/null 2>&1; then
+ eend 1
+ else
+ eend 0
+ fi
+}
+
diff --git a/sci-biology/foldingathome/files/5.91_beta/folding-conf.d b/sci-biology/foldingathome/files/5.91_beta/folding-conf.d
new file mode 100644
index 000000000000..bae73ef785e0
--- /dev/null
+++ b/sci-biology/foldingathome/files/5.91_beta/folding-conf.d
@@ -0,0 +1,18 @@
+# Config file for /etc/init.d/foldingathome
+#
+# The f@h client configuration can be found in /opt/foldingathome/client.cfg
+# Run /opt/foldingathome/initfolding to reconfigure that.
+#
+# Enter options here to be passed to the Folding client:
+#
+# -oneunit Instruct the client to quit following the completion of one work unit.
+# -verbosity x Sets the output level, from 1 to 9 (max). The default is 3
+# -forceasm Force core assembly optimizations to be used if available
+# -advmethods Request to be assigned any new Cores or work units.
+#
+# A full listing of options can be found here:
+# http://www.stanford.edu/group/pandegroup/folding/console-userguide.html
+# But use of other options are not recommended when using the Folding client
+# as a service.
+#
+FOLD_OPTS="-local"
diff --git a/sci-biology/foldingathome/files/5.91_beta/initfolding b/sci-biology/foldingathome/files/5.91_beta/initfolding
new file mode 100644
index 000000000000..01e9041a5a5d
--- /dev/null
+++ b/sci-biology/foldingathome/files/5.91_beta/initfolding
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+cd /opt/foldingathome/amd64-smp
+/opt/foldingathome/amd64-smp/fah5 -configonly
+/bin/chown -R foldingathome:nogroup /opt/foldingathome/amd64-smp
+
diff --git a/sci-biology/foldingathome/files/digest-foldingathome-5.91_beta b/sci-biology/foldingathome/files/digest-foldingathome-5.91_beta
new file mode 100644
index 000000000000..e53ca6e33b3f
--- /dev/null
+++ b/sci-biology/foldingathome/files/digest-foldingathome-5.91_beta
@@ -0,0 +1,3 @@
+MD5 aef7cfdb6f4462f74b8f79d41acc29fa FAH_SMP_Linux.tgz 138220
+RMD160 019bc3511a70a31bc0c67780c75be78ca2dc29b8 FAH_SMP_Linux.tgz 138220
+SHA256 af4cb6f88009378788c055112a2612f0a7bf8a93b22af68888eee660fa668040 FAH_SMP_Linux.tgz 138220
diff --git a/sci-biology/foldingathome/foldingathome-5.91_beta.ebuild b/sci-biology/foldingathome/foldingathome-5.91_beta.ebuild
new file mode 100644
index 000000000000..30ad6280315b
--- /dev/null
+++ b/sci-biology/foldingathome/foldingathome-5.91_beta.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/foldingathome-5.91_beta.ebuild,v 1.1 2007/04/10 10:37:24 je_fro Exp $
+
+# no version number on this install dir since upgrades will be using same dir
+# (data will be stored here too)
+# The clientX files from old foldingathome will remain untouched.
+I="/opt/foldingathome/amd64-smp"
+
+inherit eutils
+
+DESCRIPTION="Folding@Home is a distributed computing project for protein folding."
+HOMEPAGE="http://folding.stanford.edu/FAQ-SMP.html"
+SRC_URI="http://folding.stanford.edu/release/FAH_SMP_Linux.tgz"
+
+LICENSE="folding-at-home"
+SLOT="0"
+
+# Currently only amd64 is supported.
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=sys-apps/baselayout-1.8.0
+ >=sys-libs/glibc-2.3.0
+ app-emulation/emul-linux-x86-baselibs"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto ${I}
+ newexe ${FILESDIR}/5.91_beta/initfolding initfolding
+ doexe fah5 mpiexec
+ insinto /etc/conf.d
+ newins ${FILESDIR}/5.91_beta/folding-conf.d foldingathome
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/5.91_beta/fah-init foldingathome
+}
+
+pkg_preinst() {
+ # the bash shell is important for "su -c" in init script
+ enewuser foldingathome -1 /bin/bash /opt/foldingathome
+}
+
+pkg_postinst() {
+ chown -R foldingathome:nogroup /opt/foldingathome
+ einfo "To run Folding@home in the background at boot:"
+ einfo " rc-update add foldingathome default"
+ einfo ""
+ einfo "Please run ${I}/initfolding to configure your client"
+ einfo "and edit /etc/conf.d/foldingathome for options"
+ einfo ""
+ einfo "This experimental F@H package exists alongside your old data files"
+ einfo "in ${I}."
+ einfo ""
+}
+
+pkg_postrm() {
+ einfo "Folding@home data files were not removed."
+ einfo " Remove them manually from ${I}"
+ einfo ""
+}