summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-29 05:42:13 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-29 05:42:13 +0000
commit7a1182ad868b45969250800b1f0ed6037553f164 (patch)
treeb31a3f981c8d5c158988b00deb0e2943aa19578c /sci-biology
parentRemove broken package (Bug #346701) (diff)
downloadgentoo-2-7a1182ad868b45969250800b1f0ed6037553f164.tar.gz
gentoo-2-7a1182ad868b45969250800b1f0ed6037553f164.tar.bz2
gentoo-2-7a1182ad868b45969250800b1f0ed6037553f164.zip
Fix sed on *FLAGS from : to |, EAPI bump
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/stride/ChangeLog8
-rw-r--r--sci-biology/stride/stride-20011129-r1.ebuild17
-rw-r--r--sci-biology/stride/stride-20011129.ebuild10
3 files changed, 20 insertions, 15 deletions
diff --git a/sci-biology/stride/ChangeLog b/sci-biology/stride/ChangeLog
index 9935c2305739..5c7fea7ad1fc 100644
--- a/sci-biology/stride/ChangeLog
+++ b/sci-biology/stride/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/stride
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/stride/ChangeLog,v 1.10 2010/04/25 11:25:18 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/stride/ChangeLog,v 1.11 2011/06/29 05:42:13 jlec Exp $
+
+ 29 Jun 2011; Justin Lecher <jlec@gentoo.org> stride-20011129.ebuild,
+ stride-20011129-r1.ebuild:
+ Fix sed on *FLAGS from : to |, EAPI bump
07 Mar 2010; Justin Lecher <jlec@gentoo.org>
stride-20011129-r1.ebuild:
diff --git a/sci-biology/stride/stride-20011129-r1.ebuild b/sci-biology/stride/stride-20011129-r1.ebuild
index 75992f7db596..254f7399e461 100644
--- a/sci-biology/stride/stride-20011129-r1.ebuild
+++ b/sci-biology/stride/stride-20011129-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/stride/stride-20011129-r1.ebuild,v 1.3 2010/03/07 09:10:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/stride/stride-20011129-r1.ebuild,v 1.4 2011/06/29 05:42:13 jlec Exp $
-EAPI="2"
+EAPI=4
inherit eutils toolchain-funcs
-DESCRIPTION="A program for protein secondary structure assignment from atomic coordinates."
+DESCRIPTION="Protein secondary structure assignment from atomic coordinates"
HOMEPAGE="http://webclu.bio.wzw.tum.de/stride/"
SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/unix/${PN}/src/${PN}.tar.gz
mirror://gentoo/${PN}-20060723-update.patch.bz2"
@@ -21,14 +21,15 @@ S="${WORKDIR}"
src_prepare() {
# this patch updates the source to the most recent
# version which was kindly provided by the author
- epatch "${DISTDIR}/${PN}-20060723-update.patch.bz2"
- epatch "${FILESDIR}"/${PN}-LDFLAGS.patch
+ epatch \
+ "${DISTDIR}/${PN}-20060723-update.patch.bz2" \
+ "${FILESDIR}"/${PN}-LDFLAGS.patch
# fix makefile
- sed -e "/^CC/s:gcc -g:$(tc-getCC) ${CFLAGS}:" -i Makefile || \
+ sed -e "/^CC/s|gcc -g|$(tc-getCC) ${CFLAGS}|" -i Makefile || \
die "Failed to fix Makefile"
}
src_install() {
- dobin ${PN} || die "Failed to install stride binary"
+ dobin ${PN}
}
diff --git a/sci-biology/stride/stride-20011129.ebuild b/sci-biology/stride/stride-20011129.ebuild
index 700bb3d838f6..136c7c1e8c16 100644
--- a/sci-biology/stride/stride-20011129.ebuild
+++ b/sci-biology/stride/stride-20011129.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/stride/stride-20011129.ebuild,v 1.7 2009/11/06 02:50:45 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/stride/stride-20011129.ebuild,v 1.8 2011/06/29 05:42:13 jlec Exp $
inherit eutils toolchain-funcs
-DESCRIPTION="A program for protein secondary structure assignment from atomic coordinates."
-LICENSE="as-is"
+DESCRIPTION="Protein secondary structure assignment from atomic coordinates"
HOMEPAGE="http://webclu.bio.wzw.tum.de/stride/"
SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/unix/${PN}/src/${PN}.tar.gz
mirror://gentoo/${PN}-20060723-update.patch.bz2"
SLOT="0"
+LICENSE="as-is"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
@@ -25,7 +25,7 @@ src_unpack() {
epatch "${DISTDIR}/${PN}-20060723-update.patch.bz2"
# fix makefile
- sed -e "/^CC/s:gcc -g:$(tc-getCC) ${CFLAGS}:" -i Makefile || \
+ sed -e "/^CC/s|gcc -g|$(tc-getCC) ${CFLAGS}|" -i Makefile || \
die "Failed to fix Makefile"
}