summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-07-20 00:56:03 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2011-07-20 00:56:03 +0000
commite1c4cfd192ef7a0cd0469df5ddfe40462e3ac779 (patch)
treea73b29dd7b7362801b2f12d65314a924d82ddc07 /sci-biology
parentNew package, ebuild written by me, dependency of sci-biology/GBrowse (diff)
downloadgentoo-2-e1c4cfd192ef7a0cd0469df5ddfe40462e3ac779.tar.gz
gentoo-2-e1c4cfd192ef7a0cd0469df5ddfe40462e3ac779.tar.bz2
gentoo-2-e1c4cfd192ef7a0cd0469df5ddfe40462e3ac779.zip
Import from sci overlay, rename and rewrite; thanks to Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> and Justin Lecher <jlec@gentoo.org>
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/GBrowse/ChangeLog11
-rw-r--r--sci-biology/GBrowse/GBrowse-2.39.ebuild68
-rw-r--r--sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch72
-rw-r--r--sci-biology/GBrowse/metadata.xml13
4 files changed, 164 insertions, 0 deletions
diff --git a/sci-biology/GBrowse/ChangeLog b/sci-biology/GBrowse/ChangeLog
new file mode 100644
index 000000000000..962c42fadde1
--- /dev/null
+++ b/sci-biology/GBrowse/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-biology/GBrowse
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/GBrowse/ChangeLog,v 1.1 2011/07/20 00:56:03 weaver Exp $
+
+*GBrowse-2.39 (20 Jul 2011)
+
+ 20 Jul 2011; Andrey Kislyuk <weaver@gentoo.org> +GBrowse-2.39.ebuild,
+ +files/GBrowseInstall.pm-2.39.patch, +metadata.xml:
+ Import from sci overlay, rename and rewrite; thanks to Martin Mokrejs
+ <mmokrejs@fold.natur.cuni.cz> and Justin Lecher <jlec@gentoo.org>
+
diff --git a/sci-biology/GBrowse/GBrowse-2.39.ebuild b/sci-biology/GBrowse/GBrowse-2.39.ebuild
new file mode 100644
index 000000000000..b842940d510b
--- /dev/null
+++ b/sci-biology/GBrowse/GBrowse-2.39.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/GBrowse/GBrowse-2.39.ebuild,v 1.1 2011/07/20 00:56:03 weaver Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=LDS
+inherit perl-module webapp
+
+DESCRIPTION="Generic Model Organism Database Project - The Generic Genome Browser"
+HOMEPAGE="http://gmod.org/wiki/GBrowse"
+KEYWORDS="~amd64 ~x86"
+IUSE="-minimal mysql postgres +sqlite"
+
+CDEPEND=">=sci-biology/bioperl-1.6.9
+ >=dev-perl/Bio-Graphics-2.09
+ >=dev-perl/GD-2.07
+ >=dev-perl/CGI-Session-4.02
+ dev-perl/IO-String
+ dev-perl/JSON
+ dev-perl/libwww-perl
+ dev-perl/Statistics-Descriptive
+ !minimal? (
+ dev-perl/Bio-Das
+ >=dev-perl/Bio-SamTools-1.20
+ dev-perl/Crypt-SSLeay
+ dev-perl/DB_File-Lock
+ dev-perl/DBI
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ sqlite? ( dev-perl/DBD-SQLite )
+ dev-perl/FCGI
+ dev-perl/File-NFSLock
+ dev-perl/GD-SVG
+ dev-perl/Net-OpenID-Consumer
+ dev-perl/Net-SMTP-SSL
+ )"
+# >=dev-perl/Bio-DB-BigFile-1.00 - requires jklib to compile
+DEPEND="virtual/perl-Module-Build
+ dev-perl/Capture-Tiny
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}"/GBrowseInstall.pm-${PV}.patch )
+
+src_configure() {
+ webapp_src_preinst
+
+# myconf="--install_base=${D}/usr" or "--install_base=/opt/gbrowse"
+ myconf="--conf=/etc/gbrowse2"
+ myconf="${myconf} --htdocs=${MY_HTDOCSDIR}"
+ myconf="${myconf} --cgibin=${MY_CGIBINDIR}"
+ myconf="${myconf} --tmp=/var/tmp/gbrowse2"
+ myconf="${myconf} --persistent=/var/db/gbrowse2"
+ myconf="${myconf} --databases=/var/db/gbrowse2/databases"
+ myconf="${myconf} --installconf=no"
+ myconf="${myconf} --installetc=no"
+ perl-module_src_configure
+}
+
+src_install() {
+ dodir /var/tmp/gbrowse2
+ dodir /var/db/gbrowse2/sessions
+ dodir /var/db/gbrowse2/userdata
+ webapp_serverowned -R /var/tmp/gbrowse2 /var/db/gbrowse2
+ perl-module_src_install
+ webapp_src_install
+}
diff --git a/sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch b/sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch
new file mode 100644
index 000000000000..5aa0be9df918
--- /dev/null
+++ b/sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch
@@ -0,0 +1,72 @@
+diff -durr GBrowse-2.39-orig/install_util/GBrowseInstall.pm GBrowse-2.39/install_util/GBrowseInstall.pm
+--- GBrowse-2.39-orig/install_util/GBrowseInstall.pm 2011-07-19 20:14:52.434608020 +0000
++++ GBrowse-2.39/install_util/GBrowseInstall.pm 2011-07-19 21:02:13.685107753 +0000
+@@ -454,33 +454,33 @@
+ $gid =~ /^(\d+)$/;
+ $gid = $1;
+
+- unless (chown $uid,$gid,$tmp) {
+- $self->ownership_warning($tmp,$user);
+- }
++# unless (chown $uid,$gid,$tmp) {
++# $self->ownership_warning($tmp,$user);
++# }
+
+ my $htdocs_i = File::Spec->catfile($self->install_path->{htdocs},'i');
+ my $images = File::Spec->catfile($tmp,'images');
+ my $htdocs = $self->install_path->{htdocs};
+- chown $uid,-1,$htdocs;
++# chown $uid,-1,$htdocs;
+ {
+ local $> = $uid;
+- symlink($images,$htdocs_i); # so symlinkifowner match works!
++# symlink($images,$htdocs_i); # so symlinkifowner match works!
+ }
+- chown $>,-1,$self->install_path->{htdocs};
++# chown $>,-1,$self->install_path->{htdocs};
+
+ my $persistent = $self->install_path->{'persistent'};
+ my $sessions = File::Spec->catfile($persistent,'sessions');
+ my $userdata = File::Spec->catfile($persistent,'userdata');
+- mkpath([$sessions,$userdata],0711);
++# mkpath([$sessions,$userdata],0711);
+
+ my $databases = $self->install_path->{'databases'};
+
+- unless (chown $uid,$gid,glob(File::Spec->catfile($databases,'').'*')) {
+- $self->ownership_warning($databases,$user);
+- }
++# unless (chown $uid,$gid,glob(File::Spec->catfile($databases,'').'*')) {
++# $self->ownership_warning($databases,$user);
++# }
+
+- chmod 0755,File::Spec->catfile($self->install_path->{'etc'},'init.d','gbrowse-slave');
+- $self->fix_selinux;
++ # chmod 0755,File::Spec->catfile($self->install_path->{'etc'},'init.d','gbrowse-slave');
++ # $self->fix_selinux;
+
+ my $base = basename($self->install_path->{htdocs});
+
+@@ -489,14 +489,14 @@
+ my $metadb_script = File::Spec->catfile("bin", "gbrowse_metadb_config.pl");
+ my $perl = $self->perl;
+ my @inc = map{"-I$_"} split ':',$self->added_to_INC;
+- system $perl,@inc,$metadb_script;
+- system 'sudo','chown','-R',"$uid.$gid",$sessions,$userdata;
++# system $perl,@inc,$metadb_script;
++# system 'sudo','chown','-R',"$uid.$gid",$sessions,$userdata;
+
+- if (Module::Build->y_n(
+- "It is recommended that you restart Apache. Shall I try this for you?",'y'
+- )) {
+- system "sudo /etc/init.d/apache2 restart";
+- }
++# if (Module::Build->y_n(
++# "It is recommended that you restart Apache. Shall I try this for you?",'y'
++# )) {
++# system "sudo /etc/init.d/apache2 restart";
++# }
+
+ print STDERR "\n***INSTALLATION COMPLETE***\n";
+ print STDERR "Load http://localhost/$base for demo and documentation.\n";
+Only in GBrowse-2.39/install_util: GBrowseInstall.pm~
diff --git a/sci-biology/GBrowse/metadata.xml b/sci-biology/GBrowse/metadata.xml
new file mode 100644
index 000000000000..ba6459e35d02
--- /dev/null
+++ b/sci-biology/GBrowse/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>perl</herd>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">GBrowse</remote-id>
+ </upstream>
+</pkgmetadata>