summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-17 12:29:41 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-17 12:29:41 +0000
commitdef417e869d379afebed7269fd1ea6d4c76e4298 (patch)
treeb0c969940342488f3beb670a6ae91abddcfd6bf5 /sci-chemistry/mopac7
parentRemove qbittorrent-2.2.9 masking (diff)
downloadgentoo-2-def417e869d379afebed7269fd1ea6d4c76e4298.tar.gz
gentoo-2-def417e869d379afebed7269fd1ea6d4c76e4298.tar.bz2
gentoo-2-def417e869d379afebed7269fd1ea6d4c76e4298.zip
Version Bump, included optional build of libgmxmopac7
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/mopac7')
-rw-r--r--sci-chemistry/mopac7/ChangeLog14
-rw-r--r--sci-chemistry/mopac7/files/Makefile23
-rw-r--r--sci-chemistry/mopac7/metadata.xml3
-rw-r--r--sci-chemistry/mopac7/mopac7-1.15.ebuild78
4 files changed, 117 insertions, 1 deletions
diff --git a/sci-chemistry/mopac7/ChangeLog b/sci-chemistry/mopac7/ChangeLog
index b26a7d7d101a..707bb5d4f0cc 100644
--- a/sci-chemistry/mopac7/ChangeLog
+++ b/sci-chemistry/mopac7/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sci-chemistry/mopac7
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.20 2010/06/15 16:57:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.21 2010/06/17 12:29:41 jlec Exp $
+
+*mopac7-1.15 (17 Jun 2010)
+
+ 17 Jun 2010; Justin Lecher <jlec@gentoo.org> +mopac7-1.15.ebuild,
+ +files/Makefile, metadata.xml:
+ Version Bump, included optional build of libgmxmopac7
+
+*mopac7-1.14-r2 (16 Jun 2010)
+
+ 16 Jun 2010; Justin Lecher <jlec@gentoo.org> mopac7-1.14-r1.ebuild,
+ +mopac7-1.14-r2.ebuild:
+ gmxmopac7 support, Importing from sci overlay
15 Jun 2010; Justin Lecher <jlec@gentoo.org> mopac7-1.10-r1.ebuild,
mopac7-1.13.ebuild, mopac7-1.13-r1.ebuild:
diff --git a/sci-chemistry/mopac7/files/Makefile b/sci-chemistry/mopac7/files/Makefile
new file mode 100644
index 000000000000..50370b3c2784
--- /dev/null
+++ b/sci-chemistry/mopac7/files/Makefile
@@ -0,0 +1,23 @@
+VERSION = GENTOOVERSION
+MAJOR = 1
+
+LIBS = -lgfortran -lf2c
+
+objects := $(patsubst %.f,%.o,$(wildcard *.f))
+
+all: libgmxmopac7
+
+clean:
+ rm -f moldat.*f deriv.* mopac7*.* compfg.* dcart.*
+
+%.o: %.f
+ $(FC) $(FFLAGS) -fPIC -c $<
+
+libgmxmopac7: $(objects)
+ $(FC) -shared $(LDFLAGS) -Wl,-soname,libgmxmopac7.so.$(MAJOR) -o $@.so.$(VERSION) $^ $(LIBS)
+ ln -sf $@.so.$(VERSION) libgmxmopac7.so
+
+static: $(objects)
+ ar rcv libgmxmopac7.a *.o
+ ranlib libgmxmopac7.a
+
diff --git a/sci-chemistry/mopac7/metadata.xml b/sci-chemistry/mopac7/metadata.xml
index 9ac9ffdb3a41..e83e17cd8807 100644
--- a/sci-chemistry/mopac7/metadata.xml
+++ b/sci-chemistry/mopac7/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-chemistry</herd>
+<use>
+ <flag name="gmxmopac7">Add support library for gromacs</flag>
+</use>
</pkgmetadata>
diff --git a/sci-chemistry/mopac7/mopac7-1.15.ebuild b/sci-chemistry/mopac7/mopac7-1.15.ebuild
new file mode 100644
index 000000000000..a7d1efcce24e
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.15.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.15.ebuild,v 1.1 2010/06/17 12:29:41 jlec Exp $
+
+EAPI="3"
+
+inherit autotools fortran
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+SRC_URI="
+ http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz
+ http://wwwuser.gwdg.de/~ggroenh/qmmm/mopac/dcart.f
+ http://wwwuser.gwdg.de/~ggroenh/qmmm/mopac/gmxmop.f"
+
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gmxmopac7 static-libs"
+
+DEPEND="dev-libs/libf2c"
+RDEPEND="${DEPEND}"
+
+FORTRAN="gfortran"
+
+src_prepare() {
+ # Install the executable
+ sed -i \
+ -e "s:noinst_PROGRAMS = mopac7:bin_PROGRAMS = mopac7:g" \
+ fortran/Makefile.am \
+ || die "sed failed: install mopac7"
+ # Install the script to run the executable
+ sed -i \
+ -e "s:EXTRA_DIST = autogen.sh run_mopac7:bin_SCRIPTS = run_mopac7:g" \
+ Makefile.am \
+ || die "sed failed: install run_mopac7"
+
+ eautoreconf
+}
+
+src_configure() {
+ #set -std=legacy -fno-automatic according to
+ #http://www.bioinformatics.org/pipermail/ghemical-devel/2008-August/000763.html
+ FFLAGS="${FFLAGS} -std=legacy -fno-automatic" econf
+}
+
+src_compile() {
+ emake || die
+ if use gmxmopac7; then
+ einfo "Making mopac7 lib for gromacs"
+ mkdir "${S}"/fortran/libgmxmopac7 && cd "${S}"/fortran/libgmxmopac7
+ cp -f ../SIZES ../*.f "${FILESDIR}"/Makefile . || die
+ emake clean || die
+ cp -f "${DISTDIR}"/gmxmop.f "${DISTDIR}"/dcart.f . || die
+ sed "s:GENTOOVERSION:${PV}:g" -i Makefile
+ emake \
+ FC=${FORTRANC} || die
+ if use static-libs; then
+ emake static || die
+ fi
+ fi
+}
+
+src_install() {
+ # A correct fix would have a run_mopac7.in with @bindir@ that gets
+ # replaced by configure, and run_mopac7 added to AC_OUTPUT in configure.ac
+ sed -i "s:./fortran/mopac7:mopac7:g" run_mopac7
+
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS README ChangeLog
+ if use gmxmopac7; then
+ cd "${S}"/fortran/libgmxmopac7
+ dolib.so libgmxmopac7.so* || die
+ if use static-libs; then
+ dolib.a libgmxmopac7.a || die
+ fi
+ fi
+}