summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-16 05:36:57 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-16 05:36:57 +0000
commit3aa0183cbff930be939f2c8bfaf5f9ee925d152d (patch)
tree92316bd2231429638b2d06da6280f537568729a1 /sci-chemistry/ortep3
parentA Fortran- or C-callable, device-independent graphics package for making simp... (diff)
downloadgentoo-2-3aa0183cbff930be939f2c8bfaf5f9ee925d152d.tar.gz
gentoo-2-3aa0183cbff930be939f2c8bfaf5f9ee925d152d.tar.bz2
gentoo-2-3aa0183cbff930be939f2c8bfaf5f9ee925d152d.zip
Thermal ellipsoid plot program for crystal structure illustrations.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-chemistry/ortep3')
-rw-r--r--sci-chemistry/ortep3/ChangeLog10
-rw-r--r--sci-chemistry/ortep3/Manifest2
-rw-r--r--sci-chemistry/ortep3/files/digest-ortep3-1.0.31
-rw-r--r--sci-chemistry/ortep3/metadata.xml9
-rw-r--r--sci-chemistry/ortep3/ortep3-1.0.3.ebuild32
5 files changed, 54 insertions, 0 deletions
diff --git a/sci-chemistry/ortep3/ChangeLog b/sci-chemistry/ortep3/ChangeLog
new file mode 100644
index 000000000000..952b0826118d
--- /dev/null
+++ b/sci-chemistry/ortep3/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/ortep3
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ortep3/ChangeLog,v 1.1 2005/12/16 05:36:57 spyderous Exp $
+
+*ortep3-1.0.3 (16 Dec 2005)
+
+ 16 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>; +metadata.xml,
+ +ortep3-1.0.3.ebuild:
+ Thermal ellipsoid plot program for crystal structure illustrations.
+
diff --git a/sci-chemistry/ortep3/Manifest b/sci-chemistry/ortep3/Manifest
new file mode 100644
index 000000000000..40e40b4d5690
--- /dev/null
+++ b/sci-chemistry/ortep3/Manifest
@@ -0,0 +1,2 @@
+MD5 34cb076ea699bd80ad6d90040ed7446f files/digest-ortep3-1.0.3 52
+MD5 0ef1e78564b142e9e5482e96342460ec ortep3-1.0.3.ebuild 660
diff --git a/sci-chemistry/ortep3/files/digest-ortep3-1.0.3 b/sci-chemistry/ortep3/files/digest-ortep3-1.0.3
new file mode 100644
index 000000000000..5736181d0d97
--- /dev/null
+++ b/sci-chemistry/ortep3/files/digest-ortep3-1.0.3
@@ -0,0 +1 @@
+MD5 9af12582aa95d9cc21f18883c2afea20 ortep.f 177237
diff --git a/sci-chemistry/ortep3/metadata.xml b/sci-chemistry/ortep3/metadata.xml
new file mode 100644
index 000000000000..211b8bd0f0a4
--- /dev/null
+++ b/sci-chemistry/ortep3/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/ortep3/ortep3-1.0.3.ebuild b/sci-chemistry/ortep3/ortep3-1.0.3.ebuild
new file mode 100644
index 000000000000..4cd9dd9bfd07
--- /dev/null
+++ b/sci-chemistry/ortep3/ortep3-1.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ortep3/ortep3-1.0.3.ebuild,v 1.1 2005/12/16 05:36:57 spyderous Exp $
+
+inherit fortran
+
+FORTRAN="g77"
+DESCRIPTION="Thermal ellipsoid plot program for crystal structure illustrations"
+HOMEPAGE="http://www.ornl.gov/sci/ortep/"
+SRC_URI="ftp://ftp.ornl.gov/pub/ortep/src/ortep.f"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="sci-libs/pgplot
+ || ( x11-libs/libX11 virtual/x11 )"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}
+
+src_unpack() {
+ cp ${DISTDIR}/${A} ${S}
+}
+
+src_compile() {
+ COMMAND="${FORTRANC} -o ortep3 ${FFLAGS:- -O2} ortep.f -lpgplot -lX11"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation failed"
+}
+
+src_install() {
+ dobin ortep3
+}