summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-07-24 07:30:06 +0000
committerJustin Lecher <jlec@gentoo.org>2014-07-24 07:30:06 +0000
commit39e70fee0715caaaaec24066cffc225eef37e5ca (patch)
treeb4d3e18061d5c2f239f07138da31964ae93b60b7 /sci-chemistry
parentRevbump to fix a bug in array name expansion. Removed old (diff)
downloadgentoo-2-39e70fee0715caaaaec24066cffc225eef37e5ca.tar.gz
gentoo-2-39e70fee0715caaaaec24066cffc225eef37e5ca.tar.bz2
gentoo-2-39e70fee0715caaaaec24066cffc225eef37e5ca.zip
sci-chemistry/raster3d: Version Bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/raster3d/ChangeLog10
-rw-r--r--sci-chemistry/raster3d/metadata.xml14
-rw-r--r--sci-chemistry/raster3d/raster3d-3.0.3.ebuild107
3 files changed, 122 insertions, 9 deletions
diff --git a/sci-chemistry/raster3d/ChangeLog b/sci-chemistry/raster3d/ChangeLog
index c52d34b7f177..332e72c3e7d9 100644
--- a/sci-chemistry/raster3d/ChangeLog
+++ b/sci-chemistry/raster3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/raster3d
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/raster3d/ChangeLog,v 1.34 2012/12/14 10:16:38 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/raster3d/ChangeLog,v 1.35 2014/07/24 07:30:06 jlec Exp $
+
+*raster3d-3.0.3 (24 Jul 2014)
+
+ 24 Jul 2014; Justin Lecher <jlec@gentoo.org> +raster3d-3.0.3.ebuild,
+ metadata.xml:
+ Version Bump
14 Dec 2012; Ulrich Müller <ulm@gentoo.org> raster3d-3.0.2.ebuild:
Fix LICENSE, Artistic License, Version 2.0 according to HOMEPAGE.
diff --git a/sci-chemistry/raster3d/metadata.xml b/sci-chemistry/raster3d/metadata.xml
index ab5778df26e6..2a6e4b56f965 100644
--- a/sci-chemistry/raster3d/metadata.xml
+++ b/sci-chemistry/raster3d/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
- <upstream>
- <changelog>http://skuld.bmsc.washington.edu/raster3d/CHANGELOG</changelog>
- </upstream>
- <use>
- <flag name="gd">libgd support for PNG and JPEG output</flag>
- </use>
+ <herd>sci-chemistry</herd>
+ <upstream>
+ <changelog>http://skuld.bmsc.washington.edu/raster3d/CHANGELOG</changelog>
+ </upstream>
+ <use>
+ <flag name="gd">libgd support for PNG and JPEG output</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-chemistry/raster3d/raster3d-3.0.3.ebuild b/sci-chemistry/raster3d/raster3d-3.0.3.ebuild
new file mode 100644
index 000000000000..26167f64346d
--- /dev/null
+++ b/sci-chemistry/raster3d/raster3d-3.0.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/raster3d/raster3d-3.0.3.ebuild,v 1.1 2014/07/24 07:30:06 jlec Exp $
+
+EAPI=5
+
+inherit eutils fortran-2 flag-o-matic multilib toolchain-funcs versionator prefix
+
+MY_PN="Raster3D"
+MY_PV=$(replace_version_separator 2 -)
+MY_P="${MY_PN}_${MY_PV}"
+
+DESCRIPTION="Generation high quality raster images of proteins or other molecules"
+HOMEPAGE="http://www.bmsc.washington.edu/raster3d/raster3d.html"
+SRC_URI="http://www.bmsc.washington.edu/${PN}/${MY_P}.tar.gz -> ${MY_P}.tar"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="gd tiff"
+
+RDEPEND="
+ tiff? ( media-libs/tiff:0 )
+ gd? ( media-libs/gd[jpeg,png] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/3.0.2-as-needed.patch \
+ "${FILESDIR}"/3.0.2-gentoo-prefix.patch
+
+ sed \
+ -e "s:MYPF:${PF}:" \
+ -e "s:MYLIB:$(get_libdir):g" \
+ -i Makefile.template || \
+ die "Failed to patch makefile.template"
+
+ if ! use gd; then
+ sed \
+ -e "/GDLIBS/s:^:#:g" \
+ -e "/GDDEFS/s:^:#:g" \
+ -i Makefile.template || die
+ fi
+
+ if ! use tiff; then
+ sed \
+ -e "/TLIBS/s:^:#:g" \
+ -e "/TDEFS/s:^:#:g" \
+ -i Makefile.template || die
+ fi
+
+ if [[ $(tc-getFC) =~ gfortran ]]; then
+ append-cflags -Dgfortran
+ fi
+
+ append-fflags -ffixed-line-length-132
+
+ eprefixify Makefile.template
+ cp Makefile.template Makefile.incl || die
+}
+
+src_compile() {
+ local target
+ local i
+
+ if [[ $(tc-getFC) =~ gfortran ]]; then
+ target="linux"
+ else
+ target="linux-$(tc-getFC)"
+ fi
+
+ for i in render.o ${target} all; do
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ FFLAGS="${FFLAGS}" \
+ CC="$(tc-getCC)"\
+ FC="$(tc-getFC)" \
+ INCDIRS="-I${EPREFIX}/usr/include" \
+ LIBDIRS="-L${EPREFIX}/usr/$(get_libdir)" \
+ ${i}
+ done
+}
+
+src_install() {
+ emake prefix="${ED}"/usr \
+ bindir="${ED}"/usr/bin \
+ datadir="${ED}"/usr/share/Raster3D/materials \
+ mandir="${ED}"/usr/share/man/man1 \
+ htmldir="${ED}"/usr/share/doc/${PF}/html \
+ examdir="${ED}"/usr/share/Raster3D/examples \
+ install
+
+ dodir /etc/env.d
+ echo -e "R3D_LIB=${EPREFIX}/usr/share/${NAME}/materials" > \
+ "${ED}"/etc/env.d/10raster3d || \
+ die "Failed to install env file."
+}
+
+pkg_postinst() {
+ elog "Add following line:"
+ elog "<delegate decode=\"r3d\" command='\"render\" < \"%i\" > \"%o\"' />"
+ elog "to ${EPREFIX}/usr/$(get_libdir)/ImageMagick-6.5.8/config/delegates.xml"
+ elog "to make imagemagick use raster3d for .r3d files"
+}