summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-19 10:10:18 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-19 10:10:18 +0000
commit3e3aa096734c60f6ca5b423ae8a94b1f26422327 (patch)
treee00dfa8c26799bd9eb4f94f52fc69a7a0959e99f /sci-chemistry
parentsci-chemistry/ortep3: Remove virtual/fortran and always call fortran-2_pkg_se... (diff)
downloadgentoo-2-3e3aa096734c60f6ca5b423ae8a94b1f26422327.tar.gz
gentoo-2-3e3aa096734c60f6ca5b423ae8a94b1f26422327.tar.bz2
gentoo-2-3e3aa096734c60f6ca5b423ae8a94b1f26422327.zip
sci-chemistry/pdb2pqr: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pdb2pqr/ChangeLog7
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild10
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild4
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild10
4 files changed, 22 insertions, 9 deletions
diff --git a/sci-chemistry/pdb2pqr/ChangeLog b/sci-chemistry/pdb2pqr/ChangeLog
index 9f308555ccdd..5bbf9582a6ba 100644
--- a/sci-chemistry/pdb2pqr/ChangeLog
+++ b/sci-chemistry/pdb2pqr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/pdb2pqr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.36 2012/05/11 07:42:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.37 2012/10/19 10:10:18 jlec Exp $
+
+ 19 Oct 2012; Justin Lecher <jlec@gentoo.org> pdb2pqr-1.5.0-r2.ebuild,
+ pdb2pqr-1.7.0.ebuild, pdb2pqr-1.7.0-r2.ebuild:
+ Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
+ updated fortran-2.eclass
*pdb2pqr-1.7.0-r2 (11 May 2012)
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild
index 4ff724168839..baacac906039 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild,v 1.10 2011/06/21 16:02:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild,v 1.11 2012/10/19 10:10:18 jlec Exp $
EAPI="3"
@@ -24,7 +24,6 @@ IUSE="doc examples opal"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
RDEPEND="
- virtual/fortran
dev-python/numpy
sci-chemistry/openbabel
opal? ( dev-python/zsi )"
@@ -32,6 +31,11 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ fortran-2_pkg_setup
+ python_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.4.0-ldflags.patch
epatch "${FILESDIR}"/${PN}-1.4.0-automagic.patch
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild
index 85b3f6e4b19f..ac9f5cf46b9c 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild,v 1.1 2012/05/11 07:42:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild,v 1.2 2012/10/19 10:10:18 jlec Exp $
EAPI=4
@@ -24,7 +24,6 @@ IUSE="doc examples opal +pdb2pka"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
RDEPEND="
- virtual/fortran
dev-python/numpy
sci-chemistry/openbabel
opal? ( dev-python/zsi )
@@ -41,6 +40,7 @@ pkg_setup() {
einfo "Allow usage of ${MAXATOMS} during calculations"
fi
python_pkg_setup
+ fortran-2_pkg_setup
}
src_prepare() {
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
index 976bbb856a16..180ca27d19d3 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild,v 1.8 2011/06/21 16:02:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild,v 1.9 2012/10/19 10:10:18 jlec Exp $
EAPI="3"
@@ -24,7 +24,6 @@ IUSE="doc examples opal"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
RDEPEND="
- virtual/fortran
dev-python/numpy
sci-chemistry/openbabel
opal? ( dev-python/zsi )"
@@ -32,6 +31,11 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ fortran-2_pkg_setup
+ python_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.4.0-ldflags.patch
epatch "${FILESDIR}"/${PN}-1.4.0-automagic.patch