summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-06 23:22:51 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-06 23:22:51 +0000
commitd1ba5c34a507e35898a5a3f7faae1e5ee6492fb1 (patch)
tree7f1fb3545a15f23b77c3e360deb211623e6ea66a /sci-chemistry
parentInitial commit (diff)
downloadgentoo-2-d1ba5c34a507e35898a5a3f7faae1e5ee6492fb1.tar.gz
gentoo-2-d1ba5c34a507e35898a5a3f7faae1e5ee6492fb1.tar.bz2
gentoo-2-d1ba5c34a507e35898a5a3f7faae1e5ee6492fb1.zip
Splitted imosflm from ccp4
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/imosflm/ChangeLog10
-rw-r--r--sci-chemistry/imosflm/files/1.0.4-tk.patch50
-rw-r--r--sci-chemistry/imosflm/imosflm-1.0.4.ebuild73
-rw-r--r--sci-chemistry/imosflm/metadata.xml8
4 files changed, 141 insertions, 0 deletions
diff --git a/sci-chemistry/imosflm/ChangeLog b/sci-chemistry/imosflm/ChangeLog
new file mode 100644
index 000000000000..b16e2bae5038
--- /dev/null
+++ b/sci-chemistry/imosflm/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/imosflm
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/ChangeLog,v 1.1 2010/02/06 23:22:49 jlec Exp $
+
+*imosflm-1.0.4 (06 Feb 2010)
+
+ 06 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> +files/1.0.4-tk.patch,
+ +imosflm-1.0.4.ebuild, +metadata.xml:
+ Splitted imosflm from ccp4
+
diff --git a/sci-chemistry/imosflm/files/1.0.4-tk.patch b/sci-chemistry/imosflm/files/1.0.4-tk.patch
new file mode 100644
index 000000000000..a90175194eb4
--- /dev/null
+++ b/sci-chemistry/imosflm/files/1.0.4-tk.patch
@@ -0,0 +1,50 @@
+--- c/tkImageLoad.c 2009-08-14 21:10:19.000000000 +0200
++++ c/tkImageLoad.c.new 2009-08-14 21:10:55.000000000 +0200
+@@ -19,6 +19,7 @@
+ //#define BLOCKED 1
+ //#define UNBLOCKED 1
+ #define IN_BLOCK_FLIP 1
++#define USE_COMPOSITELESS_PHOTO_PUT_BLOCK
+
+ /* *********************************************************************/
+
+--- c/tkImageLoad.c 2009-08-14 21:13:29.000000000 +0200
++++ c/tkImageLoad.c.new 2009-08-14 21:14:59.000000000 +0200
+@@ -272,9 +272,11 @@
+ }
+ /* put the photo block into the image */
+ #ifdef __alpha
+- Tk_PhotoPutBlock(dp, &db, 0, 0, width, height);
++ Tk_PhotoPutBlock(dp, &db, 0, 0, width, height,
++ TK_PHOTO_COMPOSITE_OVERLAY);
+ #else
+- Tk_PhotoPutBlock(dp, &db, 0, 0, width, height, TK_PHOTO_COMPOSITE_SET);
++ Tk_PhotoPutBlock(dp, &db, 0, 0, width, height, TK_PHOTO_COMPOSITE_SET,
++ TK_PHOTO_COMPOSITE_OVERLAY);
+ #endif
+
+ /* Free the photo block's memory now it is finished with */
+@@ -417,9 +419,11 @@
+
+ /* put the photo block back into the image */
+ #ifdef __alpha
+- Tk_PhotoPutBlock(photo, &block, 0, 0, block.width, block.height);
++ Tk_PhotoPutBlock(photo, &block, 0, 0, block.width, block.height,
++ TK_PHOTO_COMPOSITE_OVERLAY);
+ #else
+- Tk_PhotoPutBlock(photo, &block, 0, 0, block.width, block.height,TK_PHOTO_COMPOSITE_SET);
++ Tk_PhotoPutBlock(photo, &block, 0, 0, block.width, block.height,TK_PHOTO_COMPOSITE_SET,
++ TK_PHOTO_COMPOSITE_OVERLAY);
+ #endif
+ /* Free the photo block's memory now it is finished with */
+ if (block.pixelPtr) {
+--- c/tkImageLoad.c 2009-08-14 21:15:06.000000000 +0200
++++ c/tkImageLoad.c.new 2009-08-14 21:16:53.000000000 +0200
+@@ -9,6 +9,7 @@
+ \************************************************************************/
+
+ #include <stdio.h>
++#include <string.h>
+ #include <tcl.h>
+ #include <tk.h>
+ #include <assert.h>
diff --git a/sci-chemistry/imosflm/imosflm-1.0.4.ebuild b/sci-chemistry/imosflm/imosflm-1.0.4.ebuild
new file mode 100644
index 000000000000..e08eccfa9c1b
--- /dev/null
+++ b/sci-chemistry/imosflm/imosflm-1.0.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/imosflm-1.0.4.ebuild,v 1.1 2010/02/06 23:22:49 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV="$(delete_all_version_separators ${PV})"
+
+DESCRIPTION="A new GUI for the Mosflm crystallographic data processing tool"
+HOMEPAGE="http://www.mrc-lmb.cam.ac.uk/harry/imosflm"
+SRC_URI="${HOMEPAGE}/ver${MY_PV}/downloads/${P}.zip"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/tcl
+ >=dev-tcltk/itcl-3.3
+ >=dev-tcltk/itk-3.3
+ >=dev-tcltk/iwidgets-4
+ >=dev-tcltk/tdom-0.8
+ >=dev-tcltk/tkimg-1.3
+ >=dev-tcltk/tktreectrl-2.1
+ dev-tcltk/anigif
+ dev-tcltk/combobox
+ dev-tcltk/tablelist
+ >=sci-chemistry/mosflm-7.0.4"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-tk.patch
+}
+
+src_compile() {
+ cd c
+
+ objs="tkImageLoadDLL.o tkImageLoad.o"
+ libs="-ltclstub -ltkstub"
+ config="-fPIC -DUSE_TCL_STUBS -DTK_USE_STUBS"
+ ldextra="-shared"
+
+ for file in ${objs}; do
+ einfo "$(tc-getCC) -c ${CFLAGS} ${config} ${file/.o/.c} -o ${file}"
+ $(tc-getCC) -c ${CFLAGS} ${config} ${file/.o/.c} -o ${file}
+ done
+
+ einfo "$(tc-getCC) ${LDFLAGS} ${ldextra} ${objs} -o tkImageLoad.so ${libs}"
+ $(tc-getCC) ${LDFLAGS} ${ldextra} ${objs} -o tkImageLoad.so ${libs}
+}
+
+src_install(){
+ rm -rf lib/{*.so,anigif,combobox}
+
+ insinto /usr/$(get_libdir)/${PN}
+ doins -r "${S}"/{src,bitmaps,lib}
+ fperms 775 /usr/$(get_libdir)/${PN}/src/imosflm
+
+ dolib.so c/tkImageLoad.so
+
+ cat >> "${T}"/23imosflm <<- EOF
+ IMOSFLM_VERSION="${PV}"
+ EOF
+
+ doenvd "${T}"/23imosflm
+
+ make_wrapper imosflm /usr/$(get_libdir)/${PN}/src/imosflm
+}
diff --git a/sci-chemistry/imosflm/metadata.xml b/sci-chemistry/imosflm/metadata.xml
new file mode 100644
index 000000000000..efb490d78817
--- /dev/null
+++ b/sci-chemistry/imosflm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>