summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2008-06-03 18:45:14 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2008-06-03 18:45:14 +0000
commite7fc5b9dee857530e4056fddd17881746a2763ad (patch)
treedd93df48b46e9bf71560af73ce1fbdb0d4e44de5 /sci-chemistry
parentSign Manfiest (diff)
downloadgentoo-2-e7fc5b9dee857530e4056fddd17881746a2763ad.tar.gz
gentoo-2-e7fc5b9dee857530e4056fddd17881746a2763ad.tar.bz2
gentoo-2-e7fc5b9dee857530e4056fddd17881746a2763ad.zip
No altivec patching with this gromacs version. Thanks to Maik Nijhuis in bug #224773.
(Portage version: 2.1.5.3)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gromacs/ChangeLog8
-rw-r--r--sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild12
-rw-r--r--sci-chemistry/gromacs/gromacs-3.3.1-r1.ebuild19
3 files changed, 19 insertions, 20 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index 64e695a58e71..d2acc91e00d7 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/gromacs
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.23 2007/06/13 18:15:51 armin76 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.24 2008/06/03 18:45:14 je_fro Exp $
+
+ 03 Jun 2008; Jeff Gardner <je_fro@gentoo.org> gromacs-3.3.1-r1.ebuild:
+ No altivec patching with this gromacs version. Thanks to Maik Nijhuis in
+ bug #224773.
13 Jun 2007; Raúl Porcel <armin76@gentoo.org> gromacs-3.3.1-r1.ebuild:
Modify the ebuild so it compiles on alpha and mark stable wrt #168182
diff --git a/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild b/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild
index 08b1c0b34b18..0d7ee123e392 100644
--- a/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild,v 1.4 2006/06/25 00:28:25 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild,v 1.5 2008/06/03 18:45:14 je_fro Exp $
inherit eutils
@@ -25,7 +25,7 @@ DEPEND="=sci-libs/fftw-2.1*
src_unpack() {
unpack ${A}
if use ppc64 && use altivec ; then
- epatch ${FILESDIR}/${PN}-ppc64-altivec.patch
+ epatch "${FILESDIR}"/${PN}-ppc64-altivec.patch
fi
}
@@ -56,12 +56,12 @@ src_compile() {
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
# Install documentation.
- dodoc AUTHORS COPYING INSTALL README
+ dodoc AUTHORS INSTALL README
#move html docs under /usr/share/doc
#and leave examples and templates under /usr/gromacs...
- mv ${D}/usr/share/${P}/html ${D}/usr/share/doc/${PF}
+ mv "${D}"/usr/share/${P}/html "${D}"/usr/share/doc/${PF}
}
diff --git a/sci-chemistry/gromacs/gromacs-3.3.1-r1.ebuild b/sci-chemistry/gromacs/gromacs-3.3.1-r1.ebuild
index 00317b415b17..89dbb8c16a55 100644
--- a/sci-chemistry/gromacs/gromacs-3.3.1-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-3.3.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-3.3.1-r1.ebuild,v 1.9 2007/06/13 18:15:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-3.3.1-r1.ebuild,v 1.10 2008/06/03 18:45:14 je_fro Exp $
inherit eutils fortran multilib
@@ -32,12 +32,7 @@ DEPEND=">=sci-libs/fftw-3.0.1
src_unpack() {
unpack ${A}
- if use ppc64 && use altivec ; then
- epatch "${FILESDIR}"/${PN}-ppc64-altivec.patch
- fi
-
cd "${S}"
-
# Fix typos in a couple of files.
sed -e "s:_nb_kerne010_x86_64_sse2:_nb_kernel010_x86_64_sse2:" \
-i src/gmxlib/nonbonded/nb_kernel_x86_64_sse2/nb_kernel010_x86_64_sse2.intel_syntax.s \
@@ -184,22 +179,22 @@ src_compile() {
}
src_install () {
- cd ${WORKDIR}/${P}-single ;
- emake DESTDIR=${D} install || die "installing single failed"
+ cd "${WORKDIR}"/${P}-single ;
+ emake DESTDIR="${D}" install || die "installing single failed"
if use mpi ; then
cd "${WORKDIR}"/${P}-single-mpi
- emake DESTDIR=${D} install-mdrun \
+ emake DESTDIR="${D}" install-mdrun \
|| die "installing mdrun_mpi failed"
fi
if use double-precision ; then
- cd ${WORKDIR}/${P}-double && emake DESTDIR=${D} install \
+ cd "${WORKDIR}"/${P}-double && emake DESTDIR="${D}" install \
|| die "installing double failed"
if use mpi ; then
cd "${WORKDIR}"/${P}-double-mpi
- emake DESTDIR=${D} install-mdrun \
+ emake DESTDIR="${D}" install-mdrun \
|| die "installing mdrun_mpi_d failed"
fi