summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-21 20:47:33 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-21 20:47:33 +0000
commitd68702075b62ecf043d1e7e2014ff91803f7b8b6 (patch)
tree33b1c5111a18bef3d758934e9d0eba216ea1ae85 /sci-electronics/eagle
parentDrop old; BUmp EAPI; handle static-libs (diff)
downloadgentoo-2-d68702075b62ecf043d1e7e2014ff91803f7b8b6.tar.gz
gentoo-2-d68702075b62ecf043d1e7e2014ff91803f7b8b6.tar.bz2
gentoo-2-d68702075b62ecf043d1e7e2014ff91803f7b8b6.zip
use dobin instead of exeinto /usr/bin/ && doexe
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-electronics/eagle')
-rw-r--r--sci-electronics/eagle/ChangeLog6
-rw-r--r--sci-electronics/eagle/eagle-4.16_p2-r2.ebuild16
-rw-r--r--sci-electronics/eagle/eagle-5.11.0.ebuild24
-rw-r--r--sci-electronics/eagle/eagle-5.12.0.ebuild21
4 files changed, 27 insertions, 40 deletions
diff --git a/sci-electronics/eagle/ChangeLog b/sci-electronics/eagle/ChangeLog
index dae0505cf1af..a881ebf8f0c7 100644
--- a/sci-electronics/eagle/ChangeLog
+++ b/sci-electronics/eagle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/eagle
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.64 2015/02/07 14:06:42 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.65 2015/03/21 20:47:33 jlec Exp $
+
+ 21 Mar 2015; Justin Lecher <jlec@gentoo.org> eagle-4.16_p2-r2.ebuild,
+ eagle-5.11.0.ebuild, eagle-5.12.0.ebuild:
+ use dobin instead of exeinto /usr/bin/ && doexe
07 Feb 2015; Christian Ruppert <idl0r@gentoo.org> eagle-7.2.0.ebuild:
Fix dependencies, bug 531746
diff --git a/sci-electronics/eagle/eagle-4.16_p2-r2.ebuild b/sci-electronics/eagle/eagle-4.16_p2-r2.ebuild
index c5fdfc327ed6..f4f1a6245f7c 100644
--- a/sci-electronics/eagle/eagle-4.16_p2-r2.ebuild
+++ b/sci-electronics/eagle/eagle-4.16_p2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-4.16_p2-r2.ebuild,v 1.7 2014/10/15 21:05:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-4.16_p2-r2.ebuild,v 1.8 2015/03/21 20:47:33 jlec Exp $
EAPI=5
@@ -58,23 +58,19 @@ MY_P=${PN}-lin-${MY_LANG}-${MY_PV}
S="${WORKDIR}/${MY_P}"
src_unpack() {
-
unpack ${MY_P}.tgz
use doc && cp "${DISTDIR}"/${MANFILE} "${S}"
}
src_install() {
-
- cd "${S}"
dodir ${INSTALLDIR}
# Copy all to INSTALLDIR
- cp -r . "${D}"/${INSTALLDIR}
+ cp -r . "${D}"/${INSTALLDIR} || die
# Install wrapper (suppressing leading tabs)
# see bug #188368 or http://www.cadsoft.de/faq.htm#17040701
- exeinto /usr/bin
- newexe "${FILESDIR}/eagle_wrapper_script" eagle
+ newbin "${FILESDIR}/eagle_wrapper_script" eagle
# Finally, append the path of the eagle binary respecting INSTALLDIR and any
# arguments passed to the script (thanks Denilson)
echo "${INSTALLDIR}/bin/eagle" '"$@"' >> "${D}/usr/bin/eagle"
@@ -85,7 +81,7 @@ src_install() {
# Conditionally install the user's manual
use doc && cp ${MANFILE} "${D}/usr/share/doc/${PF}"
# Remove docs left in INSTALLDIR
- rm -rf "${D}${INSTALLDIR}/{README,install,${MANFILE}}" "${D}${INSTALLDIR}/doc" "${D}${INSTALLDIR}/man"
+ rm -rf "${D}${INSTALLDIR}/{README,install,${MANFILE}}" "${D}${INSTALLDIR}/doc" "${D}${INSTALLDIR}/man" || die
echo -e "ROOTPATH=${INSTALLDIR}/bin\nPRELINK_PATH_MASK=${INSTALLDIR}" > "${S}/90eagle"
doenvd "${S}/90eagle"
@@ -97,9 +93,7 @@ src_install() {
}
pkg_postinst() {
-
elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
elog "now to set up the correct paths."
elog "You must first run eagle as root to invoke product registration."
-
}
diff --git a/sci-electronics/eagle/eagle-5.11.0.ebuild b/sci-electronics/eagle/eagle-5.11.0.ebuild
index 6efde0b2aeff..a8ce3bc7b7a8 100644
--- a/sci-electronics/eagle/eagle-5.11.0.ebuild
+++ b/sci-electronics/eagle/eagle-5.11.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-5.11.0.ebuild,v 1.6 2014/10/15 21:05:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-5.11.0.ebuild,v 1.7 2015/03/21 20:47:33 jlec Exp $
EAPI=5
@@ -50,54 +50,47 @@ esac
DOCS="README_${MY_LANG} UPDATE_${MY_LANG} library_${MY_LANG}.txt"
src_unpack() {
-
# Extract the built-in .tar.bz2 file starting at __DATA__
sed -e '1,/^__DATA__$/d' "${DISTDIR}/${A}" | tar xj || die "unpacking failed"
-
}
src_install() {
-
# Set MY_LANG for this function only since UPDATE_zh and README_zh
# don't exist
[[ ${LINGUAS} == *zh* ]] && MY_INST_LANG="zh" || MY_INST_LANG="${MY_LANG}"
- cd "${S}"
dodir ${INSTALLDIR}
# Copy all to INSTALLDIR
- cp -r . "${D}"/${INSTALLDIR}
+ cp -r . "${D}"/${INSTALLDIR} || die
# Install wrapper (suppressing leading tabs)
# see bug #188368 or http://www.cadsoft.de/faq.htm#17040701
- exeinto /usr/bin
- newexe "${FILESDIR}/eagle_wrapper_script" eagle-${PV}
+ newbin "${FILESDIR}/eagle_wrapper_script" eagle-${PV}
dosym eagle-${PV} /usr/bin/eagle
# Finally, append the path of the eagle binary respecting INSTALLDIR and any
# arguments passed to the script (thanks Denilson)
echo "${INSTALLDIR}/bin/eagle" '"$@"' >> "${D}/usr/bin/eagle-${PV}"
# Install the documentation
- cd doc
+ cd doc || die
dodoc ${DOCS}
doman eagle.1
# Install extra documentation if requested
use doc && dodoc elektro-tutorial.pdf manual_${MY_INST_LANG}.pdf tutorial_${MY_INST_LANG}.pdf
# Remove docs left in INSTALLDIR
- rm -rf "${D}${INSTALLDIR}/doc"
- cd ..
+ rm -rf "${D}${INSTALLDIR}/doc" || die
+ cd .. || die
echo -e "ROOTPATH=${INSTALLDIR}/bin\nPRELINK_PATH_MASK=${INSTALLDIR}" > "${S}/90eagle-${PV}"
doenvd "${S}/90eagle-${PV}"
# Create desktop entry
- mv bin/${PN}icon50.png bin/${PF}-icon50.png
+ mv bin/${PN}icon50.png bin/${PF}-icon50.png || die
doicon bin/${PF}-icon50.png
make_desktop_entry "${ROOT}/usr/bin/eagle-${PV}" "CadSoft EAGLE Layout Editor" ${PF}-icon50 "Graphics;Electronics"
-
}
pkg_postinst() {
-
elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
elog "now to set up the correct paths."
elog "You must first run eagle as root to invoke product registration."
@@ -107,5 +100,4 @@ pkg_postinst() {
ewarn "with versions prior to 5.0!"
ewarn
ewarn "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 4.xx."
-
}
diff --git a/sci-electronics/eagle/eagle-5.12.0.ebuild b/sci-electronics/eagle/eagle-5.12.0.ebuild
index 335e6eedb7f6..cedceeabb680 100644
--- a/sci-electronics/eagle/eagle-5.12.0.ebuild
+++ b/sci-electronics/eagle/eagle-5.12.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-5.12.0.ebuild,v 1.2 2014/10/15 21:05:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-5.12.0.ebuild,v 1.3 2015/03/21 20:47:33 jlec Exp $
EAPI="5"
@@ -8,14 +8,13 @@ inherit eutils
DESCRIPTION="CadSoft EAGLE schematic and printed circuit board (PCB) layout editor"
HOMEPAGE="http://www.cadsoft.de"
+SRC_URI="ftp://ftp.cadsoft.de/eagle/program/${PV%\.[0-9]}/${PN}-lin-${PV}.run"
KEYWORDS="~amd64 ~x86"
IUSE="doc linguas_de linguas_zh"
LICENSE="cadsoft"
SLOT="0"
-SRC_URI="ftp://ftp.cadsoft.de/eagle/program/${PV%\.[0-9]}/${PN}-lin-${PV}.run"
-
QA_PREBUILT="opt/${P}/bin/eagle"
RDEPEND="
@@ -64,35 +63,33 @@ src_install() {
# don't exist
[[ ${LINGUAS} == *zh* ]] && MY_INST_LANG="zh" || MY_INST_LANG="${MY_LANG}"
- cd "${S}"
dodir ${INSTALLDIR}
# Copy all to INSTALLDIR
- cp -r . "${D}"/${INSTALLDIR}
+ cp -r . "${D}"/${INSTALLDIR} || die
# Install wrapper (suppressing leading tabs)
# see bug #188368 or http://www.cadsoft.de/faq.htm#17040701
- exeinto /usr/bin
- newexe "${FILESDIR}/eagle_wrapper_script" eagle-${PV}
+ newbin "${FILESDIR}/eagle_wrapper_script" eagle-${PV}
dosym eagle-${PV} /usr/bin/eagle
# Finally, append the path of the eagle binary respecting INSTALLDIR and any
# arguments passed to the script (thanks Denilson)
echo "${INSTALLDIR}/bin/eagle" '"$@"' >> "${D}/usr/bin/eagle-${PV}"
# Install the documentation
- cd doc
+ cd doc || die
dodoc ${DOCS}
doman eagle.1
# Install extra documentation if requested
use doc && dodoc elektro-tutorial.pdf manual_${MY_INST_LANG}.pdf tutorial_${MY_INST_LANG}.pdf
# Remove docs left in INSTALLDIR
- rm -rf "${D}${INSTALLDIR}/doc"
- cd ..
+ rm -rf "${D}${INSTALLDIR}/doc" || die
+ cd .. || die
echo -e "ROOTPATH=${INSTALLDIR}/bin\nPRELINK_PATH_MASK=${INSTALLDIR}" > "${S}/90eagle-${PV}"
doenvd "${S}/90eagle-${PV}"
# Create desktop entry
- mv bin/${PN}icon50.png bin/${PF}-icon50.png
+ mv bin/${PN}icon50.png bin/${PF}-icon50.png || die
doicon bin/${PF}-icon50.png
make_desktop_entry "${ROOT}/usr/bin/eagle-${PV}" "CadSoft EAGLE Layout Editor" ${PF}-icon50 "Graphics;Electronics"
}