summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-02-15 22:08:49 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-02-15 22:08:49 +0000
commitd8a42d13525e0b48048cdd3dc0d536fe5d29cc03 (patch)
tree400e6aae82a5961bb8ee95d99d734af28925b114 /sci-electronics/gspeakers
parentAdding ~amd64 keyword (diff)
downloadgentoo-2-d8a42d13525e0b48048cdd3dc0d536fe5d29cc03.tar.gz
gentoo-2-d8a42d13525e0b48048cdd3dc0d536fe5d29cc03.tar.bz2
gentoo-2-d8a42d13525e0b48048cdd3dc0d536fe5d29cc03.zip
Fix building with gcc-4.3. Patch by Arttu Valo in bug #251625.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/gspeakers')
-rw-r--r--sci-electronics/gspeakers/ChangeLog8
-rw-r--r--sci-electronics/gspeakers/files/gspeakers-0.11-gcc43.patch50
-rw-r--r--sci-electronics/gspeakers/gspeakers-0.11.ebuild11
3 files changed, 64 insertions, 5 deletions
diff --git a/sci-electronics/gspeakers/ChangeLog b/sci-electronics/gspeakers/ChangeLog
index 8c371e0c6c21..9a272002d10d 100644
--- a/sci-electronics/gspeakers/ChangeLog
+++ b/sci-electronics/gspeakers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/gspeakers
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspeakers/ChangeLog,v 1.7 2007/05/19 14:52:14 calchan Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspeakers/ChangeLog,v 1.8 2009/02/15 22:08:49 dirtyepic Exp $
+
+ 15 Feb 2009; Ryan Hill <dirtyepic@gentoo.org>
+ +files/gspeakers-0.11-gcc43.patch, gspeakers-0.11.ebuild:
+ Fix building with gcc-4.3. Patch by Arttu Valo in bug #251625.
19 May 2007; Denis Dupeyron <calchan@gentoo.org> gspeakers-0.11.ebuild:
Dependencies cleaned up a bit.
diff --git a/sci-electronics/gspeakers/files/gspeakers-0.11-gcc43.patch b/sci-electronics/gspeakers/files/gspeakers-0.11-gcc43.patch
new file mode 100644
index 000000000000..47576fd9a23d
--- /dev/null
+++ b/sci-electronics/gspeakers/files/gspeakers-0.11-gcc43.patch
@@ -0,0 +1,50 @@
+--- gspeakers-0.11-orig/src/filterlinkframe.cc
++++ gspeakers-0.11/src/filterlinkframe.cc
+@@ -22,6 +22,7 @@
+ #include <stdio.h>
+ #include <fstream>
+ #include <sstream>
++#include <cstring>
+ #include "filterlinkframe.h"
+ #include "gspeakersplot.h"
+ #include "common.h"
+--- gspeakers-0.11-orig/src/freqrespeditor.cc
++++ gspeakers-0.11/src/freqrespeditor.cc
+@@ -20,6 +20,7 @@
+ #include "freqrespeditor.h"
+ #include <fstream>
+ #include <stdio.h>
++#include <cstring>
+ #include <gtkmm/stock.h>
+ #include <gtkmm/frame.h>
+ #include <gtkmm/messagedialog.h>
+--- gspeakers-0.11-orig/src/popupentry.cc
++++ gspeakers-0.11/src/popupentry.cc
+@@ -26,6 +26,7 @@
+ #include <gtkmm.h>
+ #include <gtk/gtkentry.h> /* see XXX below */
+ #include <iostream>
++#include <cstring>
+
+ using namespace std;
+
+--- gspeakers-0.11-orig/src/speakereditor.cc
++++ gspeakers-0.11/src/speakereditor.cc
+@@ -18,6 +18,7 @@
+ */
+
+ #include <fstream>
++#include <cstring>
+ #include <math.h>
+ #include "speakereditor.h"
+ #include "common.h"
+--- gspeakers-0.11-orig/src/summedfreqrespplot.cc
++++ gspeakers-0.11/src/summedfreqrespplot.cc
+@@ -20,6 +20,7 @@
+ */
+
+ #include <fstream>
++#include <cstring>
+ #include <math.h>
+ #include "summedfreqrespplot.h"
+ #include "net.h"
diff --git a/sci-electronics/gspeakers/gspeakers-0.11.ebuild b/sci-electronics/gspeakers/gspeakers-0.11.ebuild
index 7361a11b1f3c..995880820a1d 100644
--- a/sci-electronics/gspeakers/gspeakers-0.11.ebuild
+++ b/sci-electronics/gspeakers/gspeakers-0.11.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspeakers/gspeakers-0.11.ebuild,v 1.5 2007/05/19 14:52:14 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspeakers/gspeakers-0.11.ebuild,v 1.6 2009/02/15 22:08:49 dirtyepic Exp $
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="GTK based loudspeaker enclosure and crossovernetwork designer"
HOMEPAGE="http://gspeakers.sourceforge.net/"
@@ -23,3 +23,8 @@ RDEPEND="${RDEPEND}
sci-electronics/spice )"
DOCS="README* INSTALL Changelog AUTHORS NEWS ABOUT"
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}