summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-02-11 13:50:23 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-02-11 13:50:23 +0000
commit2d36752ae4f50e826ff00667dd5fa8666d28b55d (patch)
tree7355d0d41763859ad9c5ded2f7e29a1faddf108f /sci-electronics/gspiceui
parenthttp://my.opera.com/desktopteam/blog/2012/02/10/new-11-62-snapshot (diff)
downloadgentoo-2-2d36752ae4f50e826ff00667dd5fa8666d28b55d.tar.gz
gentoo-2-2d36752ae4f50e826ff00667dd5fa8666d28b55d.tar.bz2
gentoo-2-2d36752ae4f50e826ff00667dd5fa8666d28b55d.zip
Version bump
(Portage version: 2.1.10.45/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/gspiceui')
-rw-r--r--sci-electronics/gspiceui/ChangeLog10
-rw-r--r--sci-electronics/gspiceui/files/gspiceui-1.0.0-flags.patch28
-rw-r--r--sci-electronics/gspiceui/gspiceui-1.0.0.ebuild66
3 files changed, 102 insertions, 2 deletions
diff --git a/sci-electronics/gspiceui/ChangeLog b/sci-electronics/gspiceui/ChangeLog
index 92f4be6bfbad..c23c1f031e87 100644
--- a/sci-electronics/gspiceui/ChangeLog
+++ b/sci-electronics/gspiceui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/gspiceui
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspiceui/ChangeLog,v 1.6 2011/07/15 22:56:38 calchan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspiceui/ChangeLog,v 1.7 2012/02/11 13:50:23 tomjbe Exp $
+
+*gspiceui-1.0.0 (11 Feb 2012)
+
+ 11 Feb 2012; Thomas Beierlein <tomjbe@gentoo.org> +gspiceui-1.0.0.ebuild,
+ +files/gspiceui-1.0.0-flags.patch:
+ Version bump
15 Jul 2011; Denis Dupeyron <calchan@gentoo.org> gspiceui-0.9.99.ebuild,
gspiceui-0.9.99-r1.ebuild:
diff --git a/sci-electronics/gspiceui/files/gspiceui-1.0.0-flags.patch b/sci-electronics/gspiceui/files/gspiceui-1.0.0-flags.patch
new file mode 100644
index 000000000000..17cc77d8f8b7
--- /dev/null
+++ b/sci-electronics/gspiceui/files/gspiceui-1.0.0-flags.patch
@@ -0,0 +1,28 @@
+# drop -Ofast option understood only from gcc-4.6 on
+# and make it respect LDFLAGS and CXXFLAGS
+--- src/Makefile.old 2012-02-11 13:29:27.000000000 +0100
++++ src/Makefile 2012-02-11 13:31:13.000000000 +0100
+@@ -59,13 +59,7 @@
+ INSTALLDIR = /usr/local/bin
+
+ # Compiler options
+-ifeq ($(GSPICEUI_DBG),0)
+- # Options for release (not using -Wall since it's GCC specific)
+- CXXFLAGS := -Ofast -pipe $(shell $(WXCFG) --cxxflags)
+-else
+- # Options for development
+- CXXFLAGS := -Wall -g -pipe $(shell $(WXCFG) --cxxflags)
+-endif
++ CXXFLAGS += $(shell $(WXCFG) --cxxflags)
+
+ # Includes
+ INCLUDES = -I/usr/include -I/usr/X11R6/include -I.
+@@ -106,7 +100,7 @@
+ # -o specify the output file name
+
+ $(BINDIR)/$(PROG) : $(OBJS)
+- $(CC) -pipe -o $(BINDIR)/$(PROG) obj/*.o $(LIBS)
++ $(CC) -pipe -o $(BINDIR)/$(PROG) obj/*.o $(LDFLAGS) $(LIBS)
+ ifeq ($(ROOT)/GSpiceUI.app,$(wildcard $(ROOT)/GSpiceUI.app))
+ cp $(BINDIR)/$(PROG) $(ROOT)/GSpiceUI.app/Contents/MacOS/gspiceui
+ endif
diff --git a/sci-electronics/gspiceui/gspiceui-1.0.0.ebuild b/sci-electronics/gspiceui/gspiceui-1.0.0.ebuild
new file mode 100644
index 000000000000..c3011e38922a
--- /dev/null
+++ b/sci-electronics/gspiceui/gspiceui-1.0.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspiceui/gspiceui-1.0.0.ebuild,v 1.1 2012/02/11 13:50:23 tomjbe Exp $
+
+EAPI="2"
+
+WX_GTK_VER="2.8"
+inherit eutils wxwidgets
+
+MY_P="${PN}-v${PV}0"
+
+DESCRIPTION="GUI frontend for Ngspice and Gnucap"
+HOMEPAGE="http://www.geda.seul.org/tools/gspiceui/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples schematics waveform"
+
+DEPEND="x11-libs/wxGTK:2.8[X]
+ sci-electronics/electronics-menu"
+RDEPEND="${DEPEND}
+ || ( sci-electronics/ngspice sci-electronics/gnucap )
+ waveform? ( sci-electronics/gwave )
+ schematics? ( sci-electronics/geda )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Use Gentoo LDFLAGS and CXXFLAGS
+ epatch "${FILESDIR}/${P}-flags.patch"
+
+ # Adjusting the doc path at src/main/HelpTasks.cpp
+ sed -i -e \
+ "s:/share/gspiceui/html/User-Manual.html:/share/doc/${PF}/html/User-Manual.html:g" \
+ src/main/HelpTasks.cpp || die
+}
+
+src_install() {
+ dobin bin/gspiceui || die
+ dodoc ChangeLog ReadMe ToDo || die
+ doman gspiceui.1 || die
+ newicon src/icons/gspiceui-48x48.xpm gspiceui.xpm || die
+
+ dohtml html/*.html html/*.jpg || die
+
+ # installing examples and according model and symbol files
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/sch
+ doins -r sch/* || die
+ insinto /usr/share/doc/${PF}/lib
+ doins -r lib/* || die
+ fi
+
+ make_desktop_entry gspiceui "GNU Spice GUI" gspiceui "Electronics"
+}
+
+pkg_postinst() {
+ if use examples ; then
+ elog "If you want to use the examples, copy from"
+ elog "/usr/share/doc/${PF} the sch and lib directory"
+ elog "side by side to your home directory to be able"
+ elog "to generate the netlists as normal user."
+ fi
+}