summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2013-11-03 08:10:52 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2013-11-03 08:10:52 +0000
commita743f7868d9f45ff318804da42a180229350459e (patch)
tree7bcbad116cd4c298d98882af0673b9908efd7600 /sci-electronics
parentFix python-utils-r1 tests to accomodate versions in PYTHON_PKG_DEP. (diff)
downloadgentoo-2-a743f7868d9f45ff318804da42a180229350459e.tar.gz
gentoo-2-a743f7868d9f45ff318804da42a180229350459e.tar.bz2
gentoo-2-a743f7868d9f45ff318804da42a180229350459e.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/xnec2c/ChangeLog7
-rw-r--r--sci-electronics/xnec2c/xnec2c-2.4.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sci-electronics/xnec2c/ChangeLog b/sci-electronics/xnec2c/ChangeLog
index dabd35bac18a..db05e02c3228 100644
--- a/sci-electronics/xnec2c/ChangeLog
+++ b/sci-electronics/xnec2c/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/xnec2c
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/ChangeLog,v 1.10 2013/03/17 18:05:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/ChangeLog,v 1.11 2013/11/03 08:10:52 tomjbe Exp $
+
+*xnec2c-2.4 (03 Nov 2013)
+
+ 03 Nov 2013; Thomas Beierlein <tomjbe@gentoo.org> +xnec2c-2.4.ebuild:
+ Version bump
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/sci-electronics/xnec2c/xnec2c-2.4.ebuild b/sci-electronics/xnec2c/xnec2c-2.4.ebuild
new file mode 100644
index 000000000000..f45f45a8f61f
--- /dev/null
+++ b/sci-electronics/xnec2c/xnec2c-2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/xnec2c-2.4.ebuild,v 1.1 2013/11/03 08:10:52 tomjbe Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="A GTK+ graphical interactive version of nec2c."
+HOMEPAGE="http://www.qsl.net/5b4az/pages/nec2.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/nec2/xnec2c/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P/_beta/-beta}"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ glib-gettextize --force --copy || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS README doc/*.txt
+ use doc && dohtml -r doc/*.html doc/images
+ insinto /usr/share/doc/${PF}/examples
+ use examples && doins examples/*
+}