summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 17:26:10 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 17:26:10 +0000
commitb7c6e06a8c4e275af61f95d83462adde26988d8f (patch)
tree9f5d729dadc031c196198fa2a9f96ce1ba6d856c /sci-electronics
parentRemoving masked entry for octave-forge, now gone (diff)
downloadgentoo-2-b7c6e06a8c4e275af61f95d83462adde26988d8f.tar.gz
gentoo-2-b7c6e06a8c4e275af61f95d83462adde26988d8f.tar.bz2
gentoo-2-b7c6e06a8c4e275af61f95d83462adde26988d8f.zip
Version Bump and restricting gtk+ version #273237
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/balsa/ChangeLog10
-rw-r--r--sci-electronics/balsa/balsa-3.5.ebuild44
-rw-r--r--sci-electronics/balsa/balsa-4.0.ebuild139
-rw-r--r--sci-electronics/balsa/files/4.0-datadir.patch73
-rw-r--r--sci-electronics/balsa/files/4.0-libdir.patch36
5 files changed, 279 insertions, 23 deletions
diff --git a/sci-electronics/balsa/ChangeLog b/sci-electronics/balsa/ChangeLog
index e79c10c8aabf..e6d9ea02417f 100644
--- a/sci-electronics/balsa/ChangeLog
+++ b/sci-electronics/balsa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/balsa
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/ChangeLog,v 1.13 2009/09/23 19:59:23 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/ChangeLog,v 1.14 2010/06/24 17:26:10 jlec Exp $
+
+*balsa-4.0 (24 Jun 2010)
+
+ 24 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/4.0-datadir.patch,
+ balsa-3.5.ebuild, +files/4.0-libdir.patch, +balsa-4.0.ebuild:
+ Version Bump and restricting gtk+ version, #273237
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> balsa-3.5.ebuild:
Remove virtual/libc
diff --git a/sci-electronics/balsa/balsa-3.5.ebuild b/sci-electronics/balsa/balsa-3.5.ebuild
index 96084266a902..cd61e9bb204d 100644
--- a/sci-electronics/balsa/balsa-3.5.ebuild
+++ b/sci-electronics/balsa/balsa-3.5.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/balsa-3.5.ebuild,v 1.3 2009/09/23 19:59:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/balsa-3.5.ebuild,v 1.4 2010/06/24 17:26:10 jlec Exp $
+
+EAPI="1"
inherit eutils
-IUSE=""
DESCRIPTION="The Balsa asynchronous synthesis system"
HOMEPAGE="http://www.cs.manchester.ac.uk/apt/projects/tools/balsa/"
@@ -19,11 +20,12 @@ SRC_URI="ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/BalsaExamples${PV}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
+IUSE=""
DEPEND="sys-devel/binutils
dev-libs/gmp
dev-lang/perl
- x11-libs/gtk+
+ x11-libs/gtk+:1
sci-electronics/iverilog
sci-electronics/gplcver"
@@ -44,10 +46,10 @@ src_unpack() {
if [ $TECH_AMS ]; then
unpack ${BALSA_TECH_AMS}
fi
- sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I${S}/src/libs/ \2/:" ${WORKDIR}/balsa-sim-verilog-${PV}/libs/Makefile.in
- sed -i -e 's/ $(bindir)/ $(DESTDIR)$(bindir)/' ${S}/bin/Makefile.in
- sed -i -e 's/ $(balsatypesdir)/ $(DESTDIR)$(balsatypesdir)/' ${S}/share/balsa/types/Makefile.in
- sed -i -e 's/ $(balsasimdir)/ $(DESTDIR)$(balsasimdir)/' ${S}/share/balsa/sim/Makefile.in
+ sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I"${S}"/src/libs/ \2/:" "${WORKDIR}"/balsa-sim-verilog-${PV}/libs/Makefile.in
+ sed -i -e 's/ $(bindir)/ $(DESTDIR)$(bindir)/' "${S}"/bin/Makefile.in
+ sed -i -e 's/ $(balsatypesdir)/ $(DESTDIR)$(balsatypesdir)/' "${S}"/share/balsa/types/Makefile.in
+ sed -i -e 's/ $(balsasimdir)/ $(DESTDIR)$(balsasimdir)/' "${S}"/share/balsa/sim/Makefile.in
}
src_compile() {
@@ -55,30 +57,30 @@ src_compile() {
einfo "Compiling balsa"
./configure --prefix=/usr/ || die "econf failed"
chmod +x bin/balsa-config
- PATH=$PATH:${S}/bin
+ PATH=$PATH:"${S}"/bin
emake -j1 || die
# configure AMS035 tech
if [ $TECH_AMS ]; then
einfo "Compiling AMS035 tech"
- cd ${WORKDIR}/balsa-tech-ams-20030506
+ cd "${WORKDIR}"/balsa-tech-ams-20030506
econf || die "econf failed"
fi
# config Xilinx FPGA backend
einfo "Compiling Xilinx FPGA backend"
- cd ${WORKDIR}/balsa-tech-xilinx-${PV}
+ cd "${WORKDIR}"/balsa-tech-xilinx-${PV}
econf || die "econf failed"
# config example tech
einfo "Compiling tech example"
- cd ${WORKDIR}/balsa-tech-example-${PV}
+ cd "${WORKDIR}"/balsa-tech-example-${PV}
econf || die "econf failed"
# config verilog simulator wrappers
einfo "Compiling verilog simulator wrappers"
- cd ${WORKDIR}/balsa-sim-verilog-${PV}
- ./configure --includedir=${S}/src/libs/balsasim \
+ cd "${WORKDIR}"/balsa-sim-verilog-${PV}
+ ./configure --includedir="${S}"/src/libs/balsasim \
--with-icarus-includes=/usr/include \
--with-icarus-libs=/usr/lib \
--with-cver-includes=/usr/include/cver_pli_incs || die
@@ -86,31 +88,31 @@ src_compile() {
src_install() {
# install balsa
- cd ${S}
+ cd "${S}"
einfo "Installing balsa"
make DESTDIR=${D} install || die
# install manual and examples
dodir /usr/share/doc/${P}/
- cp -pPR ${WORKDIR}/BalsaExamples ${D}/usr/share/doc/${P}/
+ cp -pPR "${WORKDIR}"/BalsaExamples ${D}/usr/share/doc/${P}/
dodoc ${DISTDIR}/BalsaManual${PV}.pdf
if [ $TECH_AMS ]; then
einfo "Installing AMS035 tech"
- cd ${WORKDIR}/balsa-tech-ams-20030506
+ cd "${WORKDIR}"/balsa-tech-ams-20030506
make DESTDIR=${D} install || die "make install failed"
fi
einfo "Installing Xilinx FPGA tech"
- cd ${WORKDIR}/balsa-tech-xilinx-${PV}
+ cd "${WORKDIR}"/balsa-tech-xilinx-${PV}
make DESTDIR=${D} install || die "make install failed"
einfo "Installing example tech"
- cd ${WORKDIR}/balsa-tech-example-${PV}
+ cd "${WORKDIR}"/balsa-tech-example-${PV}
make DESTDIR=${D} install || die "make install failed"
einfo "Installing verilog simulator wrappers"
- cd ${WORKDIR}/balsa-sim-verilog-${PV}
+ cd "${WORKDIR}"/balsa-sim-verilog-${PV}
DESTDIR=${D} make install || die "make verilog wrappers failed"
# fix paths
@@ -120,7 +122,7 @@ src_install() {
find . -name "sed*" -exec rm -f {} \;
# add some docs
- cd ${S}
+ cd "${S}"
einfo "Installing docs"
dodoc AUTHORS COPYING NEWS README TODO
mv ${D}/usr/doc/* ${D}/usr/share/doc/${P}/
diff --git a/sci-electronics/balsa/balsa-4.0.ebuild b/sci-electronics/balsa/balsa-4.0.ebuild
new file mode 100644
index 000000000000..66f1e4cb9e3e
--- /dev/null
+++ b/sci-electronics/balsa/balsa-4.0.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/balsa-4.0.ebuild,v 1.1 2010/06/24 17:26:10 jlec Exp $
+
+EAPI="1"
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="The Balsa asynchronous synthesis system"
+HOMEPAGE="http://www.cs.manchester.ac.uk/apt/projects/tools/balsa/"
+SRC_URI="
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/${P}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/${PN}-sim-verilog-${PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/${PN}-tech-example-${PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/${PN}-tech-xilinx-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/gmp
+ sci-electronics/gplcver
+ sci-electronics/iverilog
+ x11-libs/gtk+:2"
+RDEPEND="${DEPEND}
+ dev-scheme/guile
+ media-gfx/graphviz
+ sci-electronics/espresso-ab
+ sci-electronics/gtkwave "
+
+BALSA_TECH_AMS="balsa-tech-ams-20030506.tar.gz"
+
+if [ -f ${DISTDIR}/${BALSA_TECH_AMS} ]; then
+ TECH_AMS=1
+fi
+
+src_unpack() {
+ unpack ${A}
+ if [ $TECH_AMS ]; then
+ unpack ${BALSA_TECH_AMS}
+ fi
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-libdir.patch
+ epatch "${FILESDIR}"/${PV}-datadir.patch
+ eautoreconf
+ sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I"${S}"/src/libs/ \2/:" "${WORKDIR}"/balsa-sim-verilog-${PV}/libs/Makefile.in
+ sed -i -e 's/ $(bindir)/ $(DESTDIR)$(bindir)/' "${S}"/bin/Makefile.in
+ sed -i -e 's/ $(balsatypesdir)/ $(DESTDIR)$(balsatypesdir)/' "${S}"/share/balsa/types/Makefile.in
+ sed -i -e 's/ $(balsasimdir)/ $(DESTDIR)$(balsasimdir)/' "${S}"/share/balsa/sim/Makefile.in
+}
+
+src_compile() {
+ tc-export CXX
+ # compile balsa
+ einfo "Compiling balsa"
+ econf
+ chmod +x bin/balsa-config
+ PATH="$PATH:"${S}"/bin"
+ emake -j1 || die
+
+ # configure AMS035 tech
+ if [ $TECH_AMS ]; then
+ einfo "Compiling AMS035 tech"
+ cd "${WORKDIR}"/balsa-tech-ams-20030506
+ econf
+ fi
+
+ # config Xilinx FPGA backend
+ einfo "Compiling Xilinx FPGA backend"
+ cd "${WORKDIR}"/balsa-tech-xilinx-${PV}
+ econf
+
+ # config example tech
+ einfo "Compiling tech example"
+ cd "${WORKDIR}"/balsa-tech-example-${PV}
+ econf
+
+ # config verilog simulator wrappers
+ einfo "Compiling verilog simulator wrappers"
+ cd "${WORKDIR}"/balsa-sim-verilog-${PV}
+# ./configure --includedir="${S}"/src/libs/balsasim \
+ econf \
+ --includedir="${S}"/src/libs/balsasim \
+ --with-icarus-includes=/usr/include \
+ --with-icarus-libs=/usr/$(get_libdir) \
+ --with-cver-includes=/usr/include/cver_pli_incs || die
+}
+
+src_install() {
+ # install balsa
+ einfo "Installing balsa"
+ emake DESTDIR=${D} install || die
+
+ if [ $TECH_AMS ]; then
+ einfo "Installing AMS035 tech"
+ cd "${WORKDIR}"/balsa-tech-ams-20030506
+ emake DESTDIR=${D} install || die "make install failed"
+ fi
+
+ einfo "Installing Xilinx FPGA tech"
+ cd "${WORKDIR}"/balsa-tech-xilinx-${PV}
+ emake DESTDIR=${D} install || die "make install failed"
+
+ einfo "Installing example tech"
+ cd "${WORKDIR}"/balsa-tech-example-${PV}
+ emake DESTDIR=${D} install || die "make install failed"
+
+ einfo "Installing verilog simulator wrappers"
+ cd "${WORKDIR}"/balsa-sim-verilog-${PV}
+ DESTDIR=${D} emake install || die "make verilog wrappers failed"
+
+ # fix paths
+ cd ${D}
+ einfo "Fixing paths"
+ find . -type f -exec sed -i -e "s:${D}::" {} \;
+ find . -name "sed*" -exec rm -f {} \;
+
+ # add some docs
+ cd "${S}"
+ einfo "Installing docs"
+ dodoc AUTHORS NEWS README TODO || die
+
+ # fix collisions
+ rm -f ${D}/usr/bin/libtool || die
+}
+
+pkg_postinst() {
+ if [ ! $TECH_AMS ]; then
+ elog "The AMS035 tech library was not installed."
+ elog "If you have the appropriate licenses request"
+ elog "the tech support files directly from balsa@cs.man.ac.uk"
+ elog "and add them to /usr/portage/distfiles before emerging."
+ else
+ elog "The AMS035 tech library was found and installed."
+ fi
+}
diff --git a/sci-electronics/balsa/files/4.0-datadir.patch b/sci-electronics/balsa/files/4.0-datadir.patch
new file mode 100644
index 000000000000..2693508d4ad3
--- /dev/null
+++ b/sci-electronics/balsa/files/4.0-datadir.patch
@@ -0,0 +1,73 @@
+diff --git a/share/scheme/Makefile.am b/share/scheme/Makefile.am
+index 37f9332..e3d81d0 100644
+--- a/share/scheme/Makefile.am
++++ b/share/scheme/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-schemedir = $(datadir)/scheme
++schemedir = $(datadir)/balsa/scheme
+
+ scheme_DATA = \
+ balsa-list-builtins.scm \
+diff --git a/share/style/dual_b/Makefile.am b/share/style/dual_b/Makefile.am
+index 478910d..d41a873 100644
+--- a/share/style/dual_b/Makefile.am
++++ b/share/style/dual_b/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-styledual_bdir = $(datadir)/style/dual_b
++styledual_bdir = $(datadir)/balsa/style/dual_b
+
+ styledual_b_DATA = \
+ startup.scm \
+diff --git a/share/style/four_b_rb/Makefile.am b/share/style/four_b_rb/Makefile.am
+index 9eeac84..b167939 100644
+--- a/share/style/four_b_rb/Makefile.am
++++ b/share/style/four_b_rb/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-stylefour_b_rbdir = $(datadir)/style/four_b_rb
++stylefour_b_rbdir = $(datadir)/balsa/style/four_b_rb
+
+ stylefour_b_rb_DATA = \
+ startup.scm \
+diff --git a/share/style/four_e_e/Makefile.am b/share/style/four_e_e/Makefile.am
+index d374125..f3d9db6 100644
+--- a/share/style/four_e_e/Makefile.am
++++ b/share/style/four_e_e/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-stylefour_e_edir = $(datadir)/style/four_e_e
++stylefour_e_edir = $(datadir)/balsa/style/four_e_e
+
+ stylefour_e_e_DATA = \
+ startup.scm \
+diff --git a/share/style/one_of_2_4/Makefile.am b/share/style/one_of_2_4/Makefile.am
+index ed02904..18d9201 100644
+--- a/share/style/one_of_2_4/Makefile.am
++++ b/share/style/one_of_2_4/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-styleone_of_2_4dir = $(datadir)/style/one_of_2_4
++styleone_of_2_4dir = $(datadir)/balsa/style/one_of_2_4
+
+ styleone_of_2_4_DATA = \
+ startup.scm \
+diff --git a/share/tech/common/Makefile.am b/share/tech/common/Makefile.am
+index 8a34646..0190b73 100644
+--- a/share/tech/common/Makefile.am
++++ b/share/tech/common/Makefile.am
+@@ -2,7 +2,7 @@
+
+ SUBDIRS =
+
+-techcommondir = $(datadir)/tech/common
++techcommondir = $(datadir)/balsa/tech/common
+
+ techcommon_DATA = \
+ components.abs \
diff --git a/sci-electronics/balsa/files/4.0-libdir.patch b/sci-electronics/balsa/files/4.0-libdir.patch
new file mode 100644
index 000000000000..9ba9739dc29f
--- /dev/null
+++ b/sci-electronics/balsa/files/4.0-libdir.patch
@@ -0,0 +1,36 @@
+diff --git a/share/balsa/parts/Makefile.am b/share/balsa/parts/Makefile.am
+index 6873e26..e168d70 100644
+--- a/share/balsa/parts/Makefile.am
++++ b/share/balsa/parts/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-balsapartsdir = $(datadir)/balsa/parts
++balsapartsdir = $(libdir)/balsa/parts
+
+ balsa_files = buffers.balsa counters.balsa
+ breeze_files = buffers.breeze counters.breeze
+diff --git a/share/balsa/sim/Makefile.am b/share/balsa/sim/Makefile.am
+index 2cd2932..233d2ec 100644
+--- a/share/balsa/sim/Makefile.am
++++ b/share/balsa/sim/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-balsasimdir = $(datadir)/balsa/sim
++balsasimdir = $(libdir)/balsa/sim
+
+ breeze_files = fileio.breeze string.breeze memory.breeze sim.breeze portio.breeze
+ balsa_files = fileio.balsa string.balsa memory.balsa sim.balsa portio.balsa
+diff --git a/share/balsa/types/Makefile.am b/share/balsa/types/Makefile.am
+index 475058a..317176f 100644
+--- a/share/balsa/types/Makefile.am
++++ b/share/balsa/types/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-balsatypesdir = $(datadir)/balsa/types
++balsatypesdir = $(libdir)/balsa/types
+
+ balsa_files = basic.balsa builtin.balsa synthesis.balsa types.balsa
+ breeze_files = basic.breeze builtin.breeze synthesis.breeze types.breeze