summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-07-08 02:17:02 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-07-08 02:17:02 +0000
commit434b5a9d62950c0077badfb90805b44f25468aef (patch)
tree8366aabc4e7c63d3a6dec21b3d230f74672b0aad /sci-geosciences/gpsd
parentadded ntp flag for gpsd time-sync (diff)
downloadgentoo-2-434b5a9d62950c0077badfb90805b44f25468aef.tar.gz
gentoo-2-434b5a9d62950c0077badfb90805b44f25468aef.tar.bz2
gentoo-2-434b5a9d62950c0077badfb90805b44f25468aef.zip
updated to latest upstream release and added a couple USE flags
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/ChangeLog7
-rw-r--r--sci-geosciences/gpsd/files/digest-gpsd-2.333
-rw-r--r--sci-geosciences/gpsd/gpsd-2.33.ebuild132
3 files changed, 141 insertions, 1 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 743a33b350cd..f1420481e2a9 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.16 2006/07/05 07:31:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.17 2006/07/08 02:17:02 nerdboy Exp $
+
+*gpsd-2.33 (08 Jul 2006)
+
+ 08 Jul 2006; Steve Arnold <nerdboy@gentoo.org> +gpsd-2.33.ebuild:
+ updated to latest upstream release and added a couple USE flags
05 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org> -gpsd-2.30-r1.ebuild:
clean old dep-broken ebuild
diff --git a/sci-geosciences/gpsd/files/digest-gpsd-2.33 b/sci-geosciences/gpsd/files/digest-gpsd-2.33
new file mode 100644
index 000000000000..3ebb820ad471
--- /dev/null
+++ b/sci-geosciences/gpsd/files/digest-gpsd-2.33
@@ -0,0 +1,3 @@
+MD5 03b57754091e4a34e27c78e1dc35c55e gpsd-2.33.tar.gz 639348
+RMD160 175b90cb8dda1d85964078a4f14cec84b0cc4885 gpsd-2.33.tar.gz 639348
+SHA256 e6a055689ad05f6adba7dbb9490891a18a240d1a30e34424b3a034f4152f2c28 gpsd-2.33.tar.gz 639348
diff --git a/sci-geosciences/gpsd/gpsd-2.33.ebuild b/sci-geosciences/gpsd/gpsd-2.33.ebuild
new file mode 100644
index 000000000000..41269408e92f
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-2.33.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.33.ebuild,v 1.1 2006/07/08 02:17:02 nerdboy Exp $
+
+inherit eutils libtool distutils
+
+DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients."
+HOMEPAGE="http://gpsd.berlios.de/"
+SRC_URI="http://download.berlios.de/gpsd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="dbus ntp static usb X"
+
+RDEPEND="X? ( || (
+ ( x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libXp
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXpm
+ x11-libs/libXaw )
+ || (
+ x11-libs/openmotif
+ x11-libs/lesstif
+ )
+ ( virtual/motif
+ virtual/x11 )
+ )
+ )
+ dev-lang/python
+ app-text/xmlto
+ dbus? ( >=sys-apps/dbus-0.6 )
+ ntp? ( net-misc/ntp )
+ usb? ( sys-apps/hotplug )"
+
+DEPEND="${RDEPEND}
+ X? ( || (
+ ( x11-proto/xproto x11-proto/xextproto )
+ virtual/x11
+ )
+ )"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ elibtoolize
+}
+
+src_compile() {
+ distutils_python_version
+
+ local my_conf="--enable-shared"
+
+ if ! use static; then
+ my_conf="${my_conf} --with-pic --disable-static"
+ else
+ my_conf="${my_conf} --enable-static"
+ fi
+
+ if ! use ntp; then
+ my_conf="${my_conf} --disable-ntpshm"
+ fi
+
+ econf ${my_conf} $(use_with X x) $(use_enable dbus) \
+ || die "econf failed"
+
+ emake LDFLAGS="${LDFLAGS} -lm" || die "emake failed"
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install
+
+ if use usb ; then
+ sed -i -e "s/gpsd.hotplug/gpsd/g" gpsd.hotplug gpsd.usermap
+ insinto /etc/hotplug/usb
+ doins gpsd.usermap
+ exeinto /etc/hotplug/usb
+ newexe gpsd.hotplug gpsd
+ else
+ newconfd ${FILESDIR}/gpsd.conf gpsd
+ newinitd ${FILESDIR}/gpsd.init gpsd
+ fi
+ if use X ; then
+ insinto /etc/X11/app-defaults
+ newins xgps.ad Xgps
+ newins xgpsspeed.ad Xgpsspeed
+ fi
+ dobin logextract
+ diropts "-m0644"
+ exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doexe gps.py gpsfake.py
+ dodoc AUTHORS HACKING INSTALL README TODO ${FILESDIR}/40-usb-serial.rules
+}
+
+pkg_postinst() {
+ einfo "To use hotplugging (USB devices) your kernel has to be compiled"
+ einfo "with CONFIG_HOTPLUG enabled and sys-apps/hotplug must be emerged"
+ einfo "(both usb and dbus support are optional)."
+ einfo
+ einfo "Different GPS devices require the corresponding kernel options"
+ einfo "to be enabled, such as USB_SERIAL_GARMIN, or a USB serial driver"
+ einfo "for an adapter such as those that come with Deluo GPS units (eg,"
+ einfo "USB_SERIAL_PL2303). Straight serial devices should always work,"
+ einfo "even without hotplug support."
+ ewarn
+ ewarn "If your client connection shows no data when gpsd is started via"
+ ewarn "the normal hotplug action, then kill the existing gpsd process"
+ ewarn "and try starting it directly via something like:"
+ ewarn "sudo /usr/sbin/gpsd -p /dev/ttyUSB0"
+ ewarn "or whatever your device is. This will verify whether your device"
+ ewarn "is working or not."
+ ewarn
+ einfo "Read the INSTALL doc for more information on supported hardware,"
+ einfo "and make sure udev has the right group permissions set on the tty"
+ einfo "devices if using USB (it should Do The Right Thing (TM))..."
+ einfo
+ einfo "Finally, the default gpsd setup looks for /dev/ttyUSB0, in the"
+ einfo "case of the USB-serial adapter mentioned above. Depending on"
+ einfo "your default device scheme (ie, udev, devfs, static), you may"
+ einfo "need to create a device alias if the default name is different."
+ einfo "A udev rule file has been provided with an example rule in the"
+ einfo "docs directory. If the device names are correct, gpsd will"
+ einfo "start automatically when the GPS device is plugged in."
+}