summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-04-09 18:06:48 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-04-09 18:06:48 +0000
commitc9269aba32a091a66a5e1933c977ec2138e015e2 (patch)
tree0dcf30618a7979eff69ad3b5824051b0874cf7f7 /sci-geosciences/marble
parentAdd missing deps wrt #216426 (diff)
downloadgentoo-2-c9269aba32a091a66a5e1933c977ec2138e015e2.tar.gz
gentoo-2-c9269aba32a091a66a5e1933c977ec2138e015e2.tar.bz2
gentoo-2-c9269aba32a091a66a5e1933c977ec2138e015e2.zip
Make dependencies compatible with split Qt:4.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'sci-geosciences/marble')
-rw-r--r--sci-geosciences/marble/ChangeLog7
-rw-r--r--sci-geosciences/marble/marble-0.4.ebuild12
2 files changed, 13 insertions, 6 deletions
diff --git a/sci-geosciences/marble/ChangeLog b/sci-geosciences/marble/ChangeLog
index 613dc0e635e0..d5bab87d73ef 100644
--- a/sci-geosciences/marble/ChangeLog
+++ b/sci-geosciences/marble/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-geosciences/marble
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/marble/ChangeLog,v 1.5 2007/10/30 13:52:46 cryos Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/marble/ChangeLog,v 1.6 2008/04/09 18:06:48 ingmar Exp $
+
+ 09 Apr 2008; Ingmar Vanhassel <ingmar@gentoo.org> marble-0.4.ebuild:
+ Make dependencies compatible with split Qt:4.
30 Oct 2007; Marcus D. Hanwell <cryos@gentoo.org> marble-0.4.ebuild:
Fix conditional error - always evaluated to true. Bug 197501.
diff --git a/sci-geosciences/marble/marble-0.4.ebuild b/sci-geosciences/marble/marble-0.4.ebuild
index 16cbfdc21509..1cbd74141f21 100644
--- a/sci-geosciences/marble/marble-0.4.ebuild
+++ b/sci-geosciences/marble/marble-0.4.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/marble/marble-0.4.ebuild,v 1.2 2007/10/30 13:52:46 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/marble/marble-0.4.ebuild,v 1.3 2008/04/09 18:06:48 ingmar Exp $
+EAPI="1"
inherit toolchain-funcs multilib
DESCRIPTION="Free 3D desk globe and world atlas"
@@ -13,7 +14,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=x11-libs/qt-4.2.3"
+RDEPEND="
+ || ( ( x11-libs/qt-gui:4
+ x11-libs/qt-svg:4 )
+ >=x11-libs/qt-4.2.3:4 )"
DEPEND="${RDEPEND}
>=dev-util/cmake-2.4.5"
@@ -36,5 +40,5 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
}