summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-11-22 13:36:55 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-11-22 13:36:55 +0000
commit53675c3b524ffc920100486ab8125f2a102f076b (patch)
treed32e090c1f517de32f7cb7aa75d0771fb9b63640 /sci-geosciences
parentfix random style issues (diff)
downloadgentoo-2-53675c3b524ffc920100486ab8125f2a102f076b.tar.gz
gentoo-2-53675c3b524ffc920100486ab8125f2a102f076b.tar.bz2
gentoo-2-53675c3b524ffc920100486ab8125f2a102f076b.zip
version bump, remove old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/osgearth/ChangeLog9
-rw-r--r--sci-geosciences/osgearth/files/osgearth-2.4-FindMiniZip.cmake.patch121
-rw-r--r--sci-geosciences/osgearth/files/osgearth-2.5-cmake-options.patch35
-rw-r--r--sci-geosciences/osgearth/osgearth-2.5.ebuild (renamed from sci-geosciences/osgearth/osgearth-2.4.ebuild)10
4 files changed, 50 insertions, 125 deletions
diff --git a/sci-geosciences/osgearth/ChangeLog b/sci-geosciences/osgearth/ChangeLog
index 1aa4db54c65e..4a673deccf65 100644
--- a/sci-geosciences/osgearth/ChangeLog
+++ b/sci-geosciences/osgearth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/osgearth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osgearth/ChangeLog,v 1.3 2013/11/03 12:02:48 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osgearth/ChangeLog,v 1.4 2013/11/22 13:36:54 hasufell Exp $
+
+*osgearth-2.5 (22 Nov 2013)
+
+ 22 Nov 2013; Julian Ospald <hasufell@gentoo.org>
+ +files/osgearth-2.5-cmake-options.patch, +osgearth-2.5.ebuild,
+ -files/osgearth-2.4-FindMiniZip.cmake.patch, -osgearth-2.4.ebuild:
+ version bump, remove old
03 Nov 2013; Julian Ospald <hasufell@gentoo.org> osgearth-2.4.ebuild:
fix dev-lang/v8 dep wrt #484786
diff --git a/sci-geosciences/osgearth/files/osgearth-2.4-FindMiniZip.cmake.patch b/sci-geosciences/osgearth/files/osgearth-2.4-FindMiniZip.cmake.patch
deleted file mode 100644
index 326a9b8c4cba..000000000000
--- a/sci-geosciences/osgearth/files/osgearth-2.4-FindMiniZip.cmake.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-commit 422e0901ddd760b230dc378e3b9359bd6d36200a
-Author: hasufell <hasufell@gentoo.org>
-Date: Sun Jul 21 18:59:14 2013 +0200
-
- BUILD: fix FindMiniZip.cmake module to use pkg-config
- https://github.com/gwaldron/osgearth/pull/340
-
-diff --git a/CMakeModules/FindMiniZip.cmake b/CMakeModules/FindMiniZip.cmake
-index c80ebbf..c8cae16 100644
---- a/CMakeModules/FindMiniZip.cmake
-+++ b/CMakeModules/FindMiniZip.cmake
-@@ -5,50 +5,65 @@
- # MINIZIP_INCLUDE_DIR, where to find the headers
- #
-
--FIND_PATH(MINIZIP_INCLUDE_DIR zip.h
-- ${CMAKE_SOURCE_DIR}/src/3rdparty/minizip
-- $ENV{MINIZIP_DIR}/include
-- $ENV{MINIZIP_DIR}
-- $ENV{OSGDIR}/include
-- $ENV{OSGDIR}
-- $ENV{OSG_ROOT}/include
-- ~/Library/Frameworks
-- /Library/Frameworks
-- /usr/local/include
-- /usr/include
-- /sw/include # Fink
-- /opt/local/include # DarwinPorts
-- /opt/csw/include # Blastwave
-- /opt/include
-- [HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Session\ Manager\\Environment;OSG_ROOT]/include
-- /usr/freeware/include
--)
-+# prefer pkg-config
-+IF(UNIX)
-+ INCLUDE(FindPkgConfig)
-+ IF(PKG_CONFIG_FOUND)
-+ pkg_check_modules(MINIZIP QUIET minizip)
-+ IF(MINIZIP_FOUND)
-+ # pkgconfig does not define the singular names
-+ SET(MINIZIP_LIBRARY ${MINIZIP_LIBRARIES})
-+ SET(MINIZIP_INCLUDE_DIR ${MINIZIP_INCLUDE_DIRS})
-+ ADD_DEFINITIONS(-DOSGEARTH_HAVE_MINIZIP)
-+ ENDIF(MINIZIP_FOUND)
-+ ENDIF(PKG_CONFIG_FOUND)
-+ENDIF(UNIX)
-
--FIND_LIBRARY(MINIZIP_LIBRARY
-- NAMES minizip
-- PATHS
-- ${CMAKE_SOURCE_DIR}/src/3rdparty/minizip
-- $ENV{MINIZIP_DIR}/lib
-- $ENV{MINIZIP_DIR}
-- $ENV{OSGDIR}/lib
-- $ENV{OSGDIR}
-- $ENV{OSG_ROOT}/lib
-- ~/Library/Frameworks
-- /Library/Frameworks
-- /usr/local/lib
-- /usr/lib
-- /sw/lib
-- /opt/local/lib
-- /opt/csw/lib
-- /opt/lib
-- [HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Session\ Manager\\Environment;OSG_ROOT]/lib
-- /usr/freeware/lib64
--)
--
--SET(MINIZIP_FOUND "NO")
--IF(MINIZIP_LIBRARY AND MINIZIP_INCLUDE_DIR)
-- SET(MINIZIP_FOUND "YES")
-- ADD_DEFINITIONS(-DOSGEARTH_HAVE_MINIZIP)
--ENDIF(MINIZIP_LIBRARY AND MINIZIP_INCLUDE_DIR)
-+# fallback logic
-+IF(NOT MINIZIP_FOUND)
-+ FIND_PATH(MINIZIP_INCLUDE_DIR zip.h
-+ ${CMAKE_SOURCE_DIR}/src/3rdparty/minizip
-+ $ENV{MINIZIP_DIR}/include
-+ $ENV{MINIZIP_DIR}
-+ $ENV{OSGDIR}/include
-+ $ENV{OSGDIR}
-+ $ENV{OSG_ROOT}/include
-+ ~/Library/Frameworks
-+ /Library/Frameworks
-+ /usr/local/include
-+ /usr/include
-+ /sw/include # Fink
-+ /opt/local/include # DarwinPorts
-+ /opt/csw/include # Blastwave
-+ /opt/include
-+ [HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Session\ Manager\\Environment;OSG_ROOT]/include
-+ /usr/freeware/include
-+ )
-
-+ FIND_LIBRARY(MINIZIP_LIBRARY
-+ NAMES minizip
-+ PATHS
-+ ${CMAKE_SOURCE_DIR}/src/3rdparty/minizip
-+ $ENV{MINIZIP_DIR}/lib
-+ $ENV{MINIZIP_DIR}
-+ $ENV{OSGDIR}/lib
-+ $ENV{OSGDIR}
-+ $ENV{OSG_ROOT}/lib
-+ ~/Library/Frameworks
-+ /Library/Frameworks
-+ /usr/local/lib
-+ /usr/lib
-+ /sw/lib
-+ /opt/local/lib
-+ /opt/csw/lib
-+ /opt/lib
-+ [HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Session\ Manager\\Environment;OSG_ROOT]/lib
-+ /usr/freeware/lib64
-+ )
-
-+ SET(MINIZIP_FOUND "NO")
-+ IF(MINIZIP_LIBRARY AND MINIZIP_INCLUDE_DIR)
-+ SET(MINIZIP_FOUND "YES")
-+ ADD_DEFINITIONS(-DOSGEARTH_HAVE_MINIZIP)
-+ ENDIF(MINIZIP_LIBRARY AND MINIZIP_INCLUDE_DIR)
-+ENDIF(NOT MINIZIP_FOUND)
diff --git a/sci-geosciences/osgearth/files/osgearth-2.5-cmake-options.patch b/sci-geosciences/osgearth/files/osgearth-2.5-cmake-options.patch
new file mode 100644
index 000000000000..a14ae658a7bd
--- /dev/null
+++ b/sci-geosciences/osgearth/files/osgearth-2.5-cmake-options.patch
@@ -0,0 +1,35 @@
+commit d92cee4d9870fab08fdfadf9ab0bfb4658a09aa3
+Author: hasufell <hasufell@gentoo.org>
+Date: Fri Nov 22 14:06:34 2013 +0100
+
+ add cmake options
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 34cd375..dbb4cb4 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -115,10 +115,20 @@ FIND_PACKAGE(Sqlite3)
+ FIND_PACKAGE(ZLIB)
+
+ SET(V8_DIR "" CACHE PATH "set to base V8 install path")
+-FIND_PACKAGE(V8)
+-
+-FIND_PACKAGE(JavaScriptCore)
+-FIND_PACKAGE(LibNoise)
++OPTION(OSGEARTH_USE_V8 "Enable to use V8 JavaScript engine" ON)
++IF(OSGEARTH_USE_V8)
++ FIND_PACKAGE(V8)
++ENDIF(OSGEARTH_USE_V8)
++
++OPTION(OSGEARTH_USE_JAVASCRIPTCORE "Enable use of JavaScriptCore" ON)
++OPTION(OSGEARTH_USE_LIBNOISE "Enable use of LibNoise" ON)
++
++IF (OSGEARTH_USE_JAVASCRIPTCORE)
++ FIND_PACKAGE(JavaScriptCore)
++ENDIF (OSGEARTH_USE_JAVASCRIPTCORE)
++IF (OSGEARTH_USE_LIBNOISE)
++ FIND_PACKAGE(LibNoise)
++ENDIF(OSGEARTH_USE_LIBNOISE)
+
+ FIND_PACKAGE(Qt4)
+ IF (QT4_FOUND)
diff --git a/sci-geosciences/osgearth/osgearth-2.4.ebuild b/sci-geosciences/osgearth/osgearth-2.5.ebuild
index 94ccaa9b997f..53ffc13da50a 100644
--- a/sci-geosciences/osgearth/osgearth-2.4.ebuild
+++ b/sci-geosciences/osgearth/osgearth-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osgearth/osgearth-2.4.ebuild,v 1.3 2013/11/03 12:02:48 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osgearth/osgearth-2.5.ebuild,v 1.1 2013/11/22 13:36:54 hasufell Exp $
EAPI=5
@@ -18,7 +18,6 @@ IUSE="doc qt4"
RDEPEND="
dev-db/sqlite:3
dev-games/openscenegraph[curl,qt4?]
- =dev-lang/v8-3.18.5.14
dev-libs/tinyxml
net-misc/curl
sci-libs/gdal
@@ -37,12 +36,17 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-${P}
-PATCHES=( "${FILESDIR}"/${P}-FindMiniZip.cmake.patch )
+PATCHES=( "${FILESDIR}"/${P}-cmake-options.patch )
src_configure() {
+ # V8 disabled due to
+ # https://github.com/gwaldron/osgearth/issues/333
local mycmakeargs=(
-DWITH_EXTERNAL_TINYXML=ON
$(cmake-utils_use qt4 OSGEARTH_USE_QT)
+ -DOSGEARTH_USE_V8=OFF
+ -DOSGEARTH_USE_JAVASCRIPTCORE=OFF
+ -DOSGEARTH_USE_LIBNOISE=OFF
)
cmake-utils_src_configure