summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-22 13:32:33 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-22 13:32:33 +0000
commitbc9f125416bb30b8eaf20de880fe7b488db017f6 (patch)
treecc3c883e82c92ac322ad3414c869e87d3a3aee54 /sci-geosciences
parentRemove entries for some treecleaned pkgs. (diff)
downloadgentoo-2-bc9f125416bb30b8eaf20de880fe7b488db017f6.tar.gz
gentoo-2-bc9f125416bb30b8eaf20de880fe7b488db017f6.tar.bz2
gentoo-2-bc9f125416bb30b8eaf20de880fe7b488db017f6.zip
Version Bump, #395271
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/ChangeLog8
-rw-r--r--sci-geosciences/qgis/metadata.xml13
-rw-r--r--sci-geosciences/qgis/qgis-1.7.3.ebuild97
3 files changed, 110 insertions, 8 deletions
diff --git a/sci-geosciences/qgis/ChangeLog b/sci-geosciences/qgis/ChangeLog
index fd8337855791..190c9e162c06 100644
--- a/sci-geosciences/qgis/ChangeLog
+++ b/sci-geosciences/qgis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/qgis
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.22 2011/08/07 12:04:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.23 2011/12/22 13:32:33 jlec Exp $
+
+*qgis-1.7.3 (22 Dec 2011)
+
+ 22 Dec 2011; Justin Lecher <jlec@gentoo.org> +qgis-1.7.3.ebuild,
+ metadata.xml:
+ Version Bump, #395271
07 Aug 2011; Markus Meier <maekke@gentoo.org> qgis-1.7.0.ebuild:
x86 stable, bug #375989
diff --git a/sci-geosciences/qgis/metadata.xml b/sci-geosciences/qgis/metadata.xml
index c7a4ff725300..04d4f42c5540 100644
--- a/sci-geosciences/qgis/metadata.xml
+++ b/sci-geosciences/qgis/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-geosciences</herd>
-<longdescription lang='en'>
+ <herd>sci-geosciences</herd>
+ <longdescription lang="en">
Quantum GIS (QGIS) is a user friendly Open Source Geographic
Information System (GIS). QGIS supports vector, raster, and database
formats. QGIS lets you browse and create map data on your
@@ -10,9 +10,8 @@
ShapeFile, geotiff). QGIS supports plugins to do things like display
tracks from your GPS.
</longdescription>
-<use>
- <flag name="grass">Add support for <pkg>sci-geosciences/grass</pkg></flag>
- <flag name="spatialite">Enable Spatial DBMS over sqlite <pkg>dev-db/spatialite</pkg></flag>
-</use>
+ <use>
+ <flag name="grass">Add support for <pkg>sci-geosciences/grass</pkg></flag>
+ <flag name="spatialite">Enable Spatial DBMS over sqlite <pkg>dev-db/spatialite</pkg></flag>
+ </use>
</pkgmetadata>
-
diff --git a/sci-geosciences/qgis/qgis-1.7.3.ebuild b/sci-geosciences/qgis/qgis-1.7.3.ebuild
new file mode 100644
index 000000000000..ceb4d191bbd9
--- /dev/null
+++ b/sci-geosciences/qgis/qgis-1.7.3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/qgis-1.7.3.ebuild,v 1.1 2011/12/22 13:32:33 jlec Exp $
+
+EAPI=3
+
+PYTHON_USE_WITH="sqlite"
+PYTHON_DEPEND="python? 2"
+inherit python base cmake-utils eutils
+
+DESCRIPTION="User friendly Geographic Information System"
+HOMEPAGE="http://www.qgis.org/"
+SRC_URI="http://qgis.org/downloads/${P}.tar.bz2
+ examples? ( http://download.osgeo.org/qgis/data/qgis_sample_data.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples gps grass gsl postgres python spatialite test"
+
+RDEPEND="
+ dev-libs/expat
+ sci-geosciences/gpsbabel
+ >=sci-libs/gdal-1.6.1[geos,python?]
+ sci-libs/geos
+ sci-libs/gsl
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-webkit:4
+ x11-libs/qwt:5[svg]
+ x11-libs/qwtpolar
+ grass? ( >=sci-geosciences/grass-6.4.0_rc6[python?] )
+ postgres? ( >=dev-db/postgresql-base-8.4 )
+ python? ( dev-python/PyQt4[X,sql,svg] )
+ spatialite? (
+ dev-db/sqlite:3
+ dev-db/spatialite
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+DOCS=( BUGS CHANGELOG CODING.pdf README )
+
+# Does not find the test binaries at all
+RESTRICT="test"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ "-DQGIS_MANUAL_SUBDIR=/share/man/"
+ "-DBUILD_SHARED_LIBS=ON"
+ "-DBINDINGS_GLOBAL_INSTALL=ON"
+ "-DQGIS_LIB_SUBDIR=$(get_libdir)"
+ "-DQGIS_PLUGIN_SUBDIR=$(get_libdir)/qgis"
+ "-DWITH_INTERNAL_SPATIALITE=OFF"
+ "-DWITH_INTERNAL_QWTPOLAR=OFF"
+ "-DPEDANTIC=OFF"
+ "-DWITH_APIDOC=OFF"
+ $(cmake-utils_use_with postgres POSTGRESQL)
+ $(cmake-utils_use_with grass GRASS)
+ $(cmake-utils_use_with python BINDINGS)
+ $(cmake-utils_use python BINDINGS_GLOBAL_INSTALL)
+ $(cmake-utils_use_with spatialite SPATIALITE)
+ $(cmake-utils_use_enable test TESTS)
+ )
+ use grass && mycmakeargs+=( "-DGRASS_PREFIX=/usr/" )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newicon images/icons/qgis-icon.png qgis.png || die
+ make_desktop_entry qgis "Quantum GIS" qgis
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${WORKDIR}"/qgis_sample_data/* || die "Unable to install examples"
+ fi
+}
+
+pkg_postinst() {
+ if use postgres; then
+ elog "If you don't intend to use an external PostGIS server"
+ elog "you should install:"
+ elog " dev-db/postgis"
+ fi
+}