summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 19:48:35 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 19:48:35 +0000
commitd886cbd1aff7342efa4954cf5566713fff499004 (patch)
tree930b7d96746cccd66d7bcfb9b5caa52f848d477a /sci-geosciences
parentAdded nopiessp support for gcc-4 (diff)
downloadgentoo-2-d886cbd1aff7342efa4954cf5566713fff499004.tar.gz
gentoo-2-d886cbd1aff7342efa4954cf5566713fff499004.tar.bz2
gentoo-2-d886cbd1aff7342efa4954cf5566713fff499004.zip
Correct handling of *FLAGS, thanks Martin von Gagern for providing the patch
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gmt/ChangeLog10
-rw-r--r--sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch78
-rw-r--r--sci-geosciences/gmt/gmt-4.0.ebuild22
-rw-r--r--sci-geosciences/gmt/gmt-4.1.1.ebuild22
-rw-r--r--sci-geosciences/gmt/gmt-4.5.0-r2.ebuild (renamed from sci-geosciences/gmt/gmt-4.5.0-r1.ebuild)18
5 files changed, 98 insertions, 52 deletions
diff --git a/sci-geosciences/gmt/ChangeLog b/sci-geosciences/gmt/ChangeLog
index 6b9e1f204dd3..03929a7f14ab 100644
--- a/sci-geosciences/gmt/ChangeLog
+++ b/sci-geosciences/gmt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-geosciences/gmt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/ChangeLog,v 1.20 2010/06/17 09:48:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/ChangeLog,v 1.21 2010/06/24 19:48:35 jlec Exp $
+
+*gmt-4.5.0-r2 (24 Jun 2010)
+
+ 24 Jun 2010; Justin Lecher <jlec@gentoo.org> gmt-4.0.ebuild,
+ gmt-4.1.1.ebuild, -gmt-4.5.0-r1.ebuild, +gmt-4.5.0-r2.ebuild,
+ files/gmt-4.5.0-no-strip.patch:
+ Correct handling of *FLAGS, thanks Martin von Gagern for providing the
+ patch
17 Jun 2010; Justin Lecher <jlec@gentoo.org> gmt-4.0.ebuild,
gmt-4.1.1.ebuild, gmt-4.5.0-r1.ebuild:
diff --git a/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch b/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch
index 463133c657df..f0fe4c3e833e 100644
--- a/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch
+++ b/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch
@@ -1,24 +1,62 @@
-diff -ur GMT4.5.0.orig/configure GMT4.5.0/configure
---- GMT4.5.0.orig/configure 2009-07-26 12:11:29.000000000 +0200
-+++ GMT4.5.0/configure 2009-07-26 12:14:56.000000000 +0200
-@@ -11284,8 +11284,6 @@
- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
- if test "$os" = "Darwin" ; then
- LDFLAGS="$LDFLAGS -Wl,-x"
+Drop manipulation of several flags:
+
+* stripping of -g from CFLAGS, as it interferes with deliberate
+ generation of debug symbols and breaks on flags like -ggdb.
+* Addition of -s resp. -Wl,-x to LDFLAGS, as stipping of binaries is
+ done as a separate step on Gentoo (and many other distros) in order
+ to faciliate retention or splitting of debug symbols.
+* Setting of optimization flags, as the user should be free to choose
+ them.
+
+2009-07-27 Martin von Gagern
+
+Reference: http://bugs.gentoo.org/279268
+
+Index: GMT4.5.0/configure
+===================================================================
+--- GMT4.5.0.orig/configure
++++ GMT4.5.0/configure
+@@ -10665,19 +10665,6 @@ if test "X$enable_debug" = "Xyes" ; then
+ echo "${ECHO_T}yes" >&6; }
+ CFLAGS="$CFLAGS -g"
+ else
+- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
+- if test "$os" = "Darwin" ; then
+- LDFLAGS="$LDFLAGS -Wl,-x"
- else
- LDFLAGS="$LDFLAGS -s"
- fi
- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
- CFLAGS="$CFLAGS -O2"
-diff -ur GMT4.5.0.orig/configure.ac GMT4.5.0/configure.ac
---- GMT4.5.0.orig/configure.ac 2009-07-26 12:11:29.000000000 +0200
-+++ GMT4.5.0/configure.ac 2009-07-26 12:15:15.000000000 +0200
-@@ -530,8 +530,6 @@
- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
- if test "$os" = "Darwin" ; then
- LDFLAGS="$LDFLAGS -Wl,-x"
+- fi
+- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
+- CFLAGS="$CFLAGS -O2"
+- elif test "$chip" = "alpha" || test "$os" = "AUX" || test "$os" = "HP-UX"; then
+- CFLAGS="$CFLAGS"
+- else
+- CFLAGS="$CFLAGS -O"
+- fi
+ { echo "$as_me:$LINENO: result: no" >&5
+ echo "${ECHO_T}no" >&6; }
+ fi
+Index: GMT4.5.0/configure.ac
+===================================================================
+--- GMT4.5.0.orig/configure.ac
++++ GMT4.5.0/configure.ac
+@@ -527,19 +527,6 @@ if test "X$enable_debug" = "Xyes" ; then
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -g"
+ else
+- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
+- if test "$os" = "Darwin" ; then
+- LDFLAGS="$LDFLAGS -Wl,-x"
- else
- LDFLAGS="$LDFLAGS -s"
- fi
- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
- CFLAGS="$CFLAGS -O2"
+- fi
+- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
+- CFLAGS="$CFLAGS -O2"
+- elif test "$chip" = "alpha" || test "$os" = "AUX" || test "$os" = "HP-UX"; then
+- CFLAGS="$CFLAGS"
+- else
+- CFLAGS="$CFLAGS -O"
+- fi
+ AC_MSG_RESULT(no)
+ fi
+ dnl -----------------------------------------------------------------
diff --git a/sci-geosciences/gmt/gmt-4.0.ebuild b/sci-geosciences/gmt/gmt-4.0.ebuild
index d41674f57eaf..a2b0385f6e10 100644
--- a/sci-geosciences/gmt/gmt-4.0.ebuild
+++ b/sci-geosciences/gmt/gmt-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/gmt-4.0.ebuild,v 1.7 2010/06/17 09:48:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/gmt-4.0.ebuild,v 1.8 2010/06/24 19:48:35 jlec Exp $
inherit multilib
@@ -8,16 +8,16 @@ MAINV="${PV:0:1}"
DESCRIPTION="Powerful map generator"
HOMEPAGE="http://gmt.soest.hawaii.edu/"
-SRC_URI="ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_progs.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT_share.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_tut.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_scripts.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_man.tar.bz2
- doc? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_pdf.tar.bz2 )
- gmtsuppl? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_suppl.tar.bz2 )
- gmtfull? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT_full.tar.bz2 )
- gmthigh? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT_high.tar.bz2 )
- gmttria? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/triangle.tar.bz2 )"
+SRC_URI="mirror://gmt/${MAINV}/GMT${PV}_progs.tar.bz2
+ mirror://gmt/${MAINV}/GMT_share.tar.bz2
+ mirror://gmt/${MAINV}/GMT${PV}_tut.tar.bz2
+ mirror://gmt/${MAINV}/GMT${PV}_scripts.tar.bz2
+ mirror://gmt/${MAINV}/GMT${PV}_man.tar.bz2
+ doc? ( mirror://gmt/${MAINV}/GMT${PV}_pdf.tar.bz2 )
+ gmtsuppl? ( mirror://gmt/${MAINV}/GMT${PV}_suppl.tar.bz2 )
+ gmtfull? ( mirror://gmt/${MAINV}/GMT_full.tar.bz2 )
+ gmthigh? ( mirror://gmt/${MAINV}/GMT_high.tar.bz2 )
+ gmttria? ( mirror://gmt/${MAINV}/triangle.tar.bz2 )"
# Needed because GMT_share in version 3 is different of that one in version 4, but they have same name.
# Emailed one of the authors (Paul Wessel) who gave us permission to mirror
diff --git a/sci-geosciences/gmt/gmt-4.1.1.ebuild b/sci-geosciences/gmt/gmt-4.1.1.ebuild
index fb2b01ee1ef2..7c9edcf3a59a 100644
--- a/sci-geosciences/gmt/gmt-4.1.1.ebuild
+++ b/sci-geosciences/gmt/gmt-4.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/gmt-4.1.1.ebuild,v 1.2 2010/06/17 09:48:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/gmt-4.1.1.ebuild,v 1.3 2010/06/24 19:48:35 jlec Exp $
inherit multilib
@@ -8,16 +8,16 @@ MAINV="${PV:0:1}"
DESCRIPTION="Powerful map generator"
HOMEPAGE="http://gmt.soest.hawaii.edu/"
-SRC_URI="ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_progs.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT_share.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_tut.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_scripts.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_man.tar.bz2
- doc? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_pdf.tar.bz2 )
- gmtsuppl? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT${PV}_suppl.tar.bz2 )
- gmtfull? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT_full.tar.bz2 )
- gmthigh? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/GMT_high.tar.bz2 )
- gmttria? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${MAINV}/triangle.tar.bz2 )"
+SRC_URI="mirror://gmt/${MAINV}/GMT${PV}_progs.tar.bz2
+ mirror://gmt/${MAINV}/GMT_share.tar.bz2
+ mirror://gmt/${MAINV}/GMT${PV}_tut.tar.bz2
+ mirror://gmt/${MAINV}/GMT${PV}_scripts.tar.bz2
+ mirror://gmt/${MAINV}/GMT${PV}_man.tar.bz2
+ doc? ( mirror://gmt/${MAINV}/GMT${PV}_pdf.tar.bz2 )
+ gmtsuppl? ( mirror://gmt/${MAINV}/GMT${PV}_suppl.tar.bz2 )
+ gmtfull? ( mirror://gmt/${MAINV}/GMT_full.tar.bz2 )
+ gmthigh? ( mirror://gmt/${MAINV}/GMT_high.tar.bz2 )
+ gmttria? ( mirror://gmt/${MAINV}/triangle.tar.bz2 )"
# Needed because GMT_share in version 3 is different of that one in version 4, but they have same name.
LICENSE="GPL-2"
diff --git a/sci-geosciences/gmt/gmt-4.5.0-r1.ebuild b/sci-geosciences/gmt/gmt-4.5.0-r2.ebuild
index 4df2f36af5f3..56de1b49f2bf 100644
--- a/sci-geosciences/gmt/gmt-4.5.0-r1.ebuild
+++ b/sci-geosciences/gmt/gmt-4.5.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/gmt-4.5.0-r1.ebuild,v 1.2 2010/06/17 09:48:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/gmt-4.5.0-r2.ebuild,v 1.1 2010/06/24 19:48:35 jlec Exp $
inherit multilib autotools eutils
@@ -8,14 +8,14 @@ GSHHS="GSHHS2.0"
DESCRIPTION="Powerful map generator"
HOMEPAGE="http://gmt.soest.hawaii.edu/"
-SRC_URI="ftp://falcon.grdl.noaa.gov/pub/gmt/GMT${PV}_src.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/GMT${PV}_share.tar.bz2
- ftp://falcon.grdl.noaa.gov/pub/gmt/${GSHHS}_coast.tar.bz2
- doc? ( ftp://falcon.grdl.noaa.gov/pub/gmt/GMT${PV}_doc.tar.bz2 )
- gmtsuppl? ( ftp://falcon.grdl.noaa.gov/pub/gmt/GMT${PV}_suppl.tar.bz2 )
- gmtfull? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${GSHHS}_full.tar.bz2 )
- gmthigh? ( ftp://falcon.grdl.noaa.gov/pub/gmt/${GSHHS}_high.tar.bz2 )
- gmttria? ( ftp://falcon.grdl.noaa.gov/pub/gmt/GMT${PV}_triangle.tar.bz2 )"
+SRC_URI="mirror://gmt/GMT${PV}_src.tar.bz2
+ mirror://gmt/GMT${PV}_share.tar.bz2
+ mirror://gmt/${GSHHS}_coast.tar.bz2
+ doc? ( mirror://gmt/GMT${PV}_doc.tar.bz2 )
+ gmtsuppl? ( mirror://gmt/GMT${PV}_suppl.tar.bz2 )
+ gmtfull? ( mirror://gmt/${GSHHS}_full.tar.bz2 )
+ gmthigh? ( mirror://gmt/${GSHHS}_high.tar.bz2 )
+ gmttria? ( mirror://gmt/GMT${PV}_triangle.tar.bz2 )"
LICENSE="GPL-2"
SLOT="0"