summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-08-18 17:13:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-08-18 17:13:26 +0000
commit1ec6641f9e9c2c5b3096ac54779334d1fd0125e1 (patch)
treede6b88e7d2d653989507dff481e9d63595c82051 /sci-libs/amd/amd-2.2.0.ebuild
parentVersion bump as per bug 141752. (diff)
downloadgentoo-2-1ec6641f9e9c2c5b3096ac54779334d1fd0125e1.tar.gz
gentoo-2-1ec6641f9e9c2c5b3096ac54779334d1fd0125e1.tar.bz2
gentoo-2-1ec6641f9e9c2c5b3096ac54779334d1fd0125e1.zip
Version bump, and fixed the patch for tests
(Portage version: 2.1.2.11)
Diffstat (limited to 'sci-libs/amd/amd-2.2.0.ebuild')
-rw-r--r--sci-libs/amd/amd-2.2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/amd/amd-2.2.0.ebuild b/sci-libs/amd/amd-2.2.0.ebuild
new file mode 100644
index 000000000000..da7ab21d4598
--- /dev/null
+++ b/sci-libs/amd/amd-2.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/amd-2.2.0.ebuild,v 1.1 2007/08/18 17:13:26 bicatali Exp $
+
+inherit autotools eutils fortran
+
+MY_PN=AMD
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/amd"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+DEPEND="sci-libs/ufconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+FORTRAN="gfortran g77 ifc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || "emake install failed"
+ dodoc README.txt Doc/ChangeLog || "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/AMD_UserGuide.pdf || "doc install failed"
+ fi
+}