summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-01-03 05:33:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-01-03 05:33:16 +0000
commit1fea6b66ef85fbc0df6e0109dc80d47c288857f1 (patch)
tree1446393fb277649e28c8c63d2d1d02cbed482d15 /sci-libs/armadillo
parentUse generic pkg-config (diff)
downloadgentoo-2-1fea6b66ef85fbc0df6e0109dc80d47c288857f1.tar.gz
gentoo-2-1fea6b66ef85fbc0df6e0109dc80d47c288857f1.tar.bz2
gentoo-2-1fea6b66ef85fbc0df6e0109dc80d47c288857f1.zip
Use generic pkg-config
(Portage version: 2.2.01.21476-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/armadillo')
-rw-r--r--sci-libs/armadillo/ChangeLog8
-rw-r--r--sci-libs/armadillo/armadillo-3.0.2.ebuild52
-rw-r--r--sci-libs/armadillo/armadillo-3.4.4.ebuild10
3 files changed, 11 insertions, 59 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index 72c6cd0ace0b..0dc2be7cd2fd 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/armadillo
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.24 2012/12/25 03:26:02 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.25 2013/01/03 05:33:16 bicatali Exp $
+
+ 03 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org> -armadillo-3.0.2.ebuild,
+ armadillo-3.4.4.ebuild:
+ Use generic pkg-config
25 Dec 2012; Jeff Horelick <jdhore@gentoo.org> armadillo-3.4.4.ebuild:
marked x86 per bug 447130
diff --git a/sci-libs/armadillo/armadillo-3.0.2.ebuild b/sci-libs/armadillo/armadillo-3.0.2.ebuild
deleted file mode 100644
index 0e33904d78d1..000000000000
--- a/sci-libs/armadillo/armadillo-3.0.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.0.2.ebuild,v 1.5 2012/12/16 10:55:08 jlec Exp $
-
-EAPI=4
-
-CMAKE_IN_SOURCE_BUILD=1
-
-inherit cmake-utils
-
-DESCRIPTION="Streamlined C++ linear algebra library"
-HOMEPAGE="http://arma.sourceforge.net/"
-SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="blas doc lapack"
-
-RDEPEND=">=dev-libs/boost-1.34
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )"
-
-DEPEND="${DEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- # avoid the automagic cmake macros
- sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=()
- if use blas; then
- mycmakeargs+=(
- -DBLAS_FOUND=ON
- -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
- )
- fi
- if use lapack; then
- mycmakeargs+=(
- -DLAPACK_FOUND=ON
- -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
- )
- fi
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- use doc && dodoc docs/*pdf
-}
diff --git a/sci-libs/armadillo/armadillo-3.4.4.ebuild b/sci-libs/armadillo/armadillo-3.4.4.ebuild
index 22d13354b50b..8bd2db2bf79a 100644
--- a/sci-libs/armadillo/armadillo-3.4.4.ebuild
+++ b/sci-libs/armadillo/armadillo-3.4.4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.4.4.ebuild,v 1.5 2012/12/25 03:26:02 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.4.4.ebuild,v 1.6 2013/01/03 05:33:16 bicatali Exp $
EAPI=4
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake-utils
+inherit cmake-utils toolchain-funcs
DESCRIPTION="Streamlined C++ linear algebra library"
HOMEPAGE="http://arma.sourceforge.net/"
@@ -35,13 +35,13 @@ src_configure() {
if use blas; then
mycmakeargs+=(
-DBLAS_FOUND=ON
- -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ -DBLAS_LIBRARIES="$($(tc-getPKGCONFIG) --libs blas)"
)
fi
if use lapack; then
mycmakeargs+=(
-DLAPACK_FOUND=ON
- -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+ -DLAPACK_LIBRARIES="$($(tc-getPKGCONFIG) --libs lapack)"
)
fi
cmake-utils_src_configure