summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-06-28 10:31:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-06-28 10:31:39 +0000
commit85fb22309b3a616d21ab4fa06ab3e076eaae570d (patch)
treecb1e6dfd16f95e658c01382c1c58fbf6f2c18dd1 /sci-libs/fftw
parentFix beta8 digest - again! (diff)
downloadgentoo-2-85fb22309b3a616d21ab4fa06ab3e076eaae570d.tar.gz
gentoo-2-85fb22309b3a616d21ab4fa06ab3e076eaae570d.tar.bz2
gentoo-2-85fb22309b3a616d21ab4fa06ab3e076eaae570d.zip
Add src_test support for fftw.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/ChangeLog5
-rw-r--r--sci-libs/fftw/fftw-3.1.1.ebuild27
2 files changed, 25 insertions, 7 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index d0bead6137e6..fc71e787ea81 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/fftw
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.34 2006/06/24 14:21:49 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.35 2006/06/28 10:31:39 robbat2 Exp $
+
+ 28 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> fftw-3.1.1.ebuild:
+ Add src_test support for fftw.
24 Jun 2006; Markus Dittrich <markusle@gentoo.org> fftw-3.0.1-r2.ebuild,
fftw-3.1.1.ebuild:
diff --git a/sci-libs/fftw/fftw-3.1.1.ebuild b/sci-libs/fftw/fftw-3.1.1.ebuild
index 4755b4dfab68..5f51ec5ce5eb 100644
--- a/sci-libs/fftw/fftw-3.1.1.ebuild
+++ b/sci-libs/fftw/fftw-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.1.1.ebuild,v 1.6 2006/06/24 14:21:49 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.1.1.ebuild,v 1.7 2006/06/28 10:31:39 robbat2 Exp $
inherit flag-o-matic eutils toolchain-funcs autotools
@@ -11,9 +11,9 @@ SRC_URI="http://www.fftw.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="3.0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
-IUSE="altivec sse sse2"
+IUSE="altivec sse sse2 test"
-DEPEND=""
+DEPEND="test? ( dev-lang/perl )"
src_unpack() {
unpack ${A}
@@ -87,13 +87,13 @@ src_install () {
#all builds are installed in the same place
#libs have distinuguished names; include files, docs etc. identical.
cd "${S}-single"
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
cd "${S}-double"
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
cd "${S}-longdouble"
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
# Install documentation.
cd "${S}-single"
@@ -103,3 +103,18 @@ src_install () {
cd doc/html
dohtml -r .
}
+
+src_test () {
+ # We want this to be a reasonably quick test, but that is still hard...
+ ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
+ # Do not increase the number of threads, it will not help your performance
+ local testbase="perl check.pl --nthreads=1 --estimate"
+ for d in single double longdouble; do
+ cd "${S}-${d}"/tests
+ for p in 0 1 2; do
+ n="${d/longdouble/long double} / ${p}-D"
+ einfo "Testing $n"
+ ${testbase} -${p}d || die "Failure: $n"
+ done
+ done
+}