summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-05-11 07:15:32 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-05-11 07:15:32 +0000
commit4c04fe61e129bf8c74b7d9419631a6ca3d248105 (patch)
tree1315475fdc83af43a28ab15a6ea7abb3d1602a0a /sci-libs/hdf
parentadded new version fixes bug #268771 (diff)
downloadgentoo-2-4c04fe61e129bf8c74b7d9419631a6ca3d248105.tar.gz
gentoo-2-4c04fe61e129bf8c74b7d9419631a6ca3d248105.tar.bz2
gentoo-2-4c04fe61e129bf8c74b7d9419631a6ca3d248105.zip
Updated build config for gfortran and ferret.
(Portage version: 2.2_rc32/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/hdf')
-rw-r--r--sci-libs/hdf/ChangeLog5
-rw-r--r--sci-libs/hdf/hdf-4.2.0-r4.ebuild25
2 files changed, 22 insertions, 8 deletions
diff --git a/sci-libs/hdf/ChangeLog b/sci-libs/hdf/ChangeLog
index 7fc62d92b28e..a66255fe228a 100644
--- a/sci-libs/hdf/ChangeLog
+++ b/sci-libs/hdf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/hdf
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/ChangeLog,v 1.11 2009/04/16 22:16:12 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/ChangeLog,v 1.12 2009/05/11 07:15:32 nerdboy Exp $
+
+ 11 May 2009; Steve Arnold <nerdboy@gentoo.org> hdf-4.2.0-r4.ebuild:
+ Updated build config for gfortran and ferret.
16 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Re-manifesting for good patch this time - Also updated description.
diff --git a/sci-libs/hdf/hdf-4.2.0-r4.ebuild b/sci-libs/hdf/hdf-4.2.0-r4.ebuild
index 61f088b99bf1..3c1afe273fe2 100644
--- a/sci-libs/hdf/hdf-4.2.0-r4.ebuild
+++ b/sci-libs/hdf/hdf-4.2.0-r4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/hdf-4.2.0-r4.ebuild,v 1.4 2006/11/23 20:44:38 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/hdf-4.2.0-r4.ebuild,v 1.5 2009/05/11 07:15:32 nerdboy Exp $
-inherit autotools flag-o-matic fortran
+inherit autotools eutils flag-o-matic fortran toolchain-funcs
# substitute second dot by "r"
MY_PV="${PV/./X}"
@@ -25,7 +25,9 @@ DEPEND="sys-libs/zlib
>=sys-apps/sed-4
szip? ( sci-libs/szip )"
-FORTRAN="g77 gfortran"
+pkg_setup() {
+ fortran_pkg_setup
+}
src_unpack() {
unpack ${A}
@@ -41,16 +43,25 @@ src_compile() {
# BUG #75415, the shipped config/linux-gnu settings are broken.
# -Wsign-compare does not work with g77, causing lack of -fPIC for shared
# objects.
- sed -e 's|-Wsign-compare||g' -i "${S}"/config/linux-gnu || die
+ sed -i \
+ -e 's|-Wsign-compare||g' \
+ -e "s|/some/default/compiler/named/foo|$(tc-getCXX)|" \
+ -e "s|BASENAME=foo|$(tc-getCXX)|" \
+ -e "s|CC=gcc|CC=$(tc-getCC)|" \
+ -e "s|CC_BASENAME=gcc|CC_BASENAME=$(tc-getCC)|" \
+ -e "s|F77=g77|F77=${FORTRANC}|" \
+ -e "s|F77_BASENAME=g77|F77_BASENAME=${FORTRANC}|" \
+ -e "s|-O3 -fomit-frame-pointer|${CFLAGS}|" \
+ "${S}"/config/linux-gnu || die
- local myconf="--enable-production"
+ local myconf="--enable-production --with-fortran"
use szip && myconf="${myconf} --with-szlib=/usr"
use ppc && append-flags -DSUN
econf \
${myconf} \
- F77="${FORTRANC}" \
+ F77="${FORTRANC} -fno-second-underscore -std=legacy -ff2c" \
|| die "configure failed"
make LDFLAGS="${LDFLAGS} -lm" || die "make failed"