summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-06-09 03:17:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-06-09 03:17:04 +0000
commit851569e84fa3bf6bbfe9d910c7317e047f2c977f (patch)
tree396b1bf1e18bd0dabf4770329e7deedb2ae820d5 /sci-libs/hypre
parentVersion bump (diff)
downloadgentoo-2-851569e84fa3bf6bbfe9d910c7317e047f2c977f.tar.gz
gentoo-2-851569e84fa3bf6bbfe9d910c7317e047f2c977f.tar.bz2
gentoo-2-851569e84fa3bf6bbfe9d910c7317e047f2c977f.zip
Fixed underlinking (bug #493222) and enabling MPI (bug #508030) thanks Matthias Maier
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/hypre')
-rw-r--r--sci-libs/hypre/ChangeLog6
-rw-r--r--sci-libs/hypre/hypre-2.9.0b.ebuild33
2 files changed, 14 insertions, 25 deletions
diff --git a/sci-libs/hypre/ChangeLog b/sci-libs/hypre/ChangeLog
index 1594b0d478f6..01f6d3937cf7 100644
--- a/sci-libs/hypre/ChangeLog
+++ b/sci-libs/hypre/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/hypre
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hypre/ChangeLog,v 1.13 2014/04/22 17:27:16 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hypre/ChangeLog,v 1.14 2014/06/09 03:17:04 bicatali Exp $
+
+ 09 Jun 2014; Sébastien Fabbro <bicatali@gentoo.org> hypre-2.9.0b.ebuild:
+ Fixed underlinking (bug #493222) and enabling MPI (bug #508030) thanks
+ Matthias Maier
22 Apr 2014; Sébastien Fabbro <bicatali@gentoo.org> -hypre-2.8.0b-r1.ebuild,
hypre-2.9.0b.ebuild:
diff --git a/sci-libs/hypre/hypre-2.9.0b.ebuild b/sci-libs/hypre/hypre-2.9.0b.ebuild
index 43ae648d8a23..ef4905931018 100644
--- a/sci-libs/hypre/hypre-2.9.0b.ebuild
+++ b/sci-libs/hypre/hypre-2.9.0b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hypre/hypre-2.9.0b.ebuild,v 1.3 2014/04/22 17:27:16 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hypre/hypre-2.9.0b.ebuild,v 1.4 2014/06/09 03:17:04 bicatali Exp $
EAPI=5
@@ -15,14 +15,12 @@ SRC_URI="https://computation.llnl.gov/casc/hypre/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="blas doc examples fortran lapack mpi"
-
-REQUIRED_USE="mpi? ( fortran lapack )"
+IUSE="doc examples fortran mpi"
RDEPEND="
sci-libs/superlu:0=
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
+ virtual/blas
+ virtual/lapack
mpi? ( virtual/mpi )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -50,29 +48,16 @@ src_prepare() {
}
src_configure() {
- local myeconfargs+=(
+ local myeconfargs=(
--enable-shared
--without-superlu
- --without-strict-checking
+ --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')"
+ --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')"
+ --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')"
+ --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')"
$(use_enable fortran)
$(use_with mpi MPI)
)
- if use blas; then
- myeconfargs+=(
- --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')"
- --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')"
- )
- else
- myeconfargs+=( --without-blas )
- fi
- if use lapack; then
- myeconfargs+=(
- --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')"
- --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')"
- )
- else
- myeconfargs+=( --without-lapack )
- fi
econf "${myeconfargs[@]}"
}