summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-15 10:39:04 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-15 10:39:04 +0000
commitdfc265893cac6183cfd5bcb9bda541642b8f979f (patch)
tree881c0e7cdf0af2f9e73728dc9395ed550b0b9c01 /sci-libs/itpp
parentsci-biology/infernal: Cleaned old (diff)
downloadgentoo-2-dfc265893cac6183cfd5bcb9bda541642b8f979f.tar.gz
gentoo-2-dfc265893cac6183cfd5bcb9bda541642b8f979f.tar.bz2
gentoo-2-dfc265893cac6183cfd5bcb9bda541642b8f979f.zip
sci-libs/itpp: Fixes to automake-1.12 patch
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog6
-rw-r--r--sci-libs/itpp/files/itpp-4.2-automake-1.12.patch14
-rw-r--r--sci-libs/itpp/itpp-4.2-r1.ebuild7
3 files changed, 16 insertions, 11 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index bdd4f10892c6..503cfb616c2c 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.112 2012/07/06 07:45:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.113 2012/07/15 10:39:04 jlec Exp $
+
+ 15 Jul 2012; Justin Lecher <jlec@gentoo.org> itpp-4.2-r1.ebuild,
+ files/itpp-4.2-automake-1.12.patch:
+ Fixes to automake-1.12 patch
06 Jul 2012; Justin Lecher <jlec@gentoo.org> itpp-4.0.6.ebuild,
itpp-4.2-r1.ebuild, +files/itpp-4.2-automake-1.12.patch:
diff --git a/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch b/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch
index aa8723b215a5..f383d6fda591 100644
--- a/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch
+++ b/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch
@@ -2,15 +2,15 @@
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 4f06171..84044ff 100644
+index 4f06171..a1e8448 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -104,6 +104,8 @@ case $enable_explicit_deps in
- esac
- AC_MSG_RESULT($enable_explicit_deps)
+@@ -27,6 +27,8 @@ AC_CONFIG_MACRO_DIR([m4])
+ AC_CONFIG_AUX_DIR([build-aux])
+ AM_INIT_AUTOMAKE([-Wall -Werror])
+AM_PROG_AR
+
- # Set default language to C++
- AC_LANG([C++])
-
+ # Shared library versioning
+ GENERIC_LIBRARY_VERSION="7:0:0"
+ # | | |
diff --git a/sci-libs/itpp/itpp-4.2-r1.ebuild b/sci-libs/itpp/itpp-4.2-r1.ebuild
index 041e4d32c0ed..a58fb8ed140b 100644
--- a/sci-libs/itpp/itpp-4.2-r1.ebuild
+++ b/sci-libs/itpp/itpp-4.2-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.12 2012/07/06 07:45:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.13 2012/07/15 10:39:04 jlec Exp $
EAPI=4
+AUTOTOOLS_AUTORECONF=yes
+
inherit autotools-utils flag-o-matic
DESCRIPTION="C++ library of mathematical, signal processing and communication"
@@ -32,13 +34,12 @@ PATCHES=(
src_prepare() {
# turn off performance critical debug code
- use debug || append-flags -DNDEBUG
+ use debug || append-cppflags -DNDEBUG
sed \
-e 's:-pipe::g' \
-e 's:-Werror::g' \
-i configure* || die
autotools-utils_src_prepare
- AT_NOELIBTOOLIZE=yes eautoreconf
}
src_configure() {