summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 08:26:53 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 08:26:53 +0000
commit41ad98ebfc8655cde70a0d8221fe18cb7aa78454 (patch)
tree0dfb3dbb21f7d756dd7e22fe2d05a8668400a350 /sci-libs/libbufr
parentAdded fortran-2.eclass support (diff)
downloadgentoo-2-41ad98ebfc8655cde70a0d8221fe18cb7aa78454.tar.gz
gentoo-2-41ad98ebfc8655cde70a0d8221fe18cb7aa78454.tar.bz2
gentoo-2-41ad98ebfc8655cde70a0d8221fe18cb7aa78454.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libbufr')
-rw-r--r--sci-libs/libbufr/ChangeLog6
-rw-r--r--sci-libs/libbufr/libbufr-000360.ebuild9
-rw-r--r--sci-libs/libbufr/libbufr-000387.ebuild9
3 files changed, 15 insertions, 9 deletions
diff --git a/sci-libs/libbufr/ChangeLog b/sci-libs/libbufr/ChangeLog
index 609f01439b70..7b7b19c2beb7 100644
--- a/sci-libs/libbufr/ChangeLog
+++ b/sci-libs/libbufr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/libbufr
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/ChangeLog,v 1.6 2011/05/14 19:01:34 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/ChangeLog,v 1.7 2011/06/21 08:26:53 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> libbufr-000360.ebuild,
+ libbufr-000387.ebuild:
+ Added fortran-2.eclass support
14 May 2011; Steve Arnold <nerdboy@gentoo.org> libbufr-000387.ebuild:
Updated test file generation (note: do not remove blanks).
diff --git a/sci-libs/libbufr/libbufr-000360.ebuild b/sci-libs/libbufr/libbufr-000360.ebuild
index 15dba7e31300..4ddcfd95e104 100644
--- a/sci-libs/libbufr/libbufr-000360.ebuild
+++ b/sci-libs/libbufr/libbufr-000360.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/libbufr-000360.ebuild,v 1.6 2011/03/17 15:02:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/libbufr-000360.ebuild,v 1.7 2011/06/21 08:26:53 jlec Exp $
-EAPI="2"
+EAPI=2
-inherit eutils flag-o-matic toolchain-funcs
+inherit eutils fortran-2 flag-o-matic toolchain-funcs
MY_P="${PN/lib/}_${PV}"
-DESCRIPTION="ECMWF BUFR library - includes both C and Fortran example utilities."
+DESCRIPTION="ECMWF BUFR library - includes both C and Fortran example utilities"
HOMEPAGE="http://www.ecmwf.int/products/data/software/bufr.html"
SRC_URI="http://www.ecmwf.int/products/data/software/download/software_files/${MY_P}.tar.gz"
@@ -26,6 +26,7 @@ DEPEND="sys-apps/findutils"
S=${WORKDIR}/${MY_P}
pkg_setup() {
+ fortran-2_pkg_setup
case "$(tc-getFC)" in
*gfortran)
export CNAME="_gfortran"
diff --git a/sci-libs/libbufr/libbufr-000387.ebuild b/sci-libs/libbufr/libbufr-000387.ebuild
index 56d0df925db0..aaff4be2ca82 100644
--- a/sci-libs/libbufr/libbufr-000387.ebuild
+++ b/sci-libs/libbufr/libbufr-000387.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/libbufr-000387.ebuild,v 1.4 2011/05/14 20:00:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/libbufr-000387.ebuild,v 1.5 2011/06/21 08:26:53 jlec Exp $
-EAPI="3"
+EAPI=3
-inherit eutils flag-o-matic toolchain-funcs
+inherit eutils fortran-2 flag-o-matic toolchain-funcs
MY_P="${PN/lib/}_${PV}"
-DESCRIPTION="ECMWF BUFR library - includes both C and Fortran example utilities."
+DESCRIPTION="ECMWF BUFR library - includes both C and Fortran example utilities"
HOMEPAGE="http://www.ecmwf.int/products/data/software/bufr.html"
SRC_URI="http://www.ecmwf.int/products/data/software/download/software_files/${MY_P}.tar.gz"
@@ -26,6 +26,7 @@ DEPEND="sys-apps/findutils"
S=${WORKDIR}/${MY_P}
pkg_setup() {
+ fortran-2_pkg_setup
case "$(tc-getFC)" in
*gfortran)
export CNAME="_gfortran"