summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-08-31 14:28:27 +0000
committerJustin Lecher <jlec@gentoo.org>2011-08-31 14:28:27 +0000
commit85e1e9fadd96eb5a7480875f5da927308adb3646 (patch)
tree4dba400e9eed42cbaf0ec9423c1ae32ed94a1ec7 /sci-libs/libcmatrix
parentAdd deblob support (diff)
downloadgentoo-2-85e1e9fadd96eb5a7480875f5da927308adb3646.tar.gz
gentoo-2-85e1e9fadd96eb5a7480875f5da927308adb3646.tar.bz2
gentoo-2-85e1e9fadd96eb5a7480875f5da927308adb3646.zip
Version bump
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libcmatrix')
-rw-r--r--sci-libs/libcmatrix/ChangeLog12
-rw-r--r--sci-libs/libcmatrix/files/3.9.0-atlas.patch24
-rw-r--r--sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild53
-rw-r--r--sci-libs/libcmatrix/metadata.xml14
4 files changed, 95 insertions, 8 deletions
diff --git a/sci-libs/libcmatrix/ChangeLog b/sci-libs/libcmatrix/ChangeLog
index d6b96de5d33a..89cb07a810dc 100644
--- a/sci-libs/libcmatrix/ChangeLog
+++ b/sci-libs/libcmatrix/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-libs/libcmatrix
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/ChangeLog,v 1.4 2011/04/21 06:38:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/ChangeLog,v 1.5 2011/08/31 14:28:27 jlec Exp $
+
+ 31 Aug 2011; Justin Lecher <jlec@gentoo.org> +files/3.9.0-atlas.patch,
+ +libcmatrix-3.9.0.ebuild, metadata.xml:
+ Version bump
+
+*libcmatrix-3.9.0 (31 Aug 2011)
+
+ 31 Aug 2011; Justin Lecher <jlec@gentoo.org> +files/3.9.0-atlas.patch,
+ +libcmatrix-3.9.0.ebuild, metadata.xml:
+ Version bump
21 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/3.2.1-atlas.patch,
files/3.2.1-shared.patch, libcmatrix-3.2.1.ebuild:
diff --git a/sci-libs/libcmatrix/files/3.9.0-atlas.patch b/sci-libs/libcmatrix/files/3.9.0-atlas.patch
new file mode 100644
index 000000000000..329e794645eb
--- /dev/null
+++ b/sci-libs/libcmatrix/files/3.9.0-atlas.patch
@@ -0,0 +1,24 @@
+ configure-libraries.ac | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/configure-libraries.ac b/configure-libraries.ac
+index 6e9579d..a919398 100755
+--- a/configure-libraries.ac
++++ b/configure-libraries.ac
+@@ -33,6 +33,7 @@ AC_ARG_WITH(atlas,
+ AS_HELP_STRING([--with-atlas],[use the ATLAS BLAS library (default-use if found)]),,with_atlas=check)
+ if test x$with_atlas != xno; then
+ FOUNDATLAS=yes
++ PKG_CHECK_MODULES([ATLAS], [cblas])
+ AC_CHECK_HEADERS(cblas.h,,FOUNDATLAS=no
+ AC_MSG_WARN([ATLAS header files (cblas.h) not found
+ Is CPPFLAGS is defined to include relevant directory?]))
+@@ -40,7 +41,7 @@ Is CPPFLAGS is defined to include relevant directory?]))
+ AC_MSG_WARN([ATLAS library (libatlas.a) not found
+ Is LDFLAGS is defined to include relevant directory?]))
+ if test x$FOUNDATLAS = xyes; then
+- LIBS="-lcblas $LIBS"
++ LIBS="$ATLAS_LIBS $LIBS"
+ CXXFLAGS="$CXXFLAGS -DLCM_USE_EXTERNAL"
+ else
+ if test x$with_atlas = xyes; then
diff --git a/sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild b/sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild
new file mode 100644
index 000000000000..4da9c6dac23e
--- /dev/null
+++ b/sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild,v 1.1 2011/08/31 14:28:27 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+MY_P="${PN}${PV}_lite"
+
+DESCRIPTION="lite version of pNMRsim"
+HOMEPAGE="http://www.dur.ac.uk/paul.hodgkinson/pNMRsim/"
+#SRC_URI="${HOMEPAGE}/${MY_P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="atlas sse threads"
+
+RDEPEND="
+ sci-libs/minuit
+ atlas? ( || ( sci-libs/blas-atlas sci-libs/atlas ) )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}R3
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/3.2.1-shared.patch \
+ "${FILESDIR}"/3.2.1-minuit2.patch \
+ "${FILESDIR}"/3.2.1-gcc4.4.patch \
+ "${FILESDIR}"/3.2.1-gcc4.6.patch \
+ "${FILESDIR}"/${PV}-atlas.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-minuit \
+ $(use_with atlas) \
+ $(use_with sse) \
+ $(use_with threads)
+}
+
+src_install() {
+ dolib.so lib/*.so* || die "install failed"
+
+ insinto /usr/include/${PN}R3
+ doins include/* || die "no includes"
+
+ dodoc CHANGES docs/* || die "no docs"
+}
diff --git a/sci-libs/libcmatrix/metadata.xml b/sci-libs/libcmatrix/metadata.xml
index ae22c398e6ee..178121cbeb07 100644
--- a/sci-libs/libcmatrix/metadata.xml
+++ b/sci-libs/libcmatrix/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
-<use>
- <flag name='atlas'>Use of atlas blas implementation</flag>
-</use>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="atlas">Use of atlas blas implementation</flag>
+ </use>
</pkgmetadata>