summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGérald Fenoy <djay@gentoo.org>2006-10-17 15:16:45 +0000
committerGérald Fenoy <djay@gentoo.org>2006-10-17 15:16:45 +0000
commit5aa2dd7a612957c08aa05fb0c5dce0461c3cfb04 (patch)
tree8309e9afb3cfba47f68c6e54a8755ceef7c1783b /sci-libs/libcore
parentAdded ~sparc-fbsd keyword. (diff)
downloadgentoo-2-5aa2dd7a612957c08aa05fb0c5dce0461c3cfb04.tar.gz
gentoo-2-5aa2dd7a612957c08aa05fb0c5dce0461c3cfb04.tar.bz2
gentoo-2-5aa2dd7a612957c08aa05fb0c5dce0461c3cfb04.zip
Some modifications required by the move.
(Portage version: 2.1.1)
Diffstat (limited to 'sci-libs/libcore')
-rw-r--r--sci-libs/libcore/files/libcore-1.7.patch4
-rw-r--r--sci-libs/libcore/libcore-1.7.ebuild9
2 files changed, 7 insertions, 6 deletions
diff --git a/sci-libs/libcore/files/libcore-1.7.patch b/sci-libs/libcore/files/libcore-1.7.patch
index 2fff5dcc1699..645c10af023f 100644
--- a/sci-libs/libcore/files/libcore-1.7.patch
+++ b/sci-libs/libcore/files/libcore-1.7.patch
@@ -14,7 +14,7 @@
# The following library will be built:
CORE_LIB=$(CORE_PATH)/lib/libcore++${VAR}.a
-CORE_SHARED_LIB=$(CORE_PATH)/lib/libcore++${VAR}.so
-+CORE_SHARED_LIB_NAME=lib${PN}++${VAR}.so
++CORE_SHARED_LIB_NAME=libcore++${VAR}.so
+CORE_SHARED_LIB=$(CORE_PATH)/lib/$(CORE_SHARED_LIB_NAME)
TARGET=$(CORE_LIB)
@@ -40,7 +40,7 @@
MODULES := linearAlgebra geometry2d geometry3d
@@ -29,9 +29,12 @@
- COREX_LIB_LEVEL3=${CORE_PATH}/lib/lib${PN}x++$(VAR)_level3.a
+ COREX_LIB_LEVEL3=${CORE_PATH}/lib/libcorex++$(VAR)_level3.a
COREX_LIB_LEVEL2=${CORE_PATH}/lib/libcorex++$(VAR)_level2.a
COREX_LIB_LEVEL1=${CORE_PATH}/lib/libcorex++$(VAR)_level1.a
-COREX_SHARED_LIB_LEVEL3=${CORE_PATH}/lib/libcorex++$(VAR)_level3.so
diff --git a/sci-libs/libcore/libcore-1.7.ebuild b/sci-libs/libcore/libcore-1.7.ebuild
index 209b9da6018e..edeaebce5c4c 100644
--- a/sci-libs/libcore/libcore-1.7.ebuild
+++ b/sci-libs/libcore/libcore-1.7.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/libcore-1.7.ebuild,v 1.1 2006/10/17 15:02:56 djay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/libcore-1.7.ebuild,v 1.2 2006/10/17 15:16:45 djay Exp $
inherit eutils toolchain-funcs
DESCRIPTION="The main goal of the CORE project is to address the issues of
robust numerical and geometric computation."
HOMEPAGE="http://www.cs.nyu.edu/exact/core_pages/"
-SRC_URI="http://cs.nyu.edu/exact/core/download/prerelease/core_v${PV}x_std.tgz"
+MYP="${PN/lib}"
+SRC_URI="http://cs.nyu.edu/exact/core/download/prerelease/${MYP}_v${PV}x_std.tgz"
LICENSE="QPL-1.0"
SLOT="0"
@@ -18,12 +19,12 @@ DEPEND="dev-libs/gmp
doc? ( virtual/tetex ) "
RDEPEND="virtual/libc"
-S="${WORKDIR}/core_v${PV}x"
+S="${WORKDIR}/${MYP}_v${PV}x"
src_unpack(){
unpack "${A}"
cd "${S}"
- epatch ${FILESDIR}/core-1.7.patch || die "Unable to patch sources"
+ epatch ${FILESDIR}/${P}.patch || die "Unable to patch sources"
}
src_compile(){