summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-04 08:07:04 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-04 08:07:04 +0000
commit9e94e7dbda72d38663fb77a995b13503952daea5 (patch)
tree5a18c1b87c3a05e2fb380a3bff5bc6b20b84f2ac /sci-libs/nlopt
parentmarked x86 per bug 404689 (diff)
downloadgentoo-2-9e94e7dbda72d38663fb77a995b13503952daea5.tar.gz
gentoo-2-9e94e7dbda72d38663fb77a995b13503952daea5.tar.bz2
gentoo-2-9e94e7dbda72d38663fb77a995b13503952daea5.zip
sci-libs/nlopt: Correct handling of PYABI things, #405255
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/nlopt')
-rw-r--r--sci-libs/nlopt/ChangeLog5
-rw-r--r--sci-libs/nlopt/nlopt-2.2.4.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index aef013591678..6bd846e9db6e 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/nlopt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.15 2012/04/01 05:25:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.16 2012/04/04 08:07:04 jlec Exp $
+
+ 04 Apr 2012; Justin Lecher <jlec@gentoo.org> nlopt-2.2.4.ebuild:
+ Correct handling of PYABI things, #405255
01 Apr 2012; Justin Lecher <jlec@gentoo.org> nlopt-2.2.4.ebuild,
metadata.xml:
diff --git a/sci-libs/nlopt/nlopt-2.2.4.ebuild b/sci-libs/nlopt/nlopt-2.2.4.ebuild
index 7486d171915b..7a89ca74130c 100644
--- a/sci-libs/nlopt/nlopt-2.2.4.ebuild
+++ b/sci-libs/nlopt/nlopt-2.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.7 2012/04/01 05:25:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.8 2012/04/04 08:07:04 jlec Exp $
EAPI=4
@@ -25,6 +25,8 @@ DEPEND="
python? ( dev-python/numpy )"
RDEPEND="${DEPEND}"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
src_prepare() {
if use python; then
sed -i \
@@ -50,19 +52,21 @@ src_configure() {
$(use_with python)
--without-matlab
)
- use python && python_copy_sources swig
autotools-utils_src_configure
}
src_compile() {
autotools-utils_src_compile
if use python; then
+ python_copy_sources swig
compilation() {
autotools-utils_src_compile \
PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
PYTHON_LDFLAGS="$(python_get_library -l)" \
PYTHON_SITE_PKG="$(python_get_sitedir)" \
PYTHON_VERSION="$(python_get_version)" \
+ PYTHON_INCLUDES="$(python_get_includedir)" \
+ pythondir="$(python_get_sitedir)" \
pyexecdir="$(python_get_sitedir)"
}
python_execute_function -s --source-dir swig compilation
@@ -73,7 +77,8 @@ src_install() {
autotools-utils_src_install
if use python; then
installation() {
- autotools-utils_src_install \
+ rm *.la
+ emake DESTDIR=${D} install \
pyexecdir="$(python_get_sitedir)" \
pythondir="$(python_get_sitedir)"
}