summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-14 16:01:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-14 16:01:26 +0000
commitc18efec73bea6f6c8f650cef7ef2118cf36bebca (patch)
tree2781e8189afd3e21edcc38dcc5c48f376ce65a9d /sci-libs/pgplot
parentStable for HPPA (bug #369573). (diff)
downloadgentoo-2-c18efec73bea6f6c8f650cef7ef2118cf36bebca.tar.gz
gentoo-2-c18efec73bea6f6c8f650cef7ef2118cf36bebca.tar.bz2
gentoo-2-c18efec73bea6f6c8f650cef7ef2118cf36bebca.zip
Fix building with libpng15 wrt #378189 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/pgplot')
-rw-r--r--sci-libs/pgplot/ChangeLog6
-rw-r--r--sci-libs/pgplot/files/pgplot-libpng15.patch11
-rw-r--r--sci-libs/pgplot/pgplot-5.2.2-r4.ebuild16
3 files changed, 25 insertions, 8 deletions
diff --git a/sci-libs/pgplot/ChangeLog b/sci-libs/pgplot/ChangeLog
index 1822f47536f8..c50966fe9f39 100644
--- a/sci-libs/pgplot/ChangeLog
+++ b/sci-libs/pgplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/pgplot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/ChangeLog,v 1.22 2011/06/21 15:14:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/ChangeLog,v 1.23 2011/09/14 16:01:26 ssuominen Exp $
+
+ 14 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +files/pgplot-libpng15.patch, pgplot-5.2.2-r4.ebuild:
+ Fix building with libpng15 wrt #378189 by Diego Elio Pettenò
21 Jun 2011; Justin Lecher <jlec@gentoo.org> pgplot-5.2.2-r3.ebuild,
pgplot-5.2.2-r4.ebuild:
diff --git a/sci-libs/pgplot/files/pgplot-libpng15.patch b/sci-libs/pgplot/files/pgplot-libpng15.patch
new file mode 100644
index 000000000000..b1064cb4da12
--- /dev/null
+++ b/sci-libs/pgplot/files/pgplot-libpng15.patch
@@ -0,0 +1,11 @@
+--- drivers/pndriv.c
++++ drivers/pndriv.c
+@@ -222,7 +222,7 @@
+ return;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) { /* not really sure what I'm doing here... */
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ fprintf(stderr,"%s: error in libpng while writing file %s, plotting disabled\n", png_ident, filename);
+ png_destroy_write_struct(&png_ptr,&info_ptr);
+ dev->error = true;
diff --git a/sci-libs/pgplot/pgplot-5.2.2-r4.ebuild b/sci-libs/pgplot/pgplot-5.2.2-r4.ebuild
index 1017a17313b4..1202702b5242 100644
--- a/sci-libs/pgplot/pgplot-5.2.2-r4.ebuild
+++ b/sci-libs/pgplot/pgplot-5.2.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/pgplot-5.2.2-r4.ebuild,v 1.4 2011/06/21 15:14:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/pgplot-5.2.2-r4.ebuild,v 1.5 2011/09/14 16:01:26 ssuominen Exp $
EAPI=2
inherit eutils fortran-2 toolchain-funcs
@@ -23,14 +23,16 @@ RDEPEND="
DEPEND="${RDEPEND}
doc? ( virtual/latex-base )"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-drivers.patch
- epatch "${FILESDIR}"/${PN}-makemake.patch
- epatch "${FILESDIR}"/${PN}-compile-setup.patch
- epatch "${FILESDIR}"/${PN}-headers.patch
- epatch "${FILESDIR}"/${PN}-ldflags.patch
+ epatch \
+ "${FILESDIR}"/${PN}-drivers.patch \
+ "${FILESDIR}"/${PN}-makemake.patch \
+ "${FILESDIR}"/${PN}-compile-setup.patch \
+ "${FILESDIR}"/${PN}-headers.patch \
+ "${FILESDIR}"/${PN}-ldflags.patch \
+ "${FILESDIR}"/${PN}-libpng15.patch
# gfortran < 4.3 does not compile gif, pp and wd drivers
if [[ "$(tc-getFC)" == gfortran ]] &&