summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-05-13 15:53:21 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-05-13 15:53:21 +0000
commit15772de973324789117059cebd04c361f27a61f5 (patch)
tree0b35199f422d32066e7c4b30ab045e7c53b92e54 /sci-libs/qrupdate
parentMarked ppc stable for bug #306747. (diff)
downloadgentoo-2-15772de973324789117059cebd04c361f27a61f5.tar.gz
gentoo-2-15772de973324789117059cebd04c361f27a61f5.tar.bz2
gentoo-2-15772de973324789117059cebd04c361f27a61f5.zip
Version bump. Added static-libs use flag. Some clean up
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/qrupdate')
-rw-r--r--sci-libs/qrupdate/ChangeLog8
-rw-r--r--sci-libs/qrupdate/files/qrupdate-1.1.1-Makefiles.patch88
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.1.ebuild47
3 files changed, 142 insertions, 1 deletions
diff --git a/sci-libs/qrupdate/ChangeLog b/sci-libs/qrupdate/ChangeLog
index 6ddf2ba73320..efe6af9c55db 100644
--- a/sci-libs/qrupdate/ChangeLog
+++ b/sci-libs/qrupdate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/qrupdate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.12 2010/05/13 06:33:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.13 2010/05/13 15:53:20 bicatali Exp $
+
+*qrupdate-1.1.1 (13 May 2010)
+
+ 13 May 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +qrupdate-1.1.1.ebuild, +files/qrupdate-1.1.1-Makefiles.patch:
+ Version bump. Added static-libs use flag. Some clean up
13 May 2010; Jeroen Roovers <jer@gentoo.org> qrupdate-1.1.0.ebuild:
Stable for HPPA (bug #318649).
diff --git a/sci-libs/qrupdate/files/qrupdate-1.1.1-Makefiles.patch b/sci-libs/qrupdate/files/qrupdate-1.1.1-Makefiles.patch
new file mode 100644
index 000000000000..9c9ef9317342
--- /dev/null
+++ b/sci-libs/qrupdate/files/qrupdate-1.1.1-Makefiles.patch
@@ -0,0 +1,88 @@
+diff -Nur qrupdate-1.1.1.orig/Makefile qrupdate-1.1.1/Makefile
+--- qrupdate-1.1.1.orig/Makefile 2009-02-06 09:12:00.000000000 +0000
++++ qrupdate-1.1.1/Makefile 2010-05-13 17:27:15.000000000 +0100
+@@ -32,22 +32,22 @@
+ @echo " make install - installs everything"
+
+ lib:
+- make -C src/ lib
++ $(MAKE) -C src lib
+ solib:
+- make -C src/ solib
++ $(MAKE) -C src solib
+ test: lib
+- make -C test/
++ $(MAKE) -C test
+
+ clean:
+ rm -f libqrupdate.a libqrupdate.so
+- make -C src/ clean
+- make -C test/ clean
++ $(MAKE) -C src clean
++ $(MAKE) -C test clean
+
+ install:
+- make -C src/ install
++ $(MAKE) -C src install
+
+ install-shlib:
+- make -C src/ install-shlib
++ $(MAKE) -C src install-shlib
+
+ install-staticlib:
+- make -C src/ install-staticlib
++ $(MAKE) -C src install-staticlib
+diff -Nur qrupdate-1.1.1.orig/src/Makefile qrupdate-1.1.1/src/Makefile
+--- qrupdate-1.1.1.orig/src/Makefile 2010-01-19 11:32:35.000000000 +0000
++++ qrupdate-1.1.1/src/Makefile 2010-05-13 17:28:30.000000000 +0100
+@@ -34,6 +34,8 @@
+
+ OBJS = $(SRC:%.f=%.o)
+
++PICOBJS = $(SRC:%.f=%.lo)
++
+ lib: ../libqrupdate.a
+
+ ifeq ($(shell uname),Darwin)
+@@ -46,19 +48,22 @@
+ ../libqrupdate.a: $(OBJS)
+ ar -cr $@ $(OBJS)
+
+-../libqrupdate.so: $(OBJS)
+- $(FC) $(FFLAGS) -shared -o $@ -Wl,-soname=libqrupdate.so.$(MAJOR) $(OBJS) \
++../libqrupdate.so: $(PICOBJS)
++ $(FC) $(LDFLAGS) -shared -o $@ -Wl,-soname=libqrupdate.so.$(MAJOR) $(PICOBJS) \
+ $(BLAS) $(LAPACK)
+
+-../libqrupdate.dylib: $(OBJS)
+- $(FC) $(FFLAGS) $(LDFLAGS) -dynamiclib -o $@ -install_name $(PREFIX)/$(LIBDIR)/libqrupdate.$(MAJOR).dylib $(OBJS) \
++../libqrupdate.dylib: $(PICOBJS)
++ $(FC) $(LDFLAGS) -dynamiclib -o $@ -install_name $(PREFIX)/$(LIBDIR)/libqrupdate.$(MAJOR).dylib $(PICOBJS) \
+ $(BLAS) $(LAPACK)
+
++$(PICOBJS): %.lo: %.f
++ $(FC) $(FFLAGS) $(FPICFLAGS) -c $< -o $@
++
+ $(OBJS): %.o: %.f
+- $(FC) $(FFLAGS) $(FPICFLAGS) -c $<
++ $(FC) $(FFLAGS) -c $<
+
+ clean:
+- rm -f $(OBJS)
++ rm -f $(OBJS) $(PICOBJS)
+
+ install: install-shlib install-staticlib
+
+diff -Nur qrupdate-1.1.1.orig/test/Makefile qrupdate-1.1.1/test/Makefile
+--- qrupdate-1.1.1.orig/test/Makefile 2010-02-11 08:25:37.000000000 +0000
++++ qrupdate-1.1.1/test/Makefile 2010-05-13 17:15:51.000000000 +0100
+@@ -41,7 +41,7 @@
+ $(FC) $(FFLAGS) -c $<
+
+ ../libqrupdate.a:
+- make -C ../ lib
+-
++ $(MAKE) -C .. lib
++
+ clean:
+ rm -f *.o $(PROGS) $(OUTS)
diff --git a/sci-libs/qrupdate/qrupdate-1.1.1.ebuild b/sci-libs/qrupdate/qrupdate-1.1.1.ebuild
new file mode 100644
index 000000000000..1889fac8bf58
--- /dev/null
+++ b/sci-libs/qrupdate/qrupdate-1.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.1.ebuild,v 1.1 2010/05/13 15:53:20 bicatali Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A library for fast updating of QR and Cholesky decompositions"
+HOMEPAGE="http://sourceforge.net/projects/qrupdate"
+SRC_URI="mirror://sourceforge/qrupdate/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="static-libs"
+
+RDEPEND="virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefiles.patch
+ sed -i Makeconf \
+ -e "s:gfortran:$(tc-getFC):g" \
+ -e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \
+ -e "s:BLAS=.*:BLAS=$(pkg-config --libs blas):" \
+ -e "s:LAPACK=.*:LAPACK=$(pkg-config --libs lapack):" \
+ -e "/^LIBDIR=/a\PREFIX=${EPREFIX}/usr" \
+ -e "s:LIBDIR=lib:LIBDIR=$(get_libdir):" \
+ || die "Failed to set up Makeconf"
+}
+
+src_compile() {
+ emake solib || die "emake shared lib failed"
+ if use static-libs; then
+ emake lib || die "emake static lib failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-shlib || die "emake shared lib install failed"
+ if use static-libs; then
+ emake DESTDIR="${D}" install-staticlib || die "emake static lib install failed"
+ fi
+ dodoc README ChangeLog
+}