summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-17 23:29:09 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-17 23:29:09 +0000
commit1f0cc434ec9b02f87f7d9c0f4d7a6e4f5eb03455 (patch)
tree995eddf3bc83d63fc327add98d29b3d03ddb872f /sci-libs/scipy
parentAdd to tree from kde overlay (diff)
downloadgentoo-2-1f0cc434ec9b02f87f7d9c0f4d7a6e4f5eb03455.tar.gz
gentoo-2-1f0cc434ec9b02f87f7d9c0f4d7a6e4f5eb03455.tar.bz2
gentoo-2-1f0cc434ec9b02f87f7d9c0f4d7a6e4f5eb03455.zip
Change umfpack flag to sparse for consistency
(Portage version: 2.2.01.22013-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog7
-rw-r--r--sci-libs/scipy/files/scipy-0.11.0-test_basic.patch48
-rw-r--r--sci-libs/scipy/metadata.xml17
-rw-r--r--sci-libs/scipy/scipy-0.11.0-r1.ebuild129
-rw-r--r--sci-libs/scipy/scipy-0.9.0-r1.ebuild10
5 files changed, 19 insertions, 192 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 6d7d16f37ee8..5213bb3e4932 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.93 2013/06/09 17:58:01 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.94 2013/06/17 23:29:09 bicatali Exp $
+
+ 17 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/scipy-0.11.0-test_basic.patch, -scipy-0.11.0-r1.ebuild, metadata.xml,
+ scipy-0.9.0-r1.ebuild:
+ Change umfpack flag to sparse for consistency
09 Jun 2013; Mike Gilbert <floppym@gentoo.org> scipy-0.11.0-r1.ebuild,
scipy-0.12.0.ebuild:
diff --git a/sci-libs/scipy/files/scipy-0.11.0-test_basic.patch b/sci-libs/scipy/files/scipy-0.11.0-test_basic.patch
deleted file mode 100644
index 0b1018a3b9c0..000000000000
--- a/sci-libs/scipy/files/scipy-0.11.0-test_basic.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 6c1cd446bb6c3ffcc131de5b81e21b481400c334 Mon Sep 17 00:00:00 2001
-From: Pauli Virtanen <pav@iki.fi>
-Date: Sat, 3 Nov 2012 17:13:30 +0200
-Subject: [PATCH] TST: special: fix test_basic.py:cephes_vs_amos_mass_test
-
----
- scipy/special/tests/test_basic.py | 22 ++++++++++++++--------
- 1 file changed, 14 insertions(+), 8 deletions(-)
-
-diff --git a/scipy/special/tests/test_basic.py b/scipy/special/tests/test_basic.py
-index 973322a..6ef4f7f 100644
---- a/scipy/special/tests/test_basic.py
-+++ b/scipy/special/tests/test_basic.py
-@@ -1770,17 +1770,23 @@ def test_iv_cephes_vs_amos_mass_test(self):
- x = np.random.pareto(0.2, N) * (-1)**np.random.randint(2, size=N)
-
- imsk = (np.random.randint(8, size=N) == 0)
-- v[imsk] = v.astype(int)
-+ v[imsk] = v[imsk].astype(int)
-
-- c1 = special.iv(v, x)
-- c2 = special.iv(v, x+0j)
-+ old_err = np.seterr(all='ignore')
-+ try:
-+ c1 = special.iv(v, x)
-+ c2 = special.iv(v, x+0j)
-
-- # deal with differences in the inf cutoffs
-- c1[abs(c1) > 1e300] = np.inf
-- c2[abs(c2) > 1e300] = np.inf
-+ # deal with differences in the inf and zero cutoffs
-+ c1[abs(c1) > 1e300] = np.inf
-+ c2[abs(c2) > 1e300] = np.inf
-+ c1[abs(c1) < 1e-300] = 0
-+ c2[abs(c2) < 1e-300] = 0
-
-- dc = abs(c1/c2 - 1)
-- dc[np.isnan(dc)] = 0
-+ dc = abs(c1/c2 - 1)
-+ dc[np.isnan(dc)] = 0
-+ finally:
-+ np.seterr(**old_err)
-
- k = np.argmax(dc)
-
---
-1.7.10
-
diff --git a/sci-libs/scipy/metadata.xml b/sci-libs/scipy/metadata.xml
index bb5f7eb29fbc..4ee19593821e 100644
--- a/sci-libs/scipy/metadata.xml
+++ b/sci-libs/scipy/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+<herd>sci</herd>
+<longdescription lang="en">
SciPy is an open source library of scientific tools for Python. SciPy
supplements the popular numpy module, gathering a variety of high level
science and engineering modules together as a single package.
@@ -10,11 +10,10 @@
integration, special functions, signal and image processing, genetic
algorithms, ODE solvers, and others.
</longdescription>
- <use>
- <flag name="umfpack">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
- <flag name="sparse">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
- </use>
- <upstream>
- <remote-id type="pypi">scipy</remote-id>
- </upstream>
+<use>
+ <flag name="sparse">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
+</use>
+<upstream>
+ <remote-id type="pypi">scipy</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/sci-libs/scipy/scipy-0.11.0-r1.ebuild b/sci-libs/scipy/scipy-0.11.0-r1.ebuild
deleted file mode 100644
index e3d0df2d4eb4..000000000000
--- a/sci-libs/scipy/scipy-0.11.0-r1.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.11.0-r1.ebuild,v 1.7 2013/06/09 17:58:01 floppym Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-
-inherit eutils fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-SRC_URI="
- mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${P}-html.zip
- http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${P}-ref.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc test umfpack"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- dev-python/numpy[lapack,${PYTHON_USEDEP}]
- sci-libs/arpack
- virtual/cblas
- virtual/lapack
- umfpack? ( sci-libs/umfpack )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- umfpack? ( dev-lang/swig )"
-
-RDEPEND="${CDEPEND}
- virtual/python-imaging[${PYTHON_USEDEP}]"
-
-DOCS=( HACKING.rst.txt README.txt THANKS.txt LATEST.txt TOCHANGE.txt )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${P}-html.zip -d html || die
- fi
-}
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g'
-}
-
-python_prepare_all() {
- local libdir="${EPREFIX}"/usr/$(get_libdir)
-
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use umfpack && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-
- local PATCHES=(
- "${FILESDIR}"/${P}-test_basic.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- distutils_install_for_testing ${SCIPY_FCONFIG}
-
- cd "${TMPDIR}" || die
- "${PYTHON}" -c "
-import scipy, sys
-r = scipy.test('full', verbose=10)
-sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-
- if use doc; then
- dohtml -r "${WORKDIR}"/html/.
- dodoc "${DISTDIR}"/${P}*pdf
- fi
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy/scipy-0.9.0-r1.ebuild b/sci-libs/scipy/scipy-0.9.0-r1.ebuild
index 87805f517ef0..2e560519bd98 100644
--- a/sci-libs/scipy/scipy-0.9.0-r1.ebuild
+++ b/sci-libs/scipy/scipy-0.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.9.0-r1.ebuild,v 1.13 2013/03/07 14:37:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.9.0-r1.ebuild,v 1.14 2013/06/17 23:29:09 bicatali Exp $
EAPI="3"
@@ -22,7 +22,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
LICENSE="BSD"
SLOT="0"
-IUSE="doc umfpack"
+IUSE="doc sparse"
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
CDEPEND="
@@ -32,11 +32,11 @@ CDEPEND="
sci-libs/superlu
virtual/cblas
virtual/lapack
- umfpack? ( sci-libs/umfpack )"
+ sparse? ( sci-libs/umfpack )"
DEPEND="${CDEPEND}
virtual/pkgconfig
doc? ( app-arch/unzip )
- umfpack? ( dev-lang/swig )"
+ sparse? ( dev-lang/swig )"
RDEPEND="${CDEPEND}
dev-python/imaging"
@@ -49,7 +49,7 @@ pkg_setup() {
fortran-2_pkg_setup
# scipy automatically detects libraries by default
export {FFTW,FFTW3,UMFPACK}=None
- use umfpack && unset UMFPACK
+ use sparse && unset UMFPACK
# the missing symbols are in -lpythonX.Y, but since the version can
# differ, we just introduce the same scaryness as on Linux/ELF
[[ ${CHOST} == *-darwin* ]] \