summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-04-13 20:27:45 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-04-13 20:27:45 +0000
commit253431a5372d07a959afc77e0424e47ed5b4a81e (patch)
tree120a5de47656a613d89f8a5c26a5c5b178dfe746 /sci-libs
parentAdd patch, fix bug #266029. (diff)
downloadgentoo-2-253431a5372d07a959afc77e0424e47ed5b4a81e.tar.gz
gentoo-2-253431a5372d07a959afc77e0424e47ed5b4a81e.tar.bz2
gentoo-2-253431a5372d07a959afc77e0424e47ed5b4a81e.zip
Initial import
(Portage version: 2.2_rc29/cvs/Linux i686)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/qd/ChangeLog10
-rw-r--r--sci-libs/qd/files/qd-2.3.7-test.patch12
-rw-r--r--sci-libs/qd/metadata.xml10
-rw-r--r--sci-libs/qd/qd-2.3.7.ebuild52
4 files changed, 84 insertions, 0 deletions
diff --git a/sci-libs/qd/ChangeLog b/sci-libs/qd/ChangeLog
new file mode 100644
index 000000000000..f6efae5cd24e
--- /dev/null
+++ b/sci-libs/qd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/qd
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/ChangeLog,v 1.1 2009/04/13 20:27:45 grozin Exp $
+
+*qd-2.3.7 (14 Apr 2009)
+
+ 14 Apr 2009; Andrey Grozin <grozin@gentoo.org> +files/qd-2.3.7-test.patch,
+ +metadata.xml, +qd-2.3.7.ebuild:
+ Initial import
+
diff --git a/sci-libs/qd/files/qd-2.3.7-test.patch b/sci-libs/qd/files/qd-2.3.7-test.patch
new file mode 100644
index 000000000000..4dc1154b8277
--- /dev/null
+++ b/sci-libs/qd/files/qd-2.3.7-test.patch
@@ -0,0 +1,12 @@
+Index: qd-2.3.7/tests/quadt_test.cpp
+===================================================================
+--- qd-2.3.7.orig/tests/quadt_test.cpp
++++ qd-2.3.7/tests/quadt_test.cpp
+@@ -11,6 +11,7 @@
+ * code (see quadt.h).
+ */
+
++#include <string.h>
+ #include <cmath>
+ #include <cstdlib>
+ #include <cstdio>
diff --git a/sci-libs/qd/metadata.xml b/sci-libs/qd/metadata.xml
new file mode 100644
index 000000000000..5baa87d49888
--- /dev/null
+++ b/sci-libs/qd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Quad-double and double-double float arithmetics</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/qd/qd-2.3.7.ebuild b/sci-libs/qd/qd-2.3.7.ebuild
new file mode 100644
index 000000000000..455b648ee5ae
--- /dev/null
+++ b/sci-libs/qd/qd-2.3.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/qd-2.3.7.ebuild,v 1.1 2009/04/13 20:27:45 grozin Exp $
+EAPI=2
+inherit eutils
+DESCRIPTION="Quad-double and double-double float arithmetics"
+IUSE="fortran"
+HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-test.patch
+}
+
+src_configure() {
+ econf $(use_enable fortran enable_fortran)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS NEWS TODO || die "dodoc failed"
+ cd "${D}"/usr/share/doc || die "cd failed"
+ mv ${PN}/${PN}.pdf ${PF}/ || die "mv failed"
+ rm -rf ${PN}/ || die "rm failed"
+}
+
+src_test() {
+ local prog
+ make demo
+ cd tests
+ for prog in c_test f_test huge pslq_test qd_test qd_timer quadt_test; do
+ ./${prog}
+ done
+ cd ..
+ if use fortran; then
+ cd fortran
+ for prog in quaderq quadgsq quadgsq2d quadtsq quadtsq2d; do
+ ./${prog}
+ done
+ cd ..
+ fi
+}