summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-12-05 10:17:24 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-12-05 10:17:24 +0000
commit58a93817ba81c3adf0146190de52e317f78473e0 (patch)
tree795bcd6ba2e39a300c1c3329c55f7cbb6f90a134 /sci-libs
parentremove old (diff)
downloadgentoo-2-58a93817ba81c3adf0146190de52e317f78473e0.tar.gz
gentoo-2-58a93817ba81c3adf0146190de52e317f78473e0.tar.bz2
gentoo-2-58a93817ba81c3adf0146190de52e317f78473e0.zip
Use REQUIRED_USE instead of providing sane defaults wrt #392683 by Murph <MattFinn@gmail.com>
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/ChangeLog6
-rw-r--r--sci-libs/hdf5/hdf5-1.8.8.ebuild33
2 files changed, 14 insertions, 25 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 68ec612baf02..f1ed0f168fc9 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.77 2011/11/21 17:33:09 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.78 2011/12/05 10:17:24 xarthisius Exp $
+
+ 05 Dec 2011; Kacper Kowalik <xarthisius@gentoo.org> hdf5-1.8.8.ebuild:
+ Use REQUIRED_USE instead of providing sane defaults wrt #392683 by Murph
+ <MattFinn@gmail.com>
21 Nov 2011; Kacper Kowalik <xarthisius@gentoo.org>
+files/hdf5-1.8.8-array_bounds.patch, +files/hdf5-1.8.8-implicits.patch,
diff --git a/sci-libs/hdf5/hdf5-1.8.8.ebuild b/sci-libs/hdf5/hdf5-1.8.8.ebuild
index abf3331123e7..0e94db9f32ed 100644
--- a/sci-libs/hdf5/hdf5-1.8.8.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.8.ebuild,v 1.2 2011/11/21 17:33:09 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.8.ebuild,v 1.3 2011/12/05 10:17:24 xarthisius Exp $
EAPI=4
-inherit autotools eutils fortran-2
+inherit autotools eutils fortran-2 toolchain-funcs
DESCRIPTION="General purpose library and file format for storing scientific data"
HOMEPAGE="http://www.hdfgroup.org/HDF5/"
@@ -25,7 +25,11 @@ RDEPEND="
DEPEND="${RDEPEND}
sys-devel/libtool:2"
+REQUIRED_USE="cxx? ( !mpi ) mpi? ( !cxx )
+ threads? ( !cxx !mpi !fortran )"
+
pkg_setup() {
+ tc-export CXX CC FC # workaround for bug 285148
if use fortran; then
use fortran2003 && FORTRAN_STANDARD=2003
fortran-2_pkg_setup
@@ -35,10 +39,6 @@ pkg_setup() {
ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
fi
- if use cxx; then
- ewarn "Simultaneous mpi and cxx is not supported by ${PN}"
- ewarn "Will disable cxx interface"
- fi
export CC=mpicc
use fortran && export FC=mpif90
elif has_version 'sci-libs/hdf5[mpi]'; then
@@ -64,24 +64,6 @@ src_prepare() {
}
src_configure() {
- # threadsafe incompatible with many options
- local myconf="--disable-threadsafe"
- use debug && myconf="${myconf} --enable-codestack"
- use threads && ! use fortran && ! use cxx && ! use mpi \
- && myconf="--enable-threadsafe"
-
- if use mpi; then
- myconf="${myconf} --disable-cxx"
- else
- # workaround for bug 285148
- if use cxx; then
- myconf="${myconf} $(use_enable cxx) CXX=$(tc-getCXX)"
- fi
- if use fortran; then
- myconf="${myconf} FC=$(tc-getFC)"
- fi
- fi
-
econf \
--disable-sharedlib-rpath \
--enable-production \
@@ -91,9 +73,12 @@ src_configure() {
--disable-silent-rules \
$(use_enable static-libs static) \
$(use_enable debug debug all) \
+ $(use_enable debug codestack) \
+ $(use_enable cxx) \
$(use_enable fortran) \
$(use_enable fortran2003) \
$(use_enable mpi parallel) \
+ $(use_enable threads threadsafe) \
$(use_with szip szlib) \
$(use_with threads pthread) \
$(use_with zlib) \