summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-09-16 04:58:05 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-09-16 04:58:05 +0000
commit8d0d1599f6639a8d12cde1d1a8ff822c8e4996e3 (patch)
tree5499267c81f021b7e4883f1b20d9c660f52d907b /sci-libs
parentDISTUTILS_GLOBAL_OPTIONS should be an array. (diff)
downloadgentoo-2-8d0d1599f6639a8d12cde1d1a8ff822c8e4996e3.tar.gz
gentoo-2-8d0d1599f6639a8d12cde1d1a8ff822c8e4996e3.tar.bz2
gentoo-2-8d0d1599f6639a8d12cde1d1a8ff822c8e4996e3.zip
Updated with test and QA fixes, closes bug 283747.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/shapelib/ChangeLog9
-rw-r--r--sci-libs/shapelib/files/fix-shapelib-test.diff30
-rw-r--r--sci-libs/shapelib/files/stdlib_include_fix.patch30
-rw-r--r--sci-libs/shapelib/shapelib-1.2.10-r1.ebuild9
4 files changed, 73 insertions, 5 deletions
diff --git a/sci-libs/shapelib/ChangeLog b/sci-libs/shapelib/ChangeLog
index ced1d9baec0f..73d5769b20cf 100644
--- a/sci-libs/shapelib/ChangeLog
+++ b/sci-libs/shapelib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/shapelib
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/ChangeLog,v 1.9 2008/01/04 17:47:08 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/ChangeLog,v 1.10 2009/09/16 04:58:05 nerdboy Exp $
+
+ 16 Sep 2009; Steve Arnold <nerdboy@gentoo.org> shapelib-1.2.10-r1.ebuild,
+ +files/fix-shapelib-test.diff, +files/stdlib_include_fix.patch:
+ Updated with test fix (patch provided by Thomas Beierlein) and QA fix
+ for missing include file.
04 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
shapelib-1.2.10-r1.ebuild:
diff --git a/sci-libs/shapelib/files/fix-shapelib-test.diff b/sci-libs/shapelib/files/fix-shapelib-test.diff
new file mode 100644
index 000000000000..859a5838047b
--- /dev/null
+++ b/sci-libs/shapelib/files/fix-shapelib-test.diff
@@ -0,0 +1,30 @@
+--- makeshape.sh.orig 2003-04-07 15:03:22.000000000 +0200
++++ makeshape.sh 2009-09-06 11:31:37.000000000 +0200
+@@ -5,17 +5,17 @@
+ # should display in ARCView II.
+ #
+
+-shpcreate test polygon
+-dbfcreate test.dbf -s Description 30 -n TestInt 6 0 -n TestDouble 16 5
++./shpcreate test polygon
++./dbfcreate test.dbf -s Description 30 -n TestInt 6 0 -n TestDouble 16 5
+
+-shpadd test 0 0 100 0 100 100 0 100 0 0 + 20 20 20 30 30 30 20 20
+-dbfadd test.dbf "Square with triangle missing" 1.5 2.5
++./shpadd test 0 0 100 0 100 100 0 100 0 0 + 20 20 20 30 30 30 20 20
++./dbfadd test.dbf "Square with triangle missing" 1.5 2.5
+
+-shpadd test 150 150 160 150 180 170 150 150
+-dbfadd test.dbf "Smaller triangle" 100 1000.25
++./shpadd test 150 150 160 150 180 170 150 150
++./dbfadd test.dbf "Smaller triangle" 100 1000.25
+
+-shpadd test 150 150 160 150 180 170 150 150
+-dbfadd test.dbf "" "" ""
++./shpadd test 150 150 160 150 180 170 150 150
++./dbfadd test.dbf "" "" ""
+
+-shpdump test.shp
+-dbfdump test.dbf
++./shpdump test.shp
++./dbfdump test.dbf
diff --git a/sci-libs/shapelib/files/stdlib_include_fix.patch b/sci-libs/shapelib/files/stdlib_include_fix.patch
new file mode 100644
index 000000000000..82b07699544d
--- /dev/null
+++ b/sci-libs/shapelib/files/stdlib_include_fix.patch
@@ -0,0 +1,30 @@
+--- shpcreate.c.orig 2009-09-15 20:09:39.641422056 -0700
++++ shpcreate.c 2009-09-15 20:20:31.310673754 -0700
+@@ -51,6 +51,7 @@
+ static char rcsid[] =
+ "$Id: stdlib_include_fix.patch,v 1.1 2009/09/16 04:58:04 nerdboy Exp $";
+
++#include <stdlib.h>
+ #include "shapefil.h"
+
+ int main( int argc, char ** argv )
+--- shpdump.c.orig 2009-09-15 20:09:47.615421028 -0700
++++ shpdump.c 2009-09-15 20:20:29.654673421 -0700
+@@ -67,6 +67,7 @@
+ static char rcsid[] =
+ "$Id: stdlib_include_fix.patch,v 1.1 2009/09/16 04:58:04 nerdboy Exp $";
+
++#include <stdlib.h>
+ #include "shapefil.h"
+
+ int main( int argc, char ** argv )
+--- shprewind.c.orig 2009-09-15 20:09:58.193422322 -0700
++++ shprewind.c 2009-09-15 20:20:26.954542660 -0700
+@@ -43,6 +43,7 @@
+ *
+ */
+
++#include <stdlib.h>
+ #include "shapefil.h"
+
+ int main( int argc, char ** argv )
diff --git a/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild b/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild
index dd4af6d8e417..3eddad9839d2 100644
--- a/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild
+++ b/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild,v 1.2 2008/01/04 17:47:08 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild,v 1.3 2009/09/16 04:58:05 nerdboy Exp $
inherit eutils toolchain-funcs
@@ -17,12 +17,15 @@ DEPEND=""
src_unpack() {
unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/fix-shapelib-test.diff
+ epatch "${FILESDIR}"/stdlib_include_fix.patch
sed -i \
-e 's:/usr/local/:${DESTDIR}/usr/:g' \
-e "s:/usr/lib:/usr/$(get_libdir):g" \
-e 's:SHPLIB_VERSION=1.2.9:SHPLIB_VERSION=1.2.10:g' \
-e "s:-g:${CFLAGS}:g" \
- "${S}"/Makefile || die
+ Makefile || die "sed failed"
}
src_compile() {