summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-11-05 17:29:36 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-11-05 17:29:36 +0000
commitf47cac3c29d5faa82bc9ba1865b7fabb67246b78 (patch)
treebbe84e028c8cbdb9e3fa188cbeddcedf7c76604a /sci-libs
parentx86 stable wrt bug #343985 (diff)
downloadgentoo-2-f47cac3c29d5faa82bc9ba1865b7fabb67246b78.tar.gz
gentoo-2-f47cac3c29d5faa82bc9ba1865b7fabb67246b78.tar.bz2
gentoo-2-f47cac3c29d5faa82bc9ba1865b7fabb67246b78.zip
Fix implicits.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/ChangeLog8
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.5-implicits.patch65
-rw-r--r--sci-libs/hdf5/hdf5-1.8.5_p1-r1.ebuild (renamed from sci-libs/hdf5/hdf5-1.8.5_p1.ebuild)4
3 files changed, 74 insertions, 3 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 05a91b3a2891..5fccddc22a81 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.63 2010/11/05 16:38:26 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.64 2010/11/05 17:29:36 xarthisius Exp $
+
+*hdf5-1.8.5_p1-r1 (05 Nov 2010)
+
+ 05 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org> -hdf5-1.8.5_p1.ebuild,
+ +hdf5-1.8.5_p1-r1.ebuild, +files/hdf5-1.8.5-implicits.patch:
+ Fix implicits.
*hdf5-1.8.5_p1 (05 Nov 2010)
diff --git a/sci-libs/hdf5/files/hdf5-1.8.5-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.5-implicits.patch
new file mode 100644
index 000000000000..89a9998a7ee0
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.5-implicits.patch
@@ -0,0 +1,65 @@
+Fix implicit function declarations
+
+--- hdf5-1.8.5-patch1/tools/misc/talign.c
++++ hdf5-1.8.5-patch1/tools/misc/talign.c
+@@ -23,6 +23,7 @@
+
+ #include "hdf5.h"
+ #include "H5private.h"
++#include "h5tools.h"
+
+ const char *fname = "talign.h5";
+ const char *setname = "align";
+--- hdf5-1.8.5-patch1/tools/lib/h5tools_utils.c
++++ hdf5-1.8.5-patch1/tools/lib/h5tools_utils.c
+@@ -31,6 +31,7 @@
+ #include "h5tools_utils.h"
+ #include "H5private.h"
+ #include "h5trav.h"
++#include "h5diff.h"
+
+ /* global variables */
+ int nCols = 80;
+--- hdf5-1.8.5-patch1/src/H5E.c
++++ hdf5-1.8.5-patch1/src/H5E.c
+@@ -54,6 +54,8 @@
+ /***********/
+ /* Headers */
+ /***********/
++#define _GNU_SOURCE
++#include <stdio.h>
+ #include "H5private.h" /* Generic Functions */
+ #include "H5Iprivate.h" /* IDs */
+ #include "H5Epkg.h" /* Error handling */
+--- hdf5-1.8.5-patch1/src/H5Eint.c
++++ hdf5-1.8.5-patch1/src/H5Eint.c
+@@ -37,6 +37,8 @@
+ /***********/
+ /* Headers */
+ /***********/
++#define _GNU_SOURCE
++#include <stdio.h>
+ #include "H5private.h" /* Generic Functions */
+ #include "H5Epkg.h" /* Error handling */
+ #include "H5Iprivate.h" /* IDs */
+--- hdf5-1.8.5-patch1/tools/h5copy/h5copygentest.c
++++ hdf5-1.8.5-patch1/tools/h5copy/h5copygentest.c
+@@ -20,6 +20,7 @@
+ #include "hdf5.h"
+ #include "H5private.h"
+ #include "h5tools.h"
++#include "h5tools_utils.h"
+
+ /* Name of tool */
+ #define PROGRAMNAME "h5copygentest"
+--- hdf5-1.8.5-patch1/tools/h5repack/testh5repack_detect_szip.c
++++ hdf5-1.8.5-patch1/tools/h5repack/testh5repack_detect_szip.c
+@@ -17,7 +17,7 @@
+ #include "h5repack.h"
+ #include "h5tools.h"
+ #include "h5test.h"
+-
++#include "h5tools_utils.h"
+
+ /* Name of tool */
+ #define PROGRAMNAME "h5repack_detect_szip"
diff --git a/sci-libs/hdf5/hdf5-1.8.5_p1.ebuild b/sci-libs/hdf5/hdf5-1.8.5_p1-r1.ebuild
index 1559d64fb512..f7b5a7fd79df 100644
--- a/sci-libs/hdf5/hdf5-1.8.5_p1.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.5_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.5_p1.ebuild,v 1.1 2010/11/05 16:38:27 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.5_p1-r1.ebuild,v 1.1 2010/11/05 17:29:36 xarthisius Exp $
EAPI=2
@@ -50,7 +50,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.8.3-as-needed.patch
- epatch "${FILESDIR}"/${PN}-1.8.3-includes.patch
+ epatch "${FILESDIR}"/${PN}-1.8.5-implicits.patch
epatch "${FILESDIR}"/${PN}-1.8.5-noreturn.patch
epatch "${FILESDIR}"/${PN}-1.8.4-scaleoffset.patch