summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-10-14 18:04:15 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-10-14 18:04:15 +0000
commitfaaba994c7343128e131fb7251977889ff2d5c2b (patch)
treed8100ce1a1ae9379b9857de18bd8acb5afdb1b5f /sci-libs
parentUSE foomatic should go into hplip-3.9.8 instead of hplip-3.9.8-r1. Add myself... (diff)
downloadgentoo-2-faaba994c7343128e131fb7251977889ff2d5c2b.tar.gz
gentoo-2-faaba994c7343128e131fb7251977889ff2d5c2b.tar.bz2
gentoo-2-faaba994c7343128e131fb7251977889ff2d5c2b.zip
Version bump, thanks RSebastian Mingramm for his testing.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cln/ChangeLog7
-rw-r--r--sci-libs/cln/cln-1.3.1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/sci-libs/cln/ChangeLog b/sci-libs/cln/ChangeLog
index cf41e92725e0..08ee092007de 100644
--- a/sci-libs/cln/ChangeLog
+++ b/sci-libs/cln/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/cln
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/ChangeLog,v 1.36 2009/07/14 23:30:10 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/ChangeLog,v 1.37 2009/10/14 18:04:15 bicatali Exp $
+
+*cln-1.3.1 (14 Oct 2009)
+
+ 14 Oct 2009; Sébastien Fabbro <bicatali@gentoo.org> +cln-1.3.1.ebuild:
+ Version bump, thanks RSebastian Mingramm for his testing.
*cln-1.3.0 (14 Jul 2009)
diff --git a/sci-libs/cln/cln-1.3.1.ebuild b/sci-libs/cln/cln-1.3.1.ebuild
new file mode 100644
index 000000000000..a7a8f8566ce6
--- /dev/null
+++ b/sci-libs/cln/cln-1.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.3.1.ebuild,v 1.1 2009/10/14 18:04:15 bicatali Exp $
+
+EAPI=2
+inherit eutils flag-o-matic
+
+DESCRIPTION="Class library (C++) for numbers"
+HOMEPAGE="http://www.ginac.de/CLN/"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gnu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+DEPEND="dev-libs/gmp"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use sparc && append-cppflags "-DNO_ASM"
+ use hppa && append-cppflags "-DNO_ASM"
+}
+
+src_prepare() {
+ # avoid building examples
+ # do it in Makefile.in to avoid time consuming eautoreconf
+ sed -i -e '/^SUBDIRS.*=/s/examples doc benchmarks/doc/' Makefile.in || die
+ # fix compilation under gcc 4.4
+ epatch "${FILESDIR}"/${PN}-1.2.2-gcc-4.4.patch
+}
+
+src_configure () {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --datadir=/usr/share/doc/${PF}
+}
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake html pdf || die "emake doc failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog TODO* NEWS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/cln.pdf || die
+ dohtml doc/* || die
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cc || die
+ fi
+}