summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-03-25 13:55:20 +0000
committerMark Wright <gienah@gentoo.org>2012-03-25 13:55:20 +0000
commit5b93f84fa718b2ee9122e4bcdc0f11266f7c5a9d (patch)
tree25d94c1f47e888ffabcabd6143ece0ab311caac8 /sci-mathematics/agda
parentMarking maradns-1.4.12 ppc for bug 408883 (diff)
downloadgentoo-2-5b93f84fa718b2ee9122e4bcdc0f11266f7c5a9d.tar.gz
gentoo-2-5b93f84fa718b2ee9122e4bcdc0f11266f7c5a9d.tar.bz2
gentoo-2-5b93f84fa718b2ee9122e4bcdc0f11266f7c5a9d.zip
Thanks to tomprince for adding support for agda-stdlib. Bump to 2.3.0.1, EAPI=4, [profile?] for haskell lib depends.
(Portage version: 2.1.10.51/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/agda')
-rw-r--r--sci-mathematics/agda/ChangeLog9
-rw-r--r--sci-mathematics/agda/agda-2.3.0.1.ebuild69
-rw-r--r--sci-mathematics/agda/agda-2.3.0.ebuild36
-rw-r--r--sci-mathematics/agda/files/agda-2.3.0.1-emacs.patch27
-rw-r--r--sci-mathematics/agda/metadata.xml1
5 files changed, 126 insertions, 16 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index 0cbe0345ff99..c5e173b0f6b0 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/agda
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.11 2012/01/23 13:52:38 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.12 2012/03/25 13:55:19 gienah Exp $
+
+*agda-2.3.0.1 (25 Mar 2012)
+
+ 25 Mar 2012; Mark Wright <gienah@gentoo.org> +agda-2.3.0.1.ebuild,
+ +files/agda-2.3.0.1-emacs.patch, agda-2.3.0.ebuild, metadata.xml:
+ Thanks to tomprince for adding support for agda-stdlib. Bump to 2.3.0.1,
+ EAPI=4, [profile?] for haskell lib depends.
*agda-2.3.0 (23 Jan 2012)
diff --git a/sci-mathematics/agda/agda-2.3.0.1.ebuild b/sci-mathematics/agda/agda-2.3.0.1.ebuild
new file mode 100644
index 000000000000..9822de9ac0eb
--- /dev/null
+++ b/sci-mathematics/agda/agda-2.3.0.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.1.ebuild,v 1.1 2012/03/25 13:55:19 gienah Exp $
+
+# ebuild generated by hackport 0.2.14
+
+EAPI="4"
+
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal eutils elisp-common
+
+MY_PN="Agda"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A dependently typed functional programming language and proof assistant"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="epic +stdlib"
+
+RDEPEND="<dev-haskell/binary-0.6[profile?]
+ epic? ( dev-lang/epic[profile?] )
+ =dev-haskell/hashable-1.1*[profile?]
+ =dev-haskell/hashtables-1.0*[profile?]
+ >=dev-haskell/haskeline-0.6.3.2[profile?]
+ >=dev-haskell/haskell-src-exts-1.9.6[profile?]
+ =dev-haskell/mtl-2.0*[profile?]
+ =dev-haskell/quickcheck-2.4*[profile?]
+ =dev-haskell/xhtml-3000.2*[profile?]
+ <dev-haskell/zlib-0.6[profile?]
+ >=dev-lang/ghc-6.10.4"
+PDEPEND="stdlib? ( sci-mathematics/agda-stdlib )"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.8
+ dev-haskell/happy"
+
+SITEFILE="50${PN}2-gentoo.el"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-emacs.patch
+ cabal-mksetup
+}
+
+src_configure() {
+ cabal_src_configure $(cabal_flag epic)
+}
+
+src_install() {
+ haskell-cabal_src_install
+ elisp-install ${PN} src/data/emacs-mode/*.el \
+ || die "Failed to install emacs mode"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "Failed to install elisp site file"
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ ghc-package_pkg_prerm
+ elisp-site-regen
+}
diff --git a/sci-mathematics/agda/agda-2.3.0.ebuild b/sci-mathematics/agda/agda-2.3.0.ebuild
index 469ba891b76e..72abd016e20d 100644
--- a/sci-mathematics/agda/agda-2.3.0.ebuild
+++ b/sci-mathematics/agda/agda-2.3.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.ebuild,v 1.1 2012/01/23 13:52:38 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.ebuild,v 1.2 2012/03/25 13:55:19 gienah Exp $
# ebuild generated by hackport 0.2.14
-EAPI="3"
+EAPI="4"
-CABAL_FEATURES="lib"
+CABAL_FEATURES="lib profile"
inherit haskell-cabal eutils elisp-common
MY_PN="Agda"
@@ -19,19 +19,20 @@ SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="epic"
+IUSE="epic +stdlib"
-RDEPEND="<dev-haskell/binary-0.6
- epic? ( dev-lang/epic )
- =dev-haskell/hashable-1.1*
- =dev-haskell/hashtables-1.0*
- >=dev-haskell/haskeline-0.6.3.2
- >=dev-haskell/haskell-src-exts-1.9.6
- =dev-haskell/mtl-2.0*
- =dev-haskell/quickcheck-2.4*
- =dev-haskell/xhtml-3000.2*
- <dev-haskell/zlib-0.6
+RDEPEND="<dev-haskell/binary-0.6[profile?]
+ epic? ( dev-lang/epic[profile?] )
+ =dev-haskell/hashable-1.1*[profile?]
+ =dev-haskell/hashtables-1.0*[profile?]
+ >=dev-haskell/haskeline-0.6.3.2[profile?]
+ >=dev-haskell/haskell-src-exts-1.9.6[profile?]
+ =dev-haskell/mtl-2.0*[profile?]
+ =dev-haskell/quickcheck-2.4*[profile?]
+ =dev-haskell/xhtml-3000.2*[profile?]
+ <dev-haskell/zlib-0.6[profile?]
>=dev-lang/ghc-6.10.4"
+PDEPEND="stdlib? ( sci-mathematics/agda-stdlib )"
DEPEND="${RDEPEND}
dev-haskell/alex
>=dev-haskell/cabal-1.8
@@ -41,9 +42,14 @@ SITEFILE="50${PN}2-gentoo.el"
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-emacs.patch
+ epatch "${FILESDIR}"/${P}-ghc-7.4.patch
sed -e 's@epic >= 0.1.13 && < 0.2@epic >= 0.1.13 \&\& < 0.10@' \
+ -e 's@base >= 4.2 && < 4.5@base >= 4.2 \&\& < 4.6@' \
+ -e 's@array >= 0.1 && < 0.4@array >= 0.1 \&\& < 0.5@' \
+ -e 's@filepath >= 1.1 && < 1.3@filepath >= 1.1 \&\& < 1.4@' \
+ -e 's@old-time == 1.0.\*@old-time >= 1.0 \&\& < 1.2@' \
-i "${S}/${MY_PN}.cabal" || die "Could not loosen dependencies"
- epatch "${FILESDIR}"/${P}-emacs.patch
cabal-mksetup
}
diff --git a/sci-mathematics/agda/files/agda-2.3.0.1-emacs.patch b/sci-mathematics/agda/files/agda-2.3.0.1-emacs.patch
new file mode 100644
index 000000000000..e08dc988986b
--- /dev/null
+++ b/sci-mathematics/agda/files/agda-2.3.0.1-emacs.patch
@@ -0,0 +1,27 @@
+--- Agda-2.3.0.1-orig/Agda.cabal 2012-03-12 21:09:34.000000000 +1100
++++ Agda-2.3.0.1/Agda.cabal 2012-03-26 00:07:55.476482395 +1100
+@@ -40,7 +40,6 @@
+ doc/release-notes/*.txt
+ data-dir: src/data
+ data-files: Agda.css
+- emacs-mode/*.el
+ EpicInclude/AgdaPrelude.e
+ EpicInclude/stdagda.c
+ EpicInclude/stdagda.h
+@@ -326,16 +325,3 @@
+ if impl(ghc >= 7.2)
+ ghc-options: -fwarn-identities
+ ghc-prof-options: -auto-all
+-
+-executable agda-mode
+- hs-source-dirs: src/agda-mode
+- main-is: Main.hs
+- other-modules: Paths_Agda
+- if flag(use-locale)
+- build-depends: base >= 4.2 && < 4.6
+- else
+- build-depends: base == 4.1.*,
+- utf8-string == 0.3.*
+- build-depends: filepath >= 1.1 && < 1.4,
+- process >= 1.0.1.0 && < 1.2,
+- directory >= 1.0 && < 1.2
diff --git a/sci-mathematics/agda/metadata.xml b/sci-mathematics/agda/metadata.xml
index 711ce7a4000b..a3f9b74a1fa7 100644
--- a/sci-mathematics/agda/metadata.xml
+++ b/sci-mathematics/agda/metadata.xml
@@ -11,5 +11,6 @@
</longdescription>
<use>
<flag name='epic'>Add support for the epic compiler.</flag>
+ <flag name='stdlib'>Install the standard library.</flag>
</use>
</pkgmetadata>