summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-14 19:53:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-14 19:53:51 +0000
commita11463f6162470de6fe9b840c237c649b752ea51 (patch)
tree3e02d96e5e5f8ff198d468ad935a85d4885b8bd0 /sci-mathematics/agda
parentStable on alpha, bug #327379 (diff)
downloadgentoo-2-a11463f6162470de6fe9b840c237c649b752ea51.tar.gz
gentoo-2-a11463f6162470de6fe9b840c237c649b752ea51.tar.bz2
gentoo-2-a11463f6162470de6fe9b840c237c649b752ea51.zip
Version bump, ebuild originally from markusle (bug #303973). Also forced emacs on dependencies (thanks to ulm, bug #336741)
(Portage version: 2.2_rc81/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/agda')
-rw-r--r--sci-mathematics/agda/ChangeLog12
-rw-r--r--sci-mathematics/agda/agda-1.0.2-r2.ebuild33
-rw-r--r--sci-mathematics/agda/agda-2.2.6.ebuild58
-rw-r--r--sci-mathematics/agda/files/50agda2-gentoo.el10
-rw-r--r--sci-mathematics/agda/files/agda-2.2.6-emacs.patch27
5 files changed, 118 insertions, 22 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index 5e8e3baa87ab..e34cb9858ce5 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/agda
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.8 2008/12/05 16:58:17 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.9 2010/09/14 19:53:51 bicatali Exp $
+
+*agda-2.2.6 (14 Sep 2010)
+
+ 14 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/50agda2-gentoo.el, agda-1.0.2-r2.ebuild, +agda-2.2.6.ebuild,
+ +files/agda-2.2.6-emacs.patch:
+ Version bump, ebuild originally from markusle (bug #303973). Also forced
+ emacs on dependencies (thanks to ulm, bug #336741)
*agda-1.0.2-r2 (05 Dec 2008)
diff --git a/sci-mathematics/agda/agda-1.0.2-r2.ebuild b/sci-mathematics/agda/agda-1.0.2-r2.ebuild
index 5f9d6b6b2dd3..698bf5b369e2 100644
--- a/sci-mathematics/agda/agda-1.0.2-r2.ebuild
+++ b/sci-mathematics/agda/agda-1.0.2-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-1.0.2-r2.ebuild,v 1.1 2008/12/05 16:58:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-1.0.2-r2.ebuild,v 1.2 2010/09/14 19:53:51 bicatali Exp $
+EAPI=2
inherit elisp-common eutils
MY_PN="Agda"
@@ -14,48 +15,40 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="emacs"
+IUSE=""
-RDEPEND="emacs? ( virtual/emacs app-emacs/haskell-mode )"
+RDEPEND="virtual/emacs
+ app-emacs/haskell-mode"
DEPEND="${RDEPEND}
dev-lang/ghc
dev-haskell/mtl"
SITEFILE="50${PN}-gentoo.el"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-make_install.patch
epatch "${FILESDIR}"/${P}-upstream-fixes.patch
-
sed -e "s:-package lang::" -i src/Makefile.in \
|| die "Failed to fix Makfile.in"
}
-src_compile() {
+src_configure() {
econf --enable-newsyntax
- emake || die "emake failed"
- #if use doc ; then
- # emake html
- #fi
}
src_install() {
- emake -C src ROOT="${D}" install || die "make install failed"
+ emake -C src ROOT="${D}" install || die "emake install failed"
dosym /usr/lib/EmacsAgda/bin/emacsagda /usr/bin/emacsagda
dosym emacsagda /usr/bin/agda
- if use emacs; then
- elisp-install ${PN} elisp/agda-mode.el || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
+ elisp-install ${PN} elisp/agda-mode.el || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
}
pkg_postinst() {
- use emacs && elisp-site-regen
+ elisp-site-regen
}
pkg_postrm() {
- use emacs && elisp-site-regen
+ elisp-site-regen
}
diff --git a/sci-mathematics/agda/agda-2.2.6.ebuild b/sci-mathematics/agda/agda-2.2.6.ebuild
new file mode 100644
index 000000000000..e66117bde084
--- /dev/null
+++ b/sci-mathematics/agda/agda-2.2.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.2.6.ebuild,v 1.1 2010/09/14 19:53:51 bicatali Exp $
+
+EAPI="2"
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal eutils elisp-common
+
+MY_PN="Agda"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A dependently typed programming language."
+HOMEPAGE="http://appserv.cs.chalmers.se/users/ulfn/wiki/agda.php"
+SRC_URI="http://code.haskell.org/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/emacs
+ app-emacs/haskell-mode"
+DEPEND="${RDEPEND}
+ >=dev-lang/ghc-6.12
+ dev-haskell/mtl
+ =dev-haskell/quickcheck-2*
+ dev-haskell/haskell-src
+ dev-haskell/haskeline
+ >=dev-haskell/binary-0.4.4
+ =dev-haskell/xhtml-3000.2*
+ >=dev-haskell/zlib-0.4
+ >=dev-haskell/alex-2.0
+ >=dev-haskell/happy-1.15"
+
+SITEFILE="50${PN}2-gentoo.el"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-emacs.patch
+}
+
+src_install() {
+ haskell-cabal_src_install
+ elisp-install ${PN} src/data/emacs-mode/*.el \
+ || die "Failed to install emacs mode"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "Failed to install elisp site file"
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ ghc-package_pkg_prerm
+ elisp-site-regen
+}
diff --git a/sci-mathematics/agda/files/50agda2-gentoo.el b/sci-mathematics/agda/files/50agda2-gentoo.el
new file mode 100644
index 000000000000..fd1367f727e6
--- /dev/null
+++ b/sci-mathematics/agda/files/50agda2-gentoo.el
@@ -0,0 +1,10 @@
+;;; agda site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'agda2-mode "agda2.el"
+ "Major mode for Agda files" t)
+(unless (assoc "\\.agda" auto-mode-alist)
+ (setq auto-mode-alist
+ (nconc '(("\\.agda" . agda2-mode)
+ ("\\.alfa" . agda2-mode)) auto-mode-alist)))
+
diff --git a/sci-mathematics/agda/files/agda-2.2.6-emacs.patch b/sci-mathematics/agda/files/agda-2.2.6-emacs.patch
new file mode 100644
index 000000000000..c9d0493f8a80
--- /dev/null
+++ b/sci-mathematics/agda/files/agda-2.2.6-emacs.patch
@@ -0,0 +1,27 @@
+diff -Naur Agda-2.2.6/Agda.cabal Agda-2.2.6.new/Agda.cabal
+--- Agda-2.2.6/Agda.cabal 2009-12-23 10:39:57.000000000 -0500
++++ Agda-2.2.6.new/Agda.cabal 2010-02-12 10:52:07.000000000 -0500
+@@ -40,7 +40,6 @@
+ doc/release-notes/*.txt
+ data-dir: src/data
+ data-files: Agda.css
+- emacs-mode/*.el
+
+ source-repository head
+ type: darcs
+@@ -274,15 +273,3 @@
+ -fwarn-warnings-deprecations -fwarn-deprecated-flags
+ -fwarn-dodgy-foreign-imports
+ -fwarn-wrong-do-bind -fwarn-dodgy-exports
+-
+-executable agda-mode
+- hs-source-dirs: src/agda-mode
+- main-is: Main.hs
+- other-modules: Paths_Agda
+- if flag(use-locale)
+- build-depends: base == 4.2.*
+- else
+- build-depends: base == 4.1.*,
+- utf8-string == 0.3.*
+- build-depends: filepath >= 1.1 && < 2,
+- process >= 1.0.1.0 && < 2