summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-04-13 14:58:33 +0000
committerMark Wright <gienah@gentoo.org>2012-04-13 14:58:33 +0000
commitd29d6d4521acc64e793f5e6b799f9e848c49deb3 (patch)
treec8da603813a90c4906955cd91577abcc0544dafd /sci-mathematics/agda
parentSupport epatch_user, bug #411447 (diff)
downloadgentoo-2-d29d6d4521acc64e793f5e6b799f9e848c49deb3.tar.gz
gentoo-2-d29d6d4521acc64e793f5e6b799f9e848c49deb3.tar.bz2
gentoo-2-d29d6d4521acc64e793f5e6b799f9e848c49deb3.zip
agda 2.3.0 and 2.3.0.1 requires syb, add more range checks to deps
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/agda')
-rw-r--r--sci-mathematics/agda/ChangeLog6
-rw-r--r--sci-mathematics/agda/agda-2.3.0.1.ebuild10
-rw-r--r--sci-mathematics/agda/agda-2.3.0.ebuild10
3 files changed, 21 insertions, 5 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index 2287fd1a9fdf..ffae3a701b19 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/agda
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.14 2012/04/13 10:56:39 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.15 2012/04/13 14:58:33 gienah Exp $
+
+ 13 Apr 2012; Mark Wright <gienah@gentoo.org> agda-2.3.0.1.ebuild,
+ agda-2.3.0.ebuild:
+ agda 2.3.0 and 2.3.0.1 requires syb, add more range checks to deps
13 Apr 2012; Mark Wright <gienah@gentoo.org>
+files/agda-2.3.0.1-mtl-2.1.patch, agda-2.3.0.1.ebuild:
diff --git a/sci-mathematics/agda/agda-2.3.0.1.ebuild b/sci-mathematics/agda/agda-2.3.0.1.ebuild
index 513a1e06c219..5482c1ee23d9 100644
--- a/sci-mathematics/agda/agda-2.3.0.1.ebuild
+++ b/sci-mathematics/agda/agda-2.3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.1.ebuild,v 1.3 2012/04/13 10:56:39 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.1.ebuild,v 1.4 2012/04/13 14:58:33 gienah Exp $
# ebuild generated by hackport 0.2.14
@@ -21,16 +21,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="epic +stdlib"
-RDEPEND="<dev-haskell/binary-0.6[profile?]
+RDEPEND=">=dev-haskell/binary-0.4.4[profile?]
+ <dev-haskell/binary-0.6[profile?]
epic? ( dev-lang/epic[profile?] )
=dev-haskell/hashable-1.1*[profile?]
=dev-haskell/hashtables-1.0*[profile?]
>=dev-haskell/haskeline-0.6.3.2[profile?]
+ <dev-haskell/haskeline-0.7[profile?]
>=dev-haskell/haskell-src-exts-1.9.6[profile?]
+ <dev-haskell/haskell-src-exts-1.14[profile?]
>=dev-haskell/mtl-2.0[profile?]
<dev-haskell/mtl-2.2[profile?]
=dev-haskell/quickcheck-2.4*[profile?]
+ >=dev-haskell/syb-0.1[profile?]
+ <dev-haskell/syb-0.4[profile?]
=dev-haskell/xhtml-3000.2*[profile?]
+ >=dev-haskell/zlib-0.4.0.1[profile?]
<dev-haskell/zlib-0.6[profile?]
>=dev-lang/ghc-6.10.4"
PDEPEND="stdlib? ( sci-mathematics/agda-stdlib )"
diff --git a/sci-mathematics/agda/agda-2.3.0.ebuild b/sci-mathematics/agda/agda-2.3.0.ebuild
index 72abd016e20d..95f343ce0b31 100644
--- a/sci-mathematics/agda/agda-2.3.0.ebuild
+++ b/sci-mathematics/agda/agda-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.ebuild,v 1.2 2012/03/25 13:55:19 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.ebuild,v 1.3 2012/04/13 14:58:33 gienah Exp $
# ebuild generated by hackport 0.2.14
@@ -21,15 +21,21 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="epic +stdlib"
-RDEPEND="<dev-haskell/binary-0.6[profile?]
+RDEPEND=">=dev-haskell/binary-0.4.4[profile?]
+ <dev-haskell/binary-0.6[profile?]
epic? ( dev-lang/epic[profile?] )
=dev-haskell/hashable-1.1*[profile?]
=dev-haskell/hashtables-1.0*[profile?]
>=dev-haskell/haskeline-0.6.3.2[profile?]
+ <dev-haskell/haskeline-0.7[profile?]
>=dev-haskell/haskell-src-exts-1.9.6[profile?]
+ <dev-haskell/haskell-src-exts-1.12[profile?]
=dev-haskell/mtl-2.0*[profile?]
=dev-haskell/quickcheck-2.4*[profile?]
+ >=dev-haskell/syb-0.1[profile?]
+ <dev-haskell/syb-0.4[profile?]
=dev-haskell/xhtml-3000.2*[profile?]
+ >=dev-haskell/zlib-0.4.0.1[profile?]
<dev-haskell/zlib-0.6[profile?]
>=dev-lang/ghc-6.10.4"
PDEPEND="stdlib? ( sci-mathematics/agda-stdlib )"