summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-10-28 14:13:26 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-10-28 14:13:26 +0000
commitd6e0157c13fd76477dea2bf93fa3b86a8edccbd3 (patch)
treeca8b63e67f8072623277857411301f967c250fa7 /sci-mathematics/fann
parentfix ChangeLog header (diff)
downloadgentoo-2-d6e0157c13fd76477dea2bf93fa3b86a8edccbd3.tar.gz
gentoo-2-d6e0157c13fd76477dea2bf93fa3b86a8edccbd3.tar.bz2
gentoo-2-d6e0157c13fd76477dea2bf93fa3b86a8edccbd3.zip
Version bump (this fixes bug #82918).
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'sci-mathematics/fann')
-rw-r--r--sci-mathematics/fann/ChangeLog11
-rw-r--r--sci-mathematics/fann/fann-2.0.0.ebuild69
-rw-r--r--sci-mathematics/fann/files/digest-fann-2.0.03
-rw-r--r--sci-mathematics/fann/files/fann-2.0.0-benchmark.patch49
-rw-r--r--sci-mathematics/fann/files/fann-2.0.0-shared-libs-gentoo.patch23
5 files changed, 153 insertions, 2 deletions
diff --git a/sci-mathematics/fann/ChangeLog b/sci-mathematics/fann/ChangeLog
index 5ffbd81c2996..2f371a59a33b 100644
--- a/sci-mathematics/fann/ChangeLog
+++ b/sci-mathematics/fann/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/fann
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/ChangeLog,v 1.4 2005/08/24 09:31:15 satya Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/ChangeLog,v 1.5 2006/10/28 14:13:26 markusle Exp $
+
+*fann-2.0.0 (28 Oct 2006)
+
+ 28 Oct 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/fann-2.0.0-shared-libs-gentoo.patch,
+ +files/fann-2.0.0-benchmark.patch, +fann-2.0.0.ebuild:
+ Version bump (this fixes bug #82918).
24 Aug 2005; Christian Andreetta <satya@gentoo.org> fann-1.2.0.ebuild,
fann-1.2.0-r1.ebuild:
diff --git a/sci-mathematics/fann/fann-2.0.0.ebuild b/sci-mathematics/fann/fann-2.0.0.ebuild
new file mode 100644
index 000000000000..bf849f15232c
--- /dev/null
+++ b/sci-mathematics/fann/fann-2.0.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.0.0.ebuild,v 1.1 2006/10/28 14:13:26 markusle Exp $
+
+inherit eutils
+
+DESCRIPTION="Fast Artificial Neural Network Library implements multilayer artificial neural networks in C"
+HOMEPAGE="http://leenissen.dk/fann/"
+SRC_URI="mirror://sourceforge/fann/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc python"
+
+DEPEND="python? ( dev-lang/python dev-lang/swig )"
+
+
+src_unpack() {
+ unpack ${A} || die
+ cd "${S}" || die
+ epatch "${FILESDIR}"/${P}-shared-libs-gentoo.patch
+ epatch "${FILESDIR}"/${P}-benchmark.patch
+}
+
+
+src_compile() {
+ econf ${myconf} || die "configure failed"
+ emake || die "failed to build src"
+ if use python; then
+ cd ${S}/python || \
+ die "failed to step into python subdirectory"
+ emake || die "failed to build python wrappers"
+ fi
+}
+
+src_install() {
+ cd "${S}"
+ make install DESTDIR=${D} || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use doc; then
+ dodoc doc/*.txt || \
+ die "failed to install docs"
+ insinto /usr/share/doc/${P}
+ doins doc/fann_en.pdf || \
+ die "failed to install reference manual"
+ insinto /usr/share/${PN}/benchmarks
+ doins -r benchmarks/* || \
+ die "failed to install benchmarks"
+ insinto /usr/share/${PN}/examples
+ doins examples/* || \
+ die "failed to install examples"
+ fi
+
+ if use python; then
+ cd ${S}/python || \
+ die "Faild to step into python subdirectory"
+ make install ROOT=${D} || \
+ die "failed to install python wrappers"
+ if use doc; then
+ local python_doc_dir="/usr/share/${PN}/examples/python"
+ insinto ${python_doc_dir}
+ doins examples/* || \
+ die "failed to install python examples"
+ fi
+ fi
+}
+
diff --git a/sci-mathematics/fann/files/digest-fann-2.0.0 b/sci-mathematics/fann/files/digest-fann-2.0.0
new file mode 100644
index 000000000000..4e5accece56d
--- /dev/null
+++ b/sci-mathematics/fann/files/digest-fann-2.0.0
@@ -0,0 +1,3 @@
+MD5 4224efa533265dcf39237667973d0e20 fann-2.0.0.tar.bz2 2310853
+RMD160 9d7268eaf06ab177eafb72359a1cf73a70e5a886 fann-2.0.0.tar.bz2 2310853
+SHA256 762a1313a9b935300cb66ebf052d469d04823ca721fe6dd2a49c01e13e8ab30a fann-2.0.0.tar.bz2 2310853
diff --git a/sci-mathematics/fann/files/fann-2.0.0-benchmark.patch b/sci-mathematics/fann/files/fann-2.0.0-benchmark.patch
new file mode 100644
index 000000000000..ec37e9940a63
--- /dev/null
+++ b/sci-mathematics/fann/files/fann-2.0.0-benchmark.patch
@@ -0,0 +1,49 @@
+diff -Naur fann-2.0.0/benchmarks/Makefile fann-2.0.0-new/benchmarks/Makefile
+--- fann-2.0.0/benchmarks/Makefile 2005-11-29 16:33:12.000000000 -0500
++++ fann-2.0.0-new/benchmarks/Makefile 2006-10-28 09:08:00.000000000 -0400
+@@ -16,7 +16,7 @@
+ all: $(TARGETS)
+
+ quality: quality.cc
+- $(G++) $(CFLAGS) $(LFLAGS) -I$(JNEURALDIR)include/ -L$(JNEURALDIR) -I$(LWNNDIR) -L$(LWNNDIR) $< -o $@ -lfloatfann -llwneuralnet -ljneural -lfl
++ $(G++) $(CFLAGS) $(LFLAGS) -I$(JNEURALDIR)include/ -L$(JNEURALDIR) -I$(LWNNDIR) -L$(LWNNDIR) $< -o $@ -lfloatfann -lfl
+
+ quality_fixed: quality_fixed.c
+ $(GCC) $(CFLAGS) $(LFLAGS) $< -o $@ -lfixedfann
+@@ -25,7 +25,7 @@
+ $(GCC) -ggdb -lm -DDEBUG -Wall -ansi -I../src/ -I../src/include/ ../src/fixedfann.c $< -o $@
+
+ performance: performance.cc
+- $(G++) $(CFLAGS) $(LFLAGS) -I$(JNEURALDIR)include/ -L$(JNEURALDIR) -I$(LWNNDIR) -L$(LWNNDIR) $< -o $@ -lfloatfann -llwneuralnet -ljneural -lfl
++ $(G++) $(CFLAGS) $(LFLAGS) -I$(JNEURALDIR)include/ -L$(JNEURALDIR) -I$(LWNNDIR) -L$(LWNNDIR) $< -o $@ -lfloatfann -lfl
+
+ performance_fixed: performance.cc
+ $(G++) $(CFLAGS) $(LFLAGS) -DFIXEDFANN $< -o $@ -lfixedfann
+diff -Naur fann-2.0.0/benchmarks/performance.cc fann-2.0.0-new/benchmarks/performance.cc
+--- fann-2.0.0/benchmarks/performance.cc 2005-10-24 16:48:47.000000000 -0400
++++ fann-2.0.0-new/benchmarks/performance.cc 2006-10-28 09:08:28.000000000 -0400
+@@ -19,8 +19,8 @@
+
+ //uncomment lines below to benchmark the libraries
+
+-#define JNEURAL
+-#define LWNN
++/*#define JNEURAL
++#define LWNN */
+
+ #include <stdio.h>
+ #include <stdlib.h>
+diff -Naur fann-2.0.0/benchmarks/quality.cc fann-2.0.0-new/benchmarks/quality.cc
+--- fann-2.0.0/benchmarks/quality.cc 2005-11-29 16:33:12.000000000 -0500
++++ fann-2.0.0-new/benchmarks/quality.cc 2006-10-28 09:08:19.000000000 -0400
+@@ -19,8 +19,8 @@
+
+ //uncomment lines below to benchmark the libraries
+
+-#define JNEURAL
+-#define LWNN
++/*#define JNEURAL
++#define LWNN */
+
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/sci-mathematics/fann/files/fann-2.0.0-shared-libs-gentoo.patch b/sci-mathematics/fann/files/fann-2.0.0-shared-libs-gentoo.patch
new file mode 100644
index 000000000000..2d9782a563a2
--- /dev/null
+++ b/sci-mathematics/fann/files/fann-2.0.0-shared-libs-gentoo.patch
@@ -0,0 +1,23 @@
+diff -Naur fann-2.0.0/python/pyfann/Makefile fann-2.0.0-new/python/pyfann/Makefile
+--- fann-2.0.0/python/pyfann/Makefile 2005-12-02 20:22:43.000000000 -0500
++++ fann-2.0.0-new/python/pyfann/Makefile 2006-10-28 07:36:34.000000000 -0400
+@@ -10,7 +10,7 @@
+ all: $(TARGETS)
+
+ _%.so: pyfann_wrap.o fann_helper.o
+- gcc $(LIBS) -shared -dll $^ -o $@
++ gcc $(LIBS) -fPIC -shared -dll $^ -o $@
+
+ %.o: %.c
+ gcc -c $< -I/usr/include/$(PYTHON)/ -I$(FANN_DIR)/src/include/
+diff -Naur fann-2.0.0/python/setup.py fann-2.0.0-new/python/setup.py
+--- fann-2.0.0/python/setup.py 2006-01-06 16:45:28.000000000 -0500
++++ fann-2.0.0-new/python/setup.py 2006-10-28 07:36:07.000000000 -0400
+@@ -40,6 +40,6 @@
+ url='http://sourceforge.net/projects/fann/',
+ license='GNU LESSER GENERAL PUBLIC LICENSE (LGPL)',
+ py_modules=['pyfann.libfann','pyfann.fann'],
+- ext_modules=[Extension('pyfann._libfann',['pyfann/pyfann.i','pyfann/fann_helper.c'], include_dirs=['../src/include'], extra_objects=['../src/doublefann.o']) ]
++ ext_modules=[Extension('pyfann._libfann',['pyfann/pyfann.i','pyfann/fann_helper.c'], include_dirs=['../src/include'], extra_objects=['../src/.libs/doublefann.o']) ]
+ )
+