summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-21 00:22:03 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-21 00:22:03 +0000
commit8905c953d5ba0042e68ed720c9726737c51091f1 (patch)
tree43c774f46fd25475e1f97c1d6dbb8589182b38db /sci-mathematics/mathomatic
parentfix deps for last commit (diff)
downloadgentoo-2-8905c953d5ba0042e68ed720c9726737c51091f1.tar.gz
gentoo-2-8905c953d5ba0042e68ed720c9726737c51091f1.tar.bz2
gentoo-2-8905c953d5ba0042e68ed720c9726737c51091f1.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog10
-rw-r--r--sci-mathematics/mathomatic/mathomatic-15.7.2.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index 94b225ff8c5e..128954ff0a21 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.60 2011/11/25 17:48:00 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.61 2012/01/21 00:22:03 bicatali Exp $
+
+*mathomatic-15.7.2 (21 Jan 2012)
+
+ 21 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +mathomatic-15.7.2.ebuild:
+ Version bump
*mathomatic-15.7.1 (25 Nov 2011)
diff --git a/sci-mathematics/mathomatic/mathomatic-15.7.2.ebuild b/sci-mathematics/mathomatic/mathomatic-15.7.2.ebuild
new file mode 100644
index 000000000000..01c4a57ff4c6
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-15.7.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-15.7.2.ebuild,v 1.1 2012/01/21 00:22:03 bicatali Exp $
+
+EAPI=4
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.org/"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ append-cflags -DBOLD_COLOR=1
+ emake READLINE=1 CC=$(tc-getCC)
+ emake CC=$(tc-getCC) -C primes
+}
+
+src_test() {
+ default
+ emake -C primes check
+}
+
+src_install() {
+ emake prefix="${EPREFIX}usr" DESTDIR="${D}" bininstall
+ emake prefix="${EPREFIX}usr" DESTDIR="${D}" -C primes install
+ dodoc changes.txt README.txt AUTHORS
+ newdoc primes/README.txt README-primes.txt
+ use doc && emake \
+ prefix="${EPREFIX}usr" \
+ mathdocdir="${EPREFIX}usr/share/doc/${PF}" \
+ DESTDIR="${D}" docinstall
+}