summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-06 14:20:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-06 14:20:34 +0000
commitb6f7730d313e7f78233ae2042c9e35a08830016b (patch)
treef898b90c2b85d67f27bb9819ca0d99404065b8b3 /sci-mathematics/msieve
parentVersion bump for security bug 437366. (diff)
downloadgentoo-2-b6f7730d313e7f78233ae2042c9e35a08830016b.tar.gz
gentoo-2-b6f7730d313e7f78233ae2042c9e35a08830016b.tar.bz2
gentoo-2-b6f7730d313e7f78233ae2042c9e35a08830016b.zip
Adding live ebuild
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/msieve')
-rw-r--r--sci-mathematics/msieve/ChangeLog7
-rw-r--r--sci-mathematics/msieve/msieve-9999.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/sci-mathematics/msieve/ChangeLog b/sci-mathematics/msieve/ChangeLog
index 9be2ecfcadf4..c8d01faf424e 100644
--- a/sci-mathematics/msieve/ChangeLog
+++ b/sci-mathematics/msieve/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/msieve
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/ChangeLog,v 1.10 2013/01/06 13:35:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/ChangeLog,v 1.11 2013/01/06 14:20:34 patrick Exp $
+
+*msieve-9999 (06 Jan 2013)
+
+ 06 Jan 2013; Patrick Lauer <patrick@gentoo.org> +msieve-9999.ebuild:
+ Adding live ebuild
06 Jan 2013; Patrick Lauer <patrick@gentoo.org> msieve-1.50-r4.ebuild:
Small dependency tweak to avoid linking problems
diff --git a/sci-mathematics/msieve/msieve-9999.ebuild b/sci-mathematics/msieve/msieve-9999.ebuild
new file mode 100644
index 000000000000..6e46621f34e5
--- /dev/null
+++ b/sci-mathematics/msieve/msieve-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/msieve-9999.ebuild,v 1.1 2013/01/06 14:20:34 patrick Exp $
+
+EAPI=4
+DESCRIPTION="A C library implementing a suite of algorithms to factor large integers"
+HOMEPAGE="http://sourceforge.net/projects/msieve/"
+#SRC_URI="mirror://sourceforge/${PN}/${PN}/Msieve%20v${PV}/${PN}${PV/./}src.tar.gz"
+ESVN_REPO_URI="https://msieve.svn.sourceforge.net/svnroot/msieve"
+
+inherit eutils subversion
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS=""
+IUSE="zlib +ecm mpi"
+
+# some linking troubles with gwnum
+DEPEND="ecm? ( sci-mathematics/gmp-ecm[-gwnum] )
+ mpi? ( virtual/mpi )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cd trunk
+ # TODO: Integrate ggnfs properly
+ sed -i -e 's/-march=k8//' Makefile || die
+ sed -i -e 's/CC =/#CC =/' Makefile || die
+ sed -i -e 's/CFLAGS =/CFLAGS +=/' Makefile || die
+}
+
+src_compile() {
+ cd trunk
+ if use ecm; then
+ export "ECM=1"
+ fi
+ if use mpi; then
+ export "MPI=1"
+ fi
+ if use zlib; then
+ export "ZLIB=1"
+ fi
+ emake all || die "Failed to build"
+}
+
+src_install() {
+ cd trunk
+ mkdir -p "${D}/usr/include/msieve"
+ mkdir -p "${D}/usr/lib/"
+ mkdir -p "${D}/usr/share/doc/${P}/"
+ cp include/* "${D}/usr/include/msieve" || die "Failed to install"
+ cp libmsieve.a "${D}/usr/lib/" || die "Failed to install"
+ dobin msieve || die "Failed to install"
+ cp Readme* "${D}/usr/share/doc/${P}/" || die "Failed to install"
+}