summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-02-20 00:59:19 +0000
committerMark Wright <gienah@gentoo.org>2014-02-20 00:59:19 +0000
commit7d5bb0510d30cddb6a18cd60b44eebb143d338d5 (patch)
tree528a24377c135da95a050a6a1b995e3308f63c93 /sci-mathematics/octave
parentBeta channel bump. (diff)
downloadgentoo-2-7d5bb0510d30cddb6a18cd60b44eebb143d338d5.tar.gz
gentoo-2-7d5bb0510d30cddb6a18cd60b44eebb143d338d5.tar.bz2
gentoo-2-7d5bb0510d30cddb6a18cd60b44eebb143d338d5.zip
Fix bug 501762, pkg-pretend check that dependencies are built with the same blas library as currently selected with "eselect blas show" was incorrect when "pkg-config --libs-only-l blas" listed more than 1 library, thanks to Helmut Jarausch for reporting.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog8
-rw-r--r--sci-mathematics/octave/octave-3.8.0.ebuild4
2 files changed, 9 insertions, 3 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 9b4d9ebe19b2..0a89ba9f75c1 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.149 2014/02/19 23:47:48 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.150 2014/02/20 00:59:19 gienah Exp $
+
+ 20 Feb 2014; Mark Wright <gienah@gentoo.org> octave-3.8.0.ebuild:
+ Fix bug 501762, pkg-pretend check that dependencies are built with the same
+ blas library as currently selected with "eselect blas show" was incorrect when
+ "pkg-config --libs-only-l blas" listed more than 1 library, thanks to Helmut
+ Jarausch for reporting.
19 Feb 2014; Mark Wright <gienah@gentoo.org> octave-3.8.0.ebuild:
Thanks to Olivier Huber for fixing and reporting bug 501784: replace the use
diff --git a/sci-mathematics/octave/octave-3.8.0.ebuild b/sci-mathematics/octave/octave-3.8.0.ebuild
index 06137d1c6a27..89276e82f0ed 100644
--- a/sci-mathematics/octave/octave-3.8.0.ebuild
+++ b/sci-mathematics/octave/octave-3.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.8.0.ebuild,v 1.2 2014/02/19 23:47:48 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.8.0.ebuild,v 1.3 2014/02/20 00:59:19 gienah Exp $
EAPI=5
@@ -81,7 +81,7 @@ PATCHES=(
pkg_pretend() {
if use qrupdate || use sparse; then
- local blaslib=$(pkg-config --libs-only-l "blas" | sed -e 's@.*-l@lib@' | cut -d' ' -f 1)
+ local blaslib=$(pkg-config --libs-only-l "blas" | sed -e 's@-l\([^ \t]*\)@lib\1@' | cut -d' ' -f 1)
einfo "Checking dependencies are built with the same blas lib = ${blaslib}"
local usr_lib="${ROOT}usr/$(get_libdir)"
local libs=( )