summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-04-17 22:54:19 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-04-17 22:54:19 +0000
commit3e81ea057b62890d8304aaa62d996a1910644b92 (patch)
treec91ef9f8e54ada314e6ac384197eded5ffbe635e /sci-mathematics
parentAddress llvm-2.9 problems, bug #351338. (diff)
downloadgentoo-2-3e81ea057b62890d8304aaa62d996a1910644b92.tar.gz
gentoo-2-3e81ea057b62890d8304aaa62d996a1910644b92.tar.bz2
gentoo-2-3e81ea057b62890d8304aaa62d996a1910644b92.zip
Updated and added previous version and missing patch (doh!)
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/minisat/ChangeLog10
-rw-r--r--sci-mathematics/minisat/files/minisat-2.2.0-header_fix.patch160
-rw-r--r--sci-mathematics/minisat/minisat-2.1.0.ebuild96
-rw-r--r--sci-mathematics/minisat/minisat-2.2.0-r3.ebuild13
4 files changed, 276 insertions, 3 deletions
diff --git a/sci-mathematics/minisat/ChangeLog b/sci-mathematics/minisat/ChangeLog
index 662aa5b0c676..4c886a799522 100644
--- a/sci-mathematics/minisat/ChangeLog
+++ b/sci-mathematics/minisat/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/minisat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/minisat/ChangeLog,v 1.5 2011/04/16 21:43:53 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/minisat/ChangeLog,v 1.6 2011/04/17 22:54:19 nerdboy Exp $
+
+*minisat-2.1.0 (17 Apr 2011)
+
+ 17 Apr 2011; Steve Arnold <nerdboy@gentoo.org> +minisat-2.1.0.ebuild,
+ minisat-2.2.0-r3.ebuild, +files/minisat-2.2.0-header_fix.patch:
+ Updated and added previous version and missing patch (doh!). The
+ slightly older minisat2 is required for other tools, but is not fully
+ compatible with the 2.2 release.
*minisat-2.2.0-r3 (16 Apr 2011)
diff --git a/sci-mathematics/minisat/files/minisat-2.2.0-header_fix.patch b/sci-mathematics/minisat/files/minisat-2.2.0-header_fix.patch
new file mode 100644
index 000000000000..486c012fe2a4
--- /dev/null
+++ b/sci-mathematics/minisat/files/minisat-2.2.0-header_fix.patch
@@ -0,0 +1,160 @@
+--- ./utils/System.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./utils/System.h 2011-04-12 18:33:41.000000000 -0700
+@@ -25,7 +25,7 @@
+ #include <fpu_control.h>
+ #endif
+
+-#include "mtl/IntTypes.h"
++#include <mtl/IntTypes.h>
+
+ //-------------------------------------------------------------------------------------------------
+
+--- ./utils/Options.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./utils/Options.h 2011-04-12 18:34:38.000000000 -0700
+@@ -25,9 +25,9 @@
+ #include <math.h>
+ #include <string.h>
+
+-#include "mtl/IntTypes.h"
+-#include "mtl/Vec.h"
+-#include "utils/ParseUtils.h"
++#include <mtl/IntTypes.h>
++#include <mtl/Vec.h>
++#include "ParseUtils.h"
+
+ namespace Minisat {
+
+--- ./core/SolverTypes.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./core/SolverTypes.h 2011-04-12 18:27:58.000000000 -0700
+@@ -24,11 +24,11 @@
+
+ #include <assert.h>
+
+-#include "mtl/IntTypes.h"
+-#include "mtl/Alg.h"
+-#include "mtl/Vec.h"
+-#include "mtl/Map.h"
+-#include "mtl/Alloc.h"
++#include <mtl/IntTypes.h>
++#include <mtl/Alg.h>
++#include <mtl/Vec.h>
++#include <mtl/Map.h>
++#include <mtl/Alloc.h>
+
+ namespace Minisat {
+
+--- ./core/Solver.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./core/Solver.h 2011-04-12 18:26:56.000000000 -0700
+@@ -21,11 +21,11 @@
+ #ifndef Minisat_Solver_h
+ #define Minisat_Solver_h
+
+-#include "mtl/Vec.h"
+-#include "mtl/Heap.h"
+-#include "mtl/Alg.h"
+-#include "utils/Options.h"
+-#include "core/SolverTypes.h"
++#include <mtl/Vec.h>
++#include <mtl/Heap.h>
++#include <mtl/Alg.h>
++#include <utils/Options.h>
++#include "SolverTypes.h"
+
+
+ namespace Minisat {
+--- ./mtl/Vec.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./mtl/Vec.h 2011-04-12 18:30:50.000000000 -0700
+@@ -24,8 +24,8 @@
+ #include <assert.h>
+ #include <new>
+
+-#include "mtl/IntTypes.h"
+-#include "mtl/XAlloc.h"
++#include "IntTypes.h"
++#include "XAlloc.h"
+
+ namespace Minisat {
+
+--- ./mtl/Sort.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./mtl/Sort.h 2011-04-12 18:31:05.000000000 -0700
+@@ -21,7 +21,7 @@
+ #ifndef Minisat_Sort_h
+ #define Minisat_Sort_h
+
+-#include "mtl/Vec.h"
++#include "Vec.h"
+
+ //=================================================================================================
+ // Some sorting algorithms for vec's
+--- ./mtl/Alg.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./mtl/Alg.h 2011-04-12 18:32:26.000000000 -0700
+@@ -21,7 +21,7 @@
+ #ifndef Minisat_Alg_h
+ #define Minisat_Alg_h
+
+-#include "mtl/Vec.h"
++#include "Vec.h"
+
+ namespace Minisat {
+
+--- ./mtl/Alloc.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./mtl/Alloc.h 2011-04-12 18:32:18.000000000 -0700
+@@ -21,8 +21,8 @@
+ #ifndef Minisat_Alloc_h
+ #define Minisat_Alloc_h
+
+-#include "mtl/XAlloc.h"
+-#include "mtl/Vec.h"
++#include "XAlloc.h"
++#include "Vec.h"
+
+ namespace Minisat {
+
+--- ./mtl/Heap.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./mtl/Heap.h 2011-04-12 18:32:05.000000000 -0700
+@@ -21,7 +21,7 @@
+ #ifndef Minisat_Heap_h
+ #define Minisat_Heap_h
+
+-#include "mtl/Vec.h"
++#include "Vec.h"
+
+ namespace Minisat {
+
+--- ./mtl/Map.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./mtl/Map.h 2011-04-12 18:31:36.000000000 -0700
+@@ -20,8 +20,8 @@
+ #ifndef Minisat_Map_h
+ #define Minisat_Map_h
+
+-#include "mtl/IntTypes.h"
+-#include "mtl/Vec.h"
++#include "IntTypes.h"
++#include "Vec.h"
+
+ namespace Minisat {
+
+--- ./mtl/Queue.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./mtl/Queue.h 2011-04-12 18:31:18.000000000 -0700
+@@ -21,7 +21,7 @@
+ #ifndef Minisat_Queue_h
+ #define Minisat_Queue_h
+
+-#include "mtl/Vec.h"
++#include "Vec.h"
+
+ namespace Minisat {
+
+--- ./simp/SimpSolver.h.orig 2010-07-10 09:07:36.000000000 -0700
++++ ./simp/SimpSolver.h 2011-04-12 18:35:20.000000000 -0700
+@@ -21,8 +21,8 @@
+ #ifndef Minisat_SimpSolver_h
+ #define Minisat_SimpSolver_h
+
+-#include "mtl/Queue.h"
+-#include "core/Solver.h"
++#include <mtl/Queue.h>
++#include <core/Solver.h>
+
+
+ namespace Minisat {
diff --git a/sci-mathematics/minisat/minisat-2.1.0.ebuild b/sci-mathematics/minisat/minisat-2.1.0.ebuild
new file mode 100644
index 000000000000..2a57f5af9c59
--- /dev/null
+++ b/sci-mathematics/minisat/minisat-2.1.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/minisat/minisat-2.1.0.ebuild,v 1.1 2011/04/17 22:54:19 nerdboy Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}2-070721"
+
+DESCRIPTION="Small yet efficient SAT solver with reference paper."
+HOMEPAGE="http://minisat.se/Main.html"
+SRC_URI="http://minisat.se/downloads/${MY_P}.zip
+ doc? ( http://minisat.se/downloads/MiniSat.pdf )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT"
+
+IUSE="debug doc extended-solver"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if use debug; then
+ myconf="d"
+ myext="debug"
+ else
+ myconf="r"
+ myext="release"
+ fi
+
+ if use extended-solver; then
+ mydir="simp"
+ else
+ mydir="core"
+ fi
+
+ tc-export CXX
+
+ if has_version ">=sci-mathematics/minisat-2.2.0" ; then
+ elog ""
+ elog "The minisat2 2.1 and 2.2 ABIs are not compatible and there"
+ elog "is currently no slotting. Please mask it yourself (eg, in"
+ elog "packages.mask) if you need to use the 2.1x version."
+ elog ""
+ epause 5
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "s|-O3|${CFLAGS} ${LDFLAGS}|" \
+ -e "s|@\$(CXX)|\$(CXX)|" \
+ mtl/template.mk || die
+}
+
+src_compile() {
+ export MROOT="${S}"
+ emake -C ${mydir} "$myconf" || die
+
+ if ! use debug; then
+ LIB="${PN}" emake -C ${mydir} lib || die
+ else
+ LIB="${PN}" emake -C ${mydir} libd || die
+ fi
+}
+
+src_install() {
+ # somewhat brute-force, but so is the build setup...
+
+ insinto /usr/include/${PN}2/mtl
+ doins mtl/*.h || die
+
+ insinto /usr/include/${PN}2/core
+ doins core/Solver*.h || die
+
+ insinto /usr/include/${PN}2/simp
+ doins simp/Simp*.h || die
+
+ if ! use debug; then
+ newbin ${mydir}/${PN}_${myext} ${PN} || die
+ dolib.a ${mydir}/lib${PN}.a || die
+ else
+ newbin ${mydir}/${PN}_${myext} ${PN} || die
+ newlib.a ${mydir}/lib${PN}_${myext}.a lib${PN}.a || die
+ fi
+
+ dodoc README || die
+ if use doc; then
+ dodoc "${DISTDIR}"/MiniSat.pdf || die
+ fi
+}
diff --git a/sci-mathematics/minisat/minisat-2.2.0-r3.ebuild b/sci-mathematics/minisat/minisat-2.2.0-r3.ebuild
index 76eb04624350..19a35276b91f 100644
--- a/sci-mathematics/minisat/minisat-2.2.0-r3.ebuild
+++ b/sci-mathematics/minisat/minisat-2.2.0-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/minisat/minisat-2.2.0-r3.ebuild,v 1.1 2011/04/16 21:43:53 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/minisat/minisat-2.2.0-r3.ebuild,v 1.2 2011/04/17 22:54:19 nerdboy Exp $
-EAPI="4"
+EAPI="2"
inherit eutils toolchain-funcs
@@ -37,6 +37,15 @@ pkg_setup() {
mydir="core"
fi
tc-export CXX
+
+ if has_version "=sci-mathematics/minisat-2.1*" ; then
+ elog ""
+ elog "The minisat2 2.1 and 2.2 ABIs are not compatible and there"
+ elog "is currently no slotting. Please mask it yourself (eg, in"
+ elog "packages.mask) if you still need the older version."
+ elog ""
+ epause 5
+ fi
}
src_prepare() {