summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2012-05-11 16:11:40 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2012-05-11 16:11:40 +0000
commitc0a392a36002a69db4d0808a18e2ef54744bba64 (patch)
treec1985961ac5eddafd29ef21705bdee3a9ba265af /sci-mathematics
parentVersion bump. (diff)
downloadgentoo-2-c0a392a36002a69db4d0808a18e2ef54744bba64.tar.gz
gentoo-2-c0a392a36002a69db4d0808a18e2ef54744bba64.tar.bz2
gentoo-2-c0a392a36002a69db4d0808a18e2ef54744bba64.zip
New package: Machine Learning PYthon (mlpy) is a high-performance Python library for predictive modeling.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mlpy/ChangeLog11
-rw-r--r--sci-mathematics/mlpy/metadata.xml8
-rw-r--r--sci-mathematics/mlpy/mlpy-3.5.0.ebuild31
3 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/mlpy/ChangeLog b/sci-mathematics/mlpy/ChangeLog
new file mode 100644
index 000000000000..490b111515b7
--- /dev/null
+++ b/sci-mathematics/mlpy/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/mlpy
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mlpy/ChangeLog,v 1.1 2012/05/11 16:11:40 dberkholz Exp $
+
+*mlpy-3.5.0 (11 May 2012)
+
+ 11 May 2012; Donnie Berkholz <dberkholz@gentoo.org>; +mlpy-3.5.0.ebuild,
+ +metadata.xml:
+ New package: Machine Learning PYthon (mlpy) is a high-performance Python
+ library for predictive modeling.
+
diff --git a/sci-mathematics/mlpy/metadata.xml b/sci-mathematics/mlpy/metadata.xml
new file mode 100644
index 000000000000..f48d50709994
--- /dev/null
+++ b/sci-mathematics/mlpy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dberkholz@gentoo.org</email>
+ <name>Donnie Berkholz</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-mathematics/mlpy/mlpy-3.5.0.ebuild b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
new file mode 100644
index 000000000000..79837aa931d9
--- /dev/null
+++ b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mlpy/mlpy-3.5.0.ebuild,v 1.1 2012/05/11 16:11:40 dberkholz Exp $
+
+EAPI=4
+
+inherit distutils
+
+DESCRIPTION="Machine Learning PYthon (mlpy) is a high-performance Python library for predictive modeling"
+HOMEPAGE="https://mlpy.fbk.eu/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+RDEPEND=">=sci-libs/gsl-1.11
+ >=dev-python/numpy-1.3
+ >=sci-libs/scipy-0.7
+ >=dev-lang/python-2.6"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ pushd docs 2>/dev/null || die
+ emake html || die
+ dohtml -r build/html/*
+ popd 2>/dev/null || die
+ fi
+}