summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-01 15:17:35 +0000
committerMark Wright <gienah@gentoo.org>2014-03-01 15:17:35 +0000
commitcecbea469ad9d5d64ff6e7affa01e4a101da9554 (patch)
tree769f6ce6971fc28fbbf66bb7b7818e26a5c21026 /sci-mathematics
parentRemove empty tag. (diff)
downloadgentoo-2-cecbea469ad9d5d64ff6e7affa01e4a101da9554.tar.gz
gentoo-2-cecbea469ad9d5d64ff6e7affa01e4a101da9554.tar.bz2
gentoo-2-cecbea469ad9d5d64ff6e7affa01e4a101da9554.zip
Thanks to David Kredba for reporting, add gui USE flag to add x11-libs/qscintilla dependency. Remove 3.8.1-rc3 at it is obsoleted by 3.8.1-rc4.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog10
-rw-r--r--sci-mathematics/octave/metadata.xml1
-rw-r--r--sci-mathematics/octave/octave-3.8.1_rc4-r1.ebuild (renamed from sci-mathematics/octave/octave-3.8.1_rc3.ebuild)9
3 files changed, 15 insertions, 5 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 76a9dbaf8d8b..d45290de7fe6 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.158 2014/03/01 02:46:54 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.159 2014/03/01 15:17:35 gienah Exp $
+
+*octave-3.8.1_rc4-r1 (01 Mar 2014)
+
+ 01 Mar 2014; Mark Wright <gienah@gentoo.org> +octave-3.8.1_rc4-r1.ebuild,
+ -octave-3.8.1_rc3.ebuild, metadata.xml:
+ Thanks to David Kredba for reporting, add gui USE flag to add
+ x11-libs/qscintilla dependency. Remove 3.8.1-rc3 at it is obsoleted by
+ 3.8.1-rc4.
*octave-3.8.1_rc4 (01 Mar 2014)
diff --git a/sci-mathematics/octave/metadata.xml b/sci-mathematics/octave/metadata.xml
index 96894a89c9c3..7778ca576576 100644
--- a/sci-mathematics/octave/metadata.xml
+++ b/sci-mathematics/octave/metadata.xml
@@ -11,6 +11,7 @@
</longdescription>
<use>
<flag name="glpk">Add support for <pkg>sci-libs/glpk</pkg> for linear programming</flag>
+ <flag name="gui">Enable the graphical user interface</flag>
<flag name="jit">(EXPERIMENTAL) enable JIT compiler</flag>
<flag name="qhull">Add support for <pkg>sci-libs/qhull</pkg>, to allow `delaunay', `convhull', and related functions</flag>
<flag name="qrupdate">Add support for <pkg>sci-libs/qrupdate</pkg>for QR and Cholesky update functions</flag>
diff --git a/sci-mathematics/octave/octave-3.8.1_rc3.ebuild b/sci-mathematics/octave/octave-3.8.1_rc4-r1.ebuild
index 4b7fe5e3f491..708c8d40aaf1 100644
--- a/sci-mathematics/octave/octave-3.8.1_rc3.ebuild
+++ b/sci-mathematics/octave/octave-3.8.1_rc4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.8.1_rc3.ebuild,v 1.3 2014/02/24 11:16:44 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.8.1_rc4-r1.ebuild,v 1.1 2014/03/01 15:17:35 gienah Exp $
EAPI=5
@@ -18,7 +18,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu-alpha/octave/${MY_P}.tar.gz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot hdf5 +imagemagick java jit opengl postscript
+IUSE="curl doc fftw +glpk gnuplot gui hdf5 +imagemagick java jit opengl postscript
+qhull +qrupdate readline +sparse static-libs X zlib"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -32,6 +32,7 @@ RDEPEND="
fftw? ( sci-libs/fftw:3.0 )
glpk? ( sci-mathematics/glpk )
gnuplot? ( sci-visualization/gnuplot )
+ gui? ( !hppa? ( !arm? ( x11-libs/qscintilla ) ) )
hdf5? ( sci-libs/hdf5 )
imagemagick? ( || (
media-gfx/graphicsmagick[cxx]
@@ -84,7 +85,7 @@ S="${WORKDIR}/${MY_P}"
pkg_pretend() {
if use qrupdate || use sparse; then
- local blaslib=$(pkg-config --libs-only-l blas | sed -e 's@-l\([^ \t]*\)@lib\1@' | cut -d' ' -f 1)
+ local blaslib=$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's@-l\([^ \t]*\)@lib\1@' | cut -d' ' -f 1)
einfo "Checking dependencies are built with the same blas lib = ${blaslib}"
local usr_lib="${ROOT}usr/$(get_libdir)"
local libs=( )
@@ -161,7 +162,7 @@ src_configure() {
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
$(use_enable doc docs)
$(use_enable java)
- $(use_enable opengl gui)
+ $(use_enable gui gui)
$(use_enable jit)
$(use_enable readline)
$(use_with curl)